gir1.2-appstream-1.0_0.12.0-3ubuntu1_amd64.deb


Advertisement

Description

gir1.2-appstream-1.0 - Library to access AppStream services (introspection data)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Updates Main amd64
Package filename gir1.2-appstream-1.0_0.12.0-3ubuntu1_amd64.deb
Package name gir1.2-appstream-1.0
Package version 0.12.0
Package release 3ubuntu1
Package architecture amd64
Package type deb
Category introspection
Homepage http://www.freedesktop.org/wiki/Distributions/AppStream/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.49 KB
Installed size 64.00 KB
AppStream is a metadata specification, allowing to write metadata for
software projects in a standardized format. This allows software centers
to display useful information for not installed software, as well as
determining software the user might want to install (e.g. to open an
unknown file type or to make missing firmware available).
This package contains introspection data for the AppStream library.

Alternatives

Package Version Architecture Repository
gir1.2-appstream-1.0_0.12.0-3ubuntu1_i386.deb 0.12.0 i386 Ubuntu Updates Main
gir1.2-appstream-1.0_0.12.0-3_i386.deb 0.12.0 i386 Ubuntu Main
gir1.2-appstream-1.0_0.12.0-3_amd64.deb 0.12.0 amd64 Ubuntu Main
gir1.2-appstream-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 >= 1.53
libappstream4 = 0.12.0-3ubuntu1

Replaces

Name Value
gir1.2-appstream << 0.10.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-appstream-1.0_0.12.0-3ubuntu1_amd64.deb
Source Package appstream

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-appstream-1.0 deb package:
    # sudo apt-get install gir1.2-appstream-1.0

Files

Path
/usr/lib/x86_64-linux-gnu/girepository-1.0/AppStream-1.0.typelib
/usr/share/doc/gir1.2-appstream-1.0/changelog.Debian.gz
/usr/share/doc/gir1.2-appstream-1.0/copyright

Changelog

2018-09-14 - Olivier Tilloy <olivier.tilloy@canonical.com>
appstream (0.12.0-3ubuntu1) bionic; urgency=medium
* cache-explicit-variants.patch: fix crash when upgrading from bionic
to cosmic (LP: #1792537)
2018-04-06 - Matthias Klumpp <mak@debian.org>
appstream (0.12.0-3) unstable; urgency=medium
* load-desktop-data.patch: Load desktop file data properly again
2018-04-06 - Matthias Klumpp <mak@debian.org>
appstream (0.12.0-2) unstable; urgency=medium
* Make autopkgtest work again
* Update d/copyright (Closes: #894856)
* icon config: Pull in non-HiDPI config for large icons
if large-icon HiDPI config is installed
2018-04-04 - Matthias Klumpp <mak@debian.org>
appstream (0.12.0-1) unstable; urgency=medium
* New upstream version: 0.12.0
* Drop all patches: Applied upstream
* Update .symbols file
* d/rules: Drop obsolete --parallel flag
* Add APT config snippet packages for an easy way of enabling
icon downloads for different sizes and HiDPI.
2018-01-24 - Matthias Klumpp <mak@debian.org>
appstream (0.11.8-3) unstable; urgency=medium
* appstream-doc breaks older appstream package versions (Closes: #888301)
- The upstream NEWS file accidentally moved from appstream to
appstream-doc, and now that it is there it makes sense to
keep it in the -doc package.
2018-01-24 - Matthias Klumpp <mak@debian.org>
appstream (0.11.8-2) unstable; urgency=medium
* qt-define-locations-nodebug.patch: Allow finding the Qt library
for non-debug builds correctly again (Closes: #888144)
2018-01-22 - Matthias Klumpp <mak@debian.org>
appstream (0.11.8-1) unstable; urgency=medium
* New upstream version: 0.11.8
* Update Vcs-* URLs for Salsa migration
* Bump dh compat level to 11
2017-10-22 - Matthias Klumpp <mak@debian.org>
appstream (0.11.7-1) unstable; urgency=medium
* New upstream version: 0.11.7
* Drop patches: Applied upstream
* Make appstream package suggest curl
* Bump standards version: No changes needed
* Update .symbols file
2017-10-08 - Matthias Klumpp <mak@debian.org>
appstream (0.11.6-2) unstable; urgency=medium
* fix-screenshot-validate-loop.patch: Fix endless loop when
validating screenshots
2017-10-02 - Matthias Klumpp <mak@debian.org>
appstream (0.11.6-1) unstable; urgency=medium
* New upstream version: 0.11.6

See Also

Package Description
gir1.2-avahi-0.6_0.7-3.1ubuntu1.2_amd64.deb GObject introspection data for Avahi
gir1.2-camel-1.2_3.28.5-0ubuntu0.18.04.2_amd64.deb GObject introspection for the Camel library
gir1.2-cogl-1.0_1.22.2-3ubuntu1_amd64.deb GObject introspection data for the Cogl 1.0 library
gir1.2-coglgst-2.0_1.22.2-3ubuntu1_amd64.deb GObject introspection data for the CoglGst 2.0 library
gir1.2-coglpango-1.0_1.22.2-3ubuntu1_amd64.deb GObject introspection data for the CoglPango 1.0 library
gir1.2-dbusmenu-glib-0.4_16.04.1+18.04.20171206-0ubuntu2_amd64.deb typelib file for libdbusmenu-glib4
gir1.2-dbusmenu-gtk3-0.4_16.04.1+18.04.20171206-0ubuntu2_amd64.deb typelib file for libdbusmenu-gtk3-4
gir1.2-ebook-1.2_3.28.5-0ubuntu0.18.04.2_amd64.deb GObject introspection for the EBook library
gir1.2-ebookcontacts-1.2_3.28.5-0ubuntu0.18.04.2_amd64.deb GObject introspection for the EBook Contacts library
gir1.2-edataserver-1.2_3.28.5-0ubuntu0.18.04.2_amd64.deb GObject introspection for the EDataServer library
gir1.2-edataserverui-1.2_3.28.5-0ubuntu0.18.04.2_amd64.deb GObject introspection for the EDataServerUI library
gir1.2-evince-3.0_3.28.4-0ubuntu1.2_amd64.deb GObject introspection data for the evince libraries
gir1.2-fwupd-2.0_1.0.9-0ubuntu2_amd64.deb GObject introspection data for libfwupd
gir1.2-gdm-1.0_3.28.3-0ubuntu18.04.4_amd64.deb GObject introspection data for the GNOME Display Manager
gir1.2-geocodeglib-1.0_3.25.4.1-4ubuntu0.18.04.1_amd64.deb introspection data for geocode-glib library
Advertisement
Advertisement