python-pluggy_0.6.0-1_all.deb


Advertisement

Description

python-pluggy - plugin and hook calling mechanisms for Python - 2.7

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-pluggy_0.6.0-1_all.deb
Package name python-pluggy
Package version 0.6.0
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://pypi.python.org/pypi/pluggy
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 11.91 KB
Installed size 57.00 KB
pluggy is the cristallized core of plugin management as used by some 150
plugins for pytest.
This is the Python 2 library.

Alternatives

Package Version Architecture Repository
python-pluggy_0.6.0-1_all.deb 0.6.0 all Ubuntu Universe
python-pluggy - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-pluggy_0.6.0-1_all.deb
Source Package python-pluggy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pluggy deb package:
    # sudo apt-get install python-pluggy

Files

Path
/usr/lib/python2.7/dist-packages/pluggy/__init__.py
/usr/lib/python2.7/dist-packages/pluggy/callers.py
/usr/lib/python2.7/dist-packages/pluggy-0.6.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pluggy-0.6.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pluggy-0.6.0.egg-info/top_level.txt
/usr/share/doc/python-pluggy/changelog.Debian.gz
/usr/share/doc/python-pluggy/copyright

Changelog

2018-02-26 - Ondřej Nový <onovy@debian.org>
python-pluggy (0.6.0-1) unstable; urgency=medium
* Team upload
[ Barry Warsaw ]
* d/control: Put DPMT in Maintainers and myself in Uploaders.
[ Ondřej Nový ]
* New upstream release
* d/control:
- Set Vcs-* to salsa.debian.org
- Remove useless versioning of depends on Python
* d/copyright: Use https protocol in Format field
* d/watch: Use https protocol
* d/rules: Run tests from whole testing directory
* Bump debhelper compat level to 11
* Add pypy-pluggy binary package
* Standards-Version is 4.1.3 now
* Add autopkgtest-pkg-python testsuite
2016-10-03 - Barry Warsaw <barry@debian.org>
python-pluggy (0.4.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Barry Warsaw ]
* New upstream release.  (Closes: #839386)
* d/control: Bump Standards-Version with no other changes needed.
2015-12-14 - Barry Warsaw <barry@debian.org>
python-pluggy (0.3.1-1) unstable; urgency=medium
* New upstream release.
* d/rules: Update test_pluggy.py location.
2015-05-15 - Barry Warsaw <barry@debian.org>
python-pluggy (0.3.0-1) unstable; urgency=medium
* Initial release. (Closes: #785242)

See Also

Package Description
python-pluginbase_0.5-1_all.deb Support library for building plugins systems (Python 2)
python-plumbum_1.6.5-1_all.deb library for writing shell script-like programs in Python 2
python-plwm_2.6a+20080530-2_all.deb Pointless Window Manager - Python libraries for creating Window Managers
python-pmock_0.3.1+s20140625-3_all.deb Python module for unit testing using mock objects
python-pmw-doc_1.3.2-6build1_all.deb Pmw -- Python MegaWidgets
python-pmw_1.3.2-6build1_all.deb Pmw -- Python MegaWidgets
python-png_0.0.18+ds-2_all.deb Pure Python PNG Reader/Writer (Python 2)
python-pocket-lint_0.5.31-0ubuntu2_all.deb composite linter and style checker
python-pocketsphinx_0.8.0+real5prealpha-1ubuntu2_i386.deb Speech recognition tool - python bindings
python-podcastparser-doc_0.6.2-1_all.deb Simplified, fast RSS parsing library (common documentation)
python-podcastparser_0.6.2-1_all.deb Simplified, fast RSS parsing library (Python 2)
python-polib_1.1.0-3_all.deb Python library to parse and manage gettext catalogs
python-polled-camera_1.11.11-3_all.deb Robot OS polled_camera package - Python
python-popcon_1.5.1_all.deb Python interface to Debian's Popularity Contest (popcon)
python-poppler_0.12.1-10_i386.deb Poppler Python bindings
Advertisement
Advertisement