python-pep8_1.7.1-1ubuntu1_all.deb


Advertisement

Description

python-pep8 - Python PEP 8 code style checker - Python

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-pep8_1.7.1-1ubuntu1_all.deb
Package name python-pep8
Package version 1.7.1
Package release 1ubuntu1
Package architecture all
Package type deb
Category universe/python
Homepage https://pypi.python.org/pypi/pep8
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 30.91 KB
Installed size 134.00 KB
Features a plugin architecture allowing for adding new checks is easily.
Parseable output listing line numbers of the error location.  Consists of
just one Python file, and requires only stdlib.

Alternatives

Package Version Architecture Repository
python-pep8_1.7.1-1ubuntu1_all.deb 1.7.1 all Ubuntu Universe
python-pep8 - - -

Requires

Name Value
python-pkg-resources -
python:any >= 2.7.5-5~
python:any << 2.8

Replaces

Name Value
pep8 << 1.7.0-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-pep8_1.7.1-1ubuntu1_all.deb
Source Package pep8

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pep8 deb package:
    # sudo apt-get install python-pep8

Files

Path
/usr/lib/python2.7/dist-packages/pep8.py
/usr/lib/python2.7/dist-packages/pep8-1.7.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pep8-1.7.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pep8-1.7.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/pep8-1.7.1.egg-info/namespace_packages.txt
/usr/lib/python2.7/dist-packages/pep8-1.7.1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/pep8-1.7.1.egg-info/top_level.txt
/usr/share/doc/python-pep8/changelog.Debian.gz
/usr/share/doc/python-pep8/copyright
/usr/share/python/ns/python-pep8

Changelog

2018-02-08 - Matthias Klose <doko@ubuntu.com>
pep8 (1.7.1-1ubuntu1) bionic; urgency=medium
* Allow stderr output in the autopkg tests (deprecation warning).
2017-10-30 - Sylvestre Ledru <sylvestre@debian.org>
pep8 (1.7.1-1) unstable; urgency=medium
* New upstream release
* Standards-Version updated to 4.1.1
* Silent a test failure wrt the pycodestyle transition
2016-08-23 - Ondřej Nový <onovy@debian.org>
pep8 (1.7.0-4) unstable; urgency=medium
* Team upload.
* d/source/format: Changed to 3.0 (quilt)
* Added dh-python to build depends
2016-08-12 - Ondřej Nový <onovy@debian.org>
pep8 (1.7.0-3) unstable; urgency=medium
* Team upload.
* Fixed homepage (https)
* Fixed VCS URL (https)
* Change directory to $ADTTMP before running Debian tests
* Standards-Version is 3.9.8 now (no change)
* Make pep8 transitional package which provides symlink
pep8 -> pycodestyle (Closes: #823591)
* Fixed typo in debian/pep8.1
* Bumped debhelper compat version to 9
* Fixed Breaks+Replaces for splitting into python-pep8 package
(Closes: #817187)
2016-03-14 - Barry Warsaw <barry@debian.org>
pep8 (1.7.0-2) unstable; urgency=medium
* Team upload.
* d/control: Bump Standards-Version with no other changes necessary.
* d/watch: Use pypi.debian.net redirector.
* d/tests: Added simple DEP-8 tests.
2016-03-02 - Sylvestre Ledru <sylvestre@debian.org>
pep8 (1.7.0-1) unstable; urgency=medium
* Team upload
- Maintainer is ok, doesn't have time anymore
* New upstream release (Closes: #816488)
* Package moved under the Python team umbrella
* Package moved under git maintenance (Closes: #816489)
* Run the test suite when building the package
[ Matthias Klose ]
* Let the pep8 binary use python3 (Closes: #807409)
* Build a python-pep8 package.
* Don't depend on setuptools, pkg-resources is good enough.
2015-07-28 - Daniel Stender <debian@danielstender.com>
pep8 (1.6.2-0.1) unstable; urgency=medium
* Non-maintainer upload.
* New upstream release (Closes: #788117).
2014-07-23 - David Watson <dwatson@debian.org>
pep8 (1.5.7-2) unstable; urgency=medium
* Reinsert missing changelog entry.
2014-07-23 - David Watson <dwatson@debian.org>
pep8 (1.5.7-1) unstable; urgency=medium
[ David Watson ]
* New upstream release. (Closes: #754985)
* Remove python3-all-dev build-dep. (Closes: #751538)
* Update standards version.
[ Michael Prokop ]
* Update manpage. (Closes: #749468)
2013-10-02 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
pep8 (1.4.6-1.1) unstable; urgency=low
* Non-maintainer upload.
* Use python3* dependencies in the python3-pep8 package. (Closes: #721157)

See Also

Package Description
python-periodictable-doc_1.5.0-3_all.deb Extensible periodic table of the elements (common documentation)
python-periodictable_1.5.0-3_all.deb Extensible periodic table of the elements (Python 2)
python-persistent-doc_4.2.2-1build2_all.deb Automatic persistence for Python objects - documentation
python-persistent_4.2.2-1build2_i386.deb Automatic persistence for Python objects
python-petname_2.2-0ubuntu1_all.deb python library for generating pronouncable, memorable, pet names
python-petsc4py-docs_3.7.0-3build2_all.deb Python bindings for PETSc libraries: documentation and examples
python-petsc4py_3.7.0-3build2_i386.deb Python 2 bindings for PETSc libraries
python-pex-cli_1.1.14-2ubuntu2_all.deb transitional dummy package for pex
python-pex-doc_1.1.14-2ubuntu2_all.deb library for generating Python executable zip files
python-pex_1.1.14-2ubuntu2_all.deb library for generating Python executable zip files
python-pexif_0.15-1_all.deb Python EXIF parsing
python-pexpect_4.2.1-1_all.deb Python module for automating interactive applications
python-pg8000-doc_1.10.6-1_all.deb Pure-Python PostgreSQL Driver (documentation)
python-pg8000_1.10.6-1_all.deb Pure-Python PostgreSQL Driver (Python 2)
python-pgmagick_0.7.2-1_i386.deb Yet Another Python wrapper for GraphicsMagick
Advertisement
Advertisement