python-pbgenomicconsensus_2.1.0-1_all.deb


Advertisement

Description

python-pbgenomicconsensus - Pacific Biosciences variant and consensus caller (Python 2)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-pbgenomicconsensus_2.1.0-1_all.deb
Package name python-pbgenomicconsensus
Package version 2.1.0
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/PacificBiosciences/GenomicConsensus
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 43.65 KB
Installed size 326.00 KB
The GenomicConsensus package provides Quiver, Pacific Biosciences'
flagship consensus and variant caller. Quiver is an algorithm that finds
the maximum likelihood template sequence given PacBio reads of the template.
These reads are modeled using a conditional random field approach that
prescribes a probability to a read given a template sequence. In addition to
the base sequence of each read, Quiver uses several additional quality value
covariates that the base caller provides.
This package is part of the SMRTAnalysis suite and provides the Python 2
backend library.

Alternatives

Package Version Architecture Repository
python-pbgenomicconsensus_2.1.0-1_all.deb 2.1.0 all Ubuntu Universe
python-pbgenomicconsensus - - -

Requires

Name Value
python-h5py -
python-numpy -
python-pbcommand -
python-pbconsensuscore -
python-pbcore -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-pbgenomicconsensus_2.1.0-1_all.deb
Source Package pbgenomicconsensus

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pbgenomicconsensus deb package:
    # sudo apt-get install python-pbgenomicconsensus

Files

Path
/usr/lib/python2.7/dist-packages/GenomicConsensus/ResultCollector.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/Worker.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/__init__.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/algorithmSelection.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/consensus.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/main.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/options.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/reference.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/utils.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/variants.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/windows.py
/usr/lib/python2.7/dist-packages/GenomicConsensus-2.1.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/GenomicConsensus-2.1.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/GenomicConsensus-2.1.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/GenomicConsensus-2.1.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/GenomicConsensus-2.1.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/GenomicConsensus/arrow/__init__.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/arrow/arrow.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/arrow/diploid.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/arrow/evidence.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/arrow/model.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/arrow/utils.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/io/VariantsGffWriter.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/io/__init__.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/io/utils.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/plurality/__init__.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/plurality/plurality.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/poa/__init__.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/poa/poa.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/__init__.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/diploid.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/evidence.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/model.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/quiver.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/utils.py
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/resources/2013-03/GenomicConsensus/QuiverParameters.ini
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/resources/2013-05/GenomicConsensus/QuiverParameters.ini
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/resources/2013-09/GenomicConsensus/QuiverParameters.ini
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/resources/2014-03/GenomicConsensus/QuiverParameters.ini
/usr/lib/python2.7/dist-packages/GenomicConsensus/quiver/resources/2014-09/GenomicConsensus/QuiverParameters.ini
/usr/share/doc/python-pbgenomicconsensus/NEWS.Debian.gz
/usr/share/doc/python-pbgenomicconsensus/changelog.Debian.gz
/usr/share/doc/python-pbgenomicconsensus/copyright

Changelog

2017-01-21 - Afif Elghraoui <afif@debian.org>
pbgenomicconsensus (2.1.0-1) unstable; urgency=medium
* New upstream release snapshot
(git 5893b16, 2016-07-19)
* Update manpage for new release
* Adapt test suite for missing pbtestdata
* autopkgtest: make sure to test installed version of the package
* Add python-consensuscore2 to Recommends
* Add lintian override for autopkgtest dependency list
* Install FAQ into docs rather than as a manpage
2016-07-16 - Afif Elghraoui <afif@debian.org>
pbgenomicconsensus (2.0.0+20160420-2) unstable; urgency=low
* Remove convenience script for poa (Closes: #831220)
2016-07-08 - Afif Elghraoui <afif@debian.org>
pbgenomicconsensus (2.0.0+20160420-1) unstable; urgency=medium
* Imported Upstream version 2.0.0+20160420 (upstream git 782a362)
(Closes: #830358)
* Add explicit, versioned build-dependencies
* Install python scripts at build time rather than patching setup.py
* Redo and reorganize manpages
* Bump Standards-Version to 3.9.8
* Suggest consensuscore2
* Install new examples
2016-02-12 - Afif Elghraoui <afif@ghraoui.name>
pbgenomicconsensus (2.0.0+20151210-1) unstable; urgency=medium
* Imported Upstream version 2.0.0+20151210
(corresponds to upstream release tag "smrtanalysis-3.0.2")
* Update patches
* Revise debian/*.install file to not be so specific
* Remove manpage for nonexistent script
* Add dependency on pbcommand
* Add strict dependency on same version of backend library from same package
* Rename manpages to match executables where language extensions dropped upstream
* Add NEWS file to advise users of renamed scripts
* Use secure VCS URLs in debian/control
2015-11-24 - Afif Elghraoui <afif@ghraoui.name>
pbgenomicconsensus (1.1.0-1) unstable; urgency=medium
* Imported Upstream version 1.1.0 (untagged release: bee9a1f from Jun 24)
2015-11-23 - Afif Elghraoui <afif@ghraoui.name>
pbgenomicconsensus (1.0.0-2) unstable; urgency=low
* Fix autopkgtest dependencies.
2015-10-13 - Afif Elghraoui <afif@ghraoui.name>
pbgenomicconsensus (1.0.0-1) unstable; urgency=low
* Initial release (Closes: #794447)

See Also

Package Description
python-pbh5tools-doc_0.8.0+dfsg-5build1_all.deb tools for manipulating HDF5 files produced by Pacific Biosciences (doc)
python-pbkdf2_1.3+20110613.git2a0fb15~ds0-3_all.deb Python RSA PKCS#5 v2.0 module (Python 2)
python-pbsuite-utils_15.8.24+dfsg-2_all.deb software for Pacific Biosciences sequencing data -- Python utilities
python-pcapy_0.10.8-1build1_i386.deb Python interface to the libpcap packet capture library
python-pcl-msgs_0.2.0-6_all.deb Python code for PCL-related Robot OS Messages
python-pcp_4.0.1-1_i386.deb Performance Co-Pilot Python PMAPI module
python-pcs_0.6+debian-0ubuntu3_i386.deb Packet Construction Set for Python
python-pdal_1.6.0+ds-1_i386.deb Point Data Abstraction Library - Python 2 extension
python-pdfkit_0.5.0-1_all.deb Python wrapper for wkhtmltopdf to convert HTML to PDF (Python 2)
python-pdfminer_20140328+dfsg-1_all.deb PDF parser and analyser
python-pdfrw-doc_0.4-1_all.deb PDF file manipulation library (documentation)
python-pdfrw_0.4-1_all.deb PDF file manipulation library (Python 2)
python-pdftools_0.37-4_all.deb PDF document reading classes
python-peak.rules_0.5a1+r2713-1_all.deb generic functions support for Python
python-peak.util.decorators_1.8-4_all.deb version-agnostic decorators support for Python
Advertisement
Advertisement