python-numpydoc_0.7.0-1_all.deb


Advertisement

Description

python-numpydoc - Sphinx extension to support docstrings in Numpy format -- Python 2

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-numpydoc_0.7.0-1_all.deb
Package name python-numpydoc
Package version 0.7.0
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/numpy/numpydoc
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 17.86 KB
Installed size 90.00 KB
This package defines several extensions for the Sphinx documentation
system, shipped in the numpydoc Python package. In particular, these provide
support for the Numpy docstring format in Sphinx.
This package provides the Python 2 version.

Alternatives

Package Version Architecture Repository
python-numpydoc_0.7.0-1_all.deb 0.7.0 all Ubuntu Universe
python-numpydoc - - -

Requires

Name Value
python-jinja2 -
python-sphinx -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-numpydoc_0.7.0-1_all.deb
Source Package numpydoc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-numpydoc deb package:
    # sudo apt-get install python-numpydoc

Files

Path
/usr/lib/python2.7/dist-packages/numpydoc/__init__.py
/usr/lib/python2.7/dist-packages/numpydoc/docscrape.py
/usr/lib/python2.7/dist-packages/numpydoc/docscrape_sphinx.py
/usr/lib/python2.7/dist-packages/numpydoc/numpydoc.py
/usr/lib/python2.7/dist-packages/numpydoc-0.7.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/numpydoc-0.7.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/numpydoc-0.7.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/numpydoc-0.7.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/numpydoc/templates/numpydoc_docstring.rst
/usr/lib/python2.7/dist-packages/numpydoc/tests/test_docscrape.py
/usr/share/doc/python-numpydoc/changelog.Debian.gz
/usr/share/doc/python-numpydoc/copyright

Changelog

2017-07-12 - Ghislain Antony Vaillant <ghisvail@gmail.com>
numpydoc (0.7.0-1) unstable; urgency=medium
* Team upload
[ Ghislain Antony Vaillant ]
* Upgrade watch file to version 4
* Switch from git-dpm to gbp
* New upstream version 0.7.0
* Add new build dependency on jinja2
* Drop explicit dependency on Sphinx
* Drop matplotlib from Suggests
* No more repack required
* Update copyright information
* Use secure Source URI in copyright
* Bump debhelper version to 10, no changes required
* Bump standards version to 4.0.0, no changes required
* Normalize the Vcs-Browser URI
* Run DEP-8 tests for all Python versions
* Add support for the nocheck build profile
2016-12-29 - Ghislain Antony Vaillant <ghisvail@gmail.com>
numpydoc (0.6.0+ds1-1) unstable; urgency=medium
* Team upload
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Ghislain Antony Vaillant ]
* Filter the vendored copy of sphinx.ext.linkcode from the upstream tarball
* New upstream release
* Update copyright file
* Bump versioned depends on Python to 2.7 and 3.4
* Bump standards version to 3.9.8, no changes required
* Add autopkgtest testsuite for the packaging
* Rearrange copyright paragraphs to fix Lintian warnings
* Add missing build dependency on dh-python
* Improve description of the Python 2 binary package
* cme fix dpkg-control:
- Drop versioned dependency on python-all
- Drop versioned dependency on python[,3]-sphinx
- Wrap and sort
* cme fix dpkg-copyright: use HTTPS URI in Format field
2015-10-28 - Denis Laxalde <denis@laxalde.org>
numpydoc (0.5-2) unstable; urgency=medium
* Update debian/copyright to mention all source files and license short
names; switch to BSD license for the Debian packaging to be consistent
with upstream (Closes: #803188).
2015-10-27 - Barry Warsaw <barry@debian.org>
numpydoc (0.5-1) unstable; urgency=medium
* Team upload.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Denis Laxalde ]
* New upstream release (Closes: #801947).
* Build python3 package as it's now supported upstream
* debian/control:
+ Build-Depends on python-setuptools
+ Update Homepage (numpydoc is not anymore within numpy's source tree)
+ Update Standards-Version (no change needed)
* debian/rules: use pybuild.
* Drop clean-setup patch (included upstream)
[ Barry Warsaw ]
* debian/watch: Use the pypi.debian.net redirector.
2012-06-06 - Denis Laxalde <denis@laxalde.org>
numpydoc (0.4-1) unstable; urgency=low
* Initial release (Closes: #559916)

See Also

Package Description
python-nut_2.7.4-5.1ubuntu2_all.deb network UPS tools - Python bindings for NUT server
python-nwdiag_1.0.4+dfsg-1_all.deb generate network-diagram image file from spec-text file
python-nwsclient_1.6.4-8build1_all.deb NetWorkSpaces client for distributed Python applications
python-nwsserver_2.0.0-2build1_all.deb NetWorkSpaces server for distributed applications
python-nxs_4.3.2-svn1921-6_all.deb NeXus scientific data file format - python binding
python-nxt-filer_2.2.2-4_all.deb simple GUI to manage files on a LEGO Mindstorms NXT
python-nxt_2.2.2-4_all.deb python driver/interface/wrapper for the Lego Mindstorms NXT robot
python-oauth2client_4.1.2-3_all.deb OAuth 2.0 client library - Python 2.7
python-obexftp_0.24-5build4_i386.deb Python binding to the object exchange file transfer library
python-objgraph-doc_3.4.0-1_all.deb Module for exploring Python object reference graphs (Documentation)
python-objgraph_3.4.0-1_all.deb Module for exploring Python object reference graphs
python-obsub_0.2-3_all.deb Python module that implements the observer pattern via a decorator
python-odf-doc_1.3.6-2_all.deb documentation and examples for python-odf and python3-odf
python-odf-tools_1.3.6-2_all.deb Python tools to manipulate OpenDocument files
python-odf_1.3.6-2_all.deb Python API to manipulate OpenDocument files
Advertisement
Advertisement