python-notmuch_0.26-1ubuntu3_all.deb


Advertisement

Description

python-notmuch - Python interface to the notmuch mail search and index library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-notmuch_0.26-1ubuntu3_all.deb
Package name python-notmuch
Package version 0.26
Package release 1ubuntu3
Package architecture all
Package type deb
Category universe/python
Homepage https://notmuchmail.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 23.86 KB
Installed size 152.00 KB
Notmuch is a system for indexing, searching, reading, and tagging
large collections of email messages in maildir or mh format. It uses
the Xapian library to provide fast, full-text search with a very
convenient search syntax.
This package provides a Python interface to the notmuch
functionality, directly interfacing with a shared notmuch library.

Alternatives

Package Version Architecture Repository
python-notmuch_0.26-1ubuntu3_all.deb 0.26 all Ubuntu Universe
python-notmuch - - -

Requires

Name Value
libnotmuch5 >= 0.26-1ubuntu3
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-notmuch_0.26-1ubuntu3_all.deb
Source Package notmuch

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-notmuch deb package:
    # sudo apt-get install python-notmuch

Files

Path
/usr/lib/python2.7/dist-packages/notmuch-0.26.egg-info
/usr/lib/python2.7/dist-packages/notmuch/__init__.py
/usr/lib/python2.7/dist-packages/notmuch/compat.py
/usr/lib/python2.7/dist-packages/notmuch/database.py
/usr/lib/python2.7/dist-packages/notmuch/directory.py
/usr/lib/python2.7/dist-packages/notmuch/errors.py
/usr/lib/python2.7/dist-packages/notmuch/filenames.py
/usr/lib/python2.7/dist-packages/notmuch/globals.py
/usr/lib/python2.7/dist-packages/notmuch/message.py
/usr/lib/python2.7/dist-packages/notmuch/messages.py
/usr/lib/python2.7/dist-packages/notmuch/query.py
/usr/lib/python2.7/dist-packages/notmuch/tag.py
/usr/lib/python2.7/dist-packages/notmuch/thread.py
/usr/lib/python2.7/dist-packages/notmuch/threads.py
/usr/lib/python2.7/dist-packages/notmuch/version.py
/usr/share/doc/python-notmuch/NEWS.Debian.gz
/usr/share/doc/python-notmuch/changelog.Debian.gz
/usr/share/doc/python-notmuch/copyright

Changelog

2018-03-01 - Dimitri John Ledkov <xnox@ubuntu.com>
notmuch (0.26-1ubuntu3) bionic; urgency=high
* No change rebuild against ruby-defaults without ruby2.3 support.
2018-02-01 - Matthias Klose <doko@ubuntu.com>
notmuch (0.26-1ubuntu2) bionic; urgency=medium
* No-change rebuild for ruby2.5 update.
2018-01-11 - Gianfranco Costamagna <locutusofborg@debian.org>
notmuch (0.26-1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Run tests but ignore failures on armhf (works on real HW)
see LP: #1707409
2018-01-09 - David Bremner <bremner@debian.org>
notmuch (0.26-1) unstable; urgency=medium
[ Daniel Kahn Gillmor ]
* build against python3-sphinx instead of python-sphinx
* d/changelog: strip trailing whitespace
* move to debhelper 10
* Standards-Version: bump to 4.1.3 (drop priority: extra
from transitional packages)
[ David Bremner ]
* New upstream release (see /usr/share/doc/notmuch/NEWS.gz)
- new command 'notmuch reindex'
- optional indexing of encrypted emails.
- indexing of files with duplicate message-id
* update symbols
2018-01-09 - David Bremner <bremner@debian.org>
notmuch (0.26~rc2-1) experimental; urgency=medium
* Third upstream release candidate
2018-01-01 - David Bremner <bremner@debian.org>
notmuch (0.26~rc1-1) experimental; urgency=medium
* Second upstream release candidate
2017-12-28 - David Bremner <bremner@debian.org>
notmuch (0.26~rc0-1) experimental; urgency=medium
* Upstream release candidate
2017-12-12 - Gianfranco Costamagna <locutusofborg@debian.org>
notmuch (0.25.3-1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Run tests but ignore failures on armhf (works on real HW)
see LP: #1707409
2017-12-08 - David Bremner <bremner@debian.org>
notmuch (0.25.3-1) unstable; urgency=medium
* Upstream bugfix release. Fix for OpenPGP UID validity reporting,
and build failure with GMime 3.0.3+.
* Bug fix: "notmuch FTBFS on Alpha due to broken gdb", thanks to
Michael Cree (Closes: #881028).
2017-11-06 - Gianfranco Costamagna <locutusofborg@debian.org>
notmuch (0.25.2-1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Run tests but ignore failures on armhf (works on real HW)
see LP: #1707409

See Also

Package Description
python-nototools_0~20170925-1_all.deb font support tools from the Noto Fonts project
python-nova-adminclient_0.1.8-0ubuntu2_i386.deb client for administering Openstack Nova
python-nova.lxd_17.0.0-0ubuntu1_all.deb transitional dummy package for python-nova.lxd
python-novnc_0.4+dfsg+1+20131010+gitf68af8af3d-7_all.deb HTML5 VNC client - libraries
python-ns3_3.27+dfsg-1_i386.deb Python binding of ns3
python-nss_1.0.0-1build3_i386.deb Python bindings for Network Security Services (NSS)
python-ntdb_1.0-9build1_i386.deb Python bindings for NTDB
python-ntlm_1.1.0-1_all.deb Python library that provides NTLM support
python-ntplib_0.3.3-1_all.deb Python NTP library (Python 2.x)
python-numba_0.34.0-3_i386.deb native machine code compiler for Python 2
python-numexpr_2.6.4-1_i386.deb Fast numerical array expression evaluator for Python and NumPy
python-numpydoc_0.7.0-1_all.deb Sphinx extension to support docstrings in Numpy format -- Python 2
python-nut_2.7.4-5.1ubuntu2_all.deb network UPS tools - Python bindings for NUT server
python-nwdiag_1.0.4+dfsg-1_all.deb generate network-diagram image file from spec-text file
python-nwsclient_1.6.4-8build1_all.deb NetWorkSpaces client for distributed Python applications
Advertisement
Advertisement