python-ngs_1.3.0-3_i386.deb


Advertisement

Description

python-ngs - Next Generation Sequencing language Bindings (Python bindings)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-ngs_1.3.0-3_i386.deb
Package name python-ngs
Package version 1.3.0
Package release 3
Package architecture i386
Package type deb
Category universe/python
Homepage https://github.com/ncbi/ngs
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 15.27 KB
Installed size 135.00 KB
NGS is a new, domain-specific API for accessing reads, alignments and
pileups produced from Next Generation Sequencing. The API itself is
independent from any particular back-end implementation, and supports
use of multiple back-ends simultaneously. It also provides a library for
building new back-end "engines". The engine for accessing SRA data is
contained within the sister repository ncbi-vdb.
The API is currently expressed in C++, Java and Python languages. The
design makes it possible to maintain a high degree of similarity between
the code in one language and code in another - especially between C++
and Java.
Python bindings.

Alternatives

Package Version Architecture Repository
python-ngs_1.3.0-3_amd64.deb 1.3.0 amd64 Ubuntu Universe
python-ngs - - -

Requires

Name Value
libngs-sdk-dev = 1.3.0-3
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-ngs_1.3.0-3_i386.deb
Source Package ngs-sdk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ngs deb package:
    # sudo apt-get install python-ngs

Files

Path
/usr/lib/python2.7/dist-packages/ngs-1.0.egg-info
/usr/lib/python2.7/dist-packages/ngs/Alignment.py
/usr/lib/python2.7/dist-packages/ngs/AlignmentIterator.py
/usr/lib/python2.7/dist-packages/ngs/ErrorMsg.py
/usr/lib/python2.7/dist-packages/ngs/Fragment.py
/usr/lib/python2.7/dist-packages/ngs/FragmentIterator.py
/usr/lib/python2.7/dist-packages/ngs/LibChecker.py
/usr/lib/python2.7/dist-packages/ngs/LibManager.py
/usr/lib/python2.7/dist-packages/ngs/Package.py
/usr/lib/python2.7/dist-packages/ngs/Pileup.py
/usr/lib/python2.7/dist-packages/ngs/PileupEvent.py
/usr/lib/python2.7/dist-packages/ngs/PileupEventIterator.py
/usr/lib/python2.7/dist-packages/ngs/PileupIterator.py
/usr/lib/python2.7/dist-packages/ngs/Read.py
/usr/lib/python2.7/dist-packages/ngs/ReadCollection.py
/usr/lib/python2.7/dist-packages/ngs/ReadGroup.py
/usr/lib/python2.7/dist-packages/ngs/ReadGroupIterator.py
/usr/lib/python2.7/dist-packages/ngs/ReadIterator.py
/usr/lib/python2.7/dist-packages/ngs/Refcount.py
/usr/lib/python2.7/dist-packages/ngs/Reference.py
/usr/lib/python2.7/dist-packages/ngs/ReferenceIterator.py
/usr/lib/python2.7/dist-packages/ngs/ReferenceSequence.py
/usr/lib/python2.7/dist-packages/ngs/Statistics.py
/usr/lib/python2.7/dist-packages/ngs/String.py
/usr/lib/python2.7/dist-packages/ngs/__init__.py
/usr/share/doc/python-ngs/changelog.Debian.gz
/usr/share/doc/python-ngs/copyright

Changelog

2017-08-28 - Andreas Tille <tille@debian.org>
ngs-sdk (1.3.0-3) unstable; urgency=medium
[ Scott Kitterman ]
* Reduce unneeded build-dep on python3-all-dev to python3-all
Closes: #866514
[ Andreas Tille ]
* debhelper 10
* Standards-Version: 4.1.0 (no changes needed)
* d/rules: do not parse d/changelog
* hardening=+all
2017-04-01 - Andreas Tille <tille@debian.org>
ngs-sdk (1.3.0-2) unstable; urgency=medium
* Fix install dir by using DEB_HOST_MULTIARCH instead of DEB_BUILD_GNU_TYPE
(thanks for the patch to Graham Inggs <ginggs@debian.org>)
Closes: #859257
2016-11-09 - Andreas Tille <tille@debian.org>
ngs-sdk (1.3.0-1) unstable; urgency=medium
* New upstream release
* hardening=+bindnow
2016-08-18 - Olivier Sallou <osallou@debian.org>
ngs-sdk (1.2.5-1) unstable; urgency=medium
* New upstream release 
2016-07-06 - Vincent Danjean <vdanjean@debian.org>
ngs-sdk (1.2.4-2) unstable; urgency=medium
* Add a maven2 pom file for libjava-ngs
2016-06-06 - Andreas Tille <tille@debian.org>
ngs-sdk (1.2.4-1) unstable; urgency=medium
* New upstream version
* Add missing header files to devel package
2016-04-10 - Andreas Tille <tille@debian.org>
ngs-sdk (1.2.3-3) unstable; urgency=medium
[ Andreas Tille ]
* Really get the build working even if build results are moved to the
wrong dir by the build system
* cme fix dpkg-control
* DEP5
[ Steffen Moeller ]
* Depend on default-jdk, not openjdk-8-java, introduce flags to javac
to avoid Java8 bytecode, eliminating a lintian warning.
* Bumped policy to 3.9.7, no changes required.
2016-02-06 - Andreas Tille <tille@debian.org>
ngs-sdk (1.2.3-2) unstable; urgency=medium
* debian/rules: create dynamic library in expected directory
Closes: #813557
* Turn architecture checking for non-Intel architectures from error into
warning that does not cause a failure
Closes: #813559
2016-02-01 - Olivier Sallou <osallou@debian.org>
ngs-sdk (1.2.3-1) unstable; urgency=medium
* Initial release (Closes: #809375)

See Also

Package Description
python-nibabel-doc_2.2.1-1_all.deb documentation for NiBabel
python-nibabel_2.2.1-1_all.deb Python bindings to various neuroimaging data formats
python-nids_0.6.1-1.1_i386.deb Python binding for libnids (aka pynids)
python-nifti_0.20100607.1-4.1_i386.deb Python interface to the NIfTI I/O libraries
python-nine_1.0.0-1_all.deb Python 2 / 3 compatibility, like six, but favouring Python 3
python-nipy-doc_0.4.2-1_all.deb documentation and examples for NiPy
python-nipy-lib_0.4.2-1_i386.deb Analysis of structural and functional neuroimaging data
python-nipy_0.4.2-1_all.deb Analysis of structural and functional neuroimaging data
python-nipype-doc_1.0.0+git69-gdb2670326-1_all.deb Neuroimaging data analysis pipelines in Python -- documentation
python-nipype_1.0.0+git69-gdb2670326-1_all.deb Neuroimaging data analysis pipelines in Python
python-nitime-doc_0.7-1_all.deb timeseries analysis for neuroscience data (nitime) -- documentation
python-nitime_0.7-1_all.deb timeseries analysis for neuroscience data (nitime)
python-nlopt_2.4.2+dfsg-4_i386.deb nonlinear optimization library -- Python bindings
python-nltk_3.2.5-1_all.deb Python libraries for natural language processing
python-nmap_0.6.1-1_all.deb Python interface to the Nmap port scanner
Advertisement
Advertisement