python-mygpoclient_1.8-1_all.deb


Advertisement

Description

python-mygpoclient - Client library for the gpodder.net web service

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-mygpoclient_1.8-1_all.deb
Package name python-mygpoclient
Package version 1.8
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://mygpoclient.readthedocs.io/en/latest/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 24.81 KB
Installed size 154.00 KB
The mygpoclient library allows developers to utilize a
Pythonic interface to the gpodder.net web services (formerly
known as my.gpodder.org).
In addition to the user-specific API endpoints, a public
(non-authenticated) API is provided for searching podcasts
and retrieving the podcast toplist from the server.

Alternatives

Package Version Architecture Repository
python-mygpoclient_1.8-1_all.deb 1.8 all Ubuntu Universe
python-mygpoclient - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-mygpoclient -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-mygpoclient_1.8-1_all.deb
Source Package mygpoclient

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-mygpoclient deb package:
    # sudo apt-get install python-mygpoclient

Files

Path
/usr/bin/mygpo2-bpsync
/usr/bin/mygpo2-list-devices
/usr/bin/mygpo2-simple-client
/usr/lib/python2.7/dist-packages/mygpoclient-1.8.egg-info
/usr/lib/python2.7/dist-packages/mygpoclient/__init__.py
/usr/lib/python2.7/dist-packages/mygpoclient/api.py
/usr/lib/python2.7/dist-packages/mygpoclient/api_test.py
/usr/lib/python2.7/dist-packages/mygpoclient/feeds.py
/usr/lib/python2.7/dist-packages/mygpoclient/http.py
/usr/lib/python2.7/dist-packages/mygpoclient/http_test.py
/usr/lib/python2.7/dist-packages/mygpoclient/json.py
/usr/lib/python2.7/dist-packages/mygpoclient/json_test.py
/usr/lib/python2.7/dist-packages/mygpoclient/locator.py
/usr/lib/python2.7/dist-packages/mygpoclient/locator_test.py
/usr/lib/python2.7/dist-packages/mygpoclient/public.py
/usr/lib/python2.7/dist-packages/mygpoclient/public_test.py
/usr/lib/python2.7/dist-packages/mygpoclient/simple.py
/usr/lib/python2.7/dist-packages/mygpoclient/simple_test.py
/usr/lib/python2.7/dist-packages/mygpoclient/testing.py
/usr/lib/python2.7/dist-packages/mygpoclient/util.py
/usr/share/doc/python-mygpoclient/AUTHORS
/usr/share/doc/python-mygpoclient/NEWS.Debian.gz
/usr/share/doc/python-mygpoclient/NEWS.gz
/usr/share/doc/python-mygpoclient/changelog.Debian.gz
/usr/share/doc/python-mygpoclient/copyright
/usr/share/man/man1/mygpo2-bpsync.1.gz

Changelog

2018-01-06 - tony mancill <tmancill@debian.org>
mygpoclient (1.8-1) unstable; urgency=medium
* New upstream version 1.8
* Update debian/watch to scan Github
* Freshen debian/copyright
* Update Homepage in debian/control
* Bump Standards-Version to 4.1.3
* Update Vcs URLs to be canonical
* Use debhelper 10
* Drop unneeded debian/patches
* Change priority from "extra" to "optional"
* Add python3-mygpoclient package for python3
* Build with pybuild
* Rename CLI utilities in /usr/bin in python-mygpoclient package
* Add build-dep on cmake
* Add NEWS.Debian to document binary renaming
2013-02-25 - tony mancill <tmancill@debian.org>
mygpoclient (1.7-1) unstable; urgency=low
[ Thomas Perl ]
* The "Nuisance Value" release
* debian/control: 
- Bump Standards-Version to 3.9.4
- Remove XS-Python-Version
- Bump debhelper dependency to 9; update debian/compat
* debian/rules: Use the new simple "dh"-based rules format
* Switch to dpkg-source 3.0 (quilt) format
[ tony mancill ]
* Include upstream patch 0001-Add-manpage-for-bpsync
* debian/control
- Add myself to Uploaders
- Add Vcs-Git and Vcs-Browser fields
2012-04-14 - Matthias Klose <doko@ubuntu.com>
mygpoclient (1.4-1build1) precise; urgency=low
* Rebuild to drop python2.6 dependencies and provides.
2010-04-26 - Thomas Perl <thp@thpinfo.com>
mygpoclient (1.4-1) unstable; urgency=low
* The "Do No Harm" release
* See the NEWS file for information on API changes in this version
2010-03-25 - Thomas Perl <thp@thpinfo.com>
mygpoclient (1.2-2) unstable; urgency=low
* Drop Python 2.4 support (we need absolute imports) (Closes: #575212)
2010-03-23 - Thomas Perl <thp@thpinfo.com>
mygpoclient (1.2-1) unstable; urgency=low
* New upstream release
* Update to Debian Policy 3.8.4 (no changes necessary in this package)
2010-01-17 - Thomas Perl <thp@thpinfo.com>
mygpoclient (1.0-1) unstable; urgency=low
* Initial release (Closes: #565691)

See Also

Package Description
python-mysql.connector_2.1.6-1_all.deb pure Python implementation of MySQL Client/Server protocol
python-nacl_1.1.2-1build1_i386.deb Python bindings to libsodium (Python 2)
python-nagiosplugin_1.2.4-1_all.deb Python class library for writing Nagios (Icinga) plugins (Python 2)
python-nameparser_0.5.6-1_all.deb Python module for parsing names into individual components
python-nanomsg_1.0-2build1_i386.deb Python wrapper for nanomsg (Python 2)
python-napalm-base_0.25.0-1_all.deb abstraction layer for multivendor network automation - base package
python-napalm-eos_0.6.1-1_all.deb abstraction layer for multivendor network automation - EOS support
python-napalm-fortios_0.4.0-1_all.deb abstraction layer for multivendor network automation - FortiOS support
python-napalm-ios_0.8.1-1_all.deb abstraction layer for multivendor network automation - IOS support
python-napalm-iosxr_0.5.6-1_all.deb abstraction layer for multivendor network automation - IOS-XR support
python-napalm-junos_0.12.1-1_all.deb abstraction layer for multivendor network automation - JunOS support
python-natsort-doc_4.0.3-2_all.deb Natural sorting for Python (doc)
python-natsort_4.0.3-2_all.deb Natural sorting for python
python-naturalsort_1.0.3-1.1_all.deb Simple natural order sorting API for Python that just works
python-nautilus_1.1-6_i386.deb Python binding for Nautilus components
Advertisement
Advertisement