python-mvpa2-lib_2.6.4-2_i386.deb


Advertisement

Description

python-mvpa2-lib - low-level implementations and bindings for PyMVPA v. 2

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-mvpa2-lib_2.6.4-2_i386.deb
Package name python-mvpa2-lib
Package version 2.6.4
Package release 2
Package architecture i386
Package type deb
Category universe/python
Homepage http://www.pymvpa.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 26.62 KB
Installed size 136.00 KB
This is an add-on package for the PyMVPA framework. It provides a low-level
implementation of an SMLR classifier and custom Python bindings for the LIBSVM
library.
This is a package of a development snapshot. The latest released version is
provided by the python-mvpa-lib package.

Alternatives

Package Version Architecture Repository
python-mvpa2-lib_2.6.5-1~nd18.04+1_i386.deb 2.6.5 i386 NeuroDebian Main
python-mvpa2-lib_2.6.5-1~nd18.04+1_amd64.deb 2.6.5 amd64 NeuroDebian Main
python-mvpa2-lib_2.6.4-2_amd64.deb 2.6.4 amd64 Ubuntu Universe
python-mvpa2-lib - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libstdc++6 >= 5
libsvm3 -
python >= 2.7~
python << 2.8
python-numpy >= 1:1.13.1
python-numpy-abi9 -
python:any << 2.8
python:any >= 2.7~

Provides

Name Value
python2.7-mvpa2-lib -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-mvpa2-lib_2.6.4-2_i386.deb
Source Package pymvpa2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-mvpa2-lib deb package:
    # sudo apt-get install python-mvpa2-lib

Files

Path
/usr/lib/python2.7/dist-packages/mvpa2/clfs/libsmlrc/smlrc.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/mvpa2/clfs/libsmlrc/smlrc.so
/usr/lib/python2.7/dist-packages/mvpa2/clfs/libsvmc/_svmc.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/mvpa2/clfs/libsvmc/_svmc.so
/usr/share/doc/python-mvpa2-lib/changelog.Debian.gz
/usr/share/doc/python-mvpa2-lib/copyright

Changelog

2018-01-31 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.4-2) unstable; urgency=medium
* patches to fortify scatter code and tests against degenerate cases which
reveal themselves on exotic platforms (Now should really Closes: #880793).
ref: https://github.com/numpy/numpy/issues/10496
2018-01-29 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.4-1) unstable; urgency=medium
* Fresh upstream bugfix release
* Manually create simple smlrc.so and svmc.so symlinks to multiarch .so.
Apparently numpy.ctypeslib.load_library is not creating a valid multiarch
suffix to match the one created by dh_python2
* debian/rules
- run tests under fixed MVPA_SEED=1 to avoid surprises, so should
resolve spurious FTBFS (tried to close #880793)
2017-11-03 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.3-1) unstable; urgency=medium
* Fresh bugfix release -- primarily just tests
2017-11-01 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.2-1) unstable; urgency=medium
* Fresh upstream bugfix release
- dropping all debian/patches/00* picked up from upstream
2017-10-17 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.1-2) unstable; urgency=medium
* Upload to unstable
* debian/patches/00* 
- addressing for changes in sphinx
- addressing for more strict numpy 1.13.1
* debian/control
- boosted policy to 4.0.0
- boosted compat/debhelper to 9
- added dh-python to build-depends
2017-04-20 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.1-1) experimental; urgency=medium
* Fresh upstream (primarily minor bugfix) release
- python-mock into build-depends
* debian/rules
- invoke tests via  python -m nose  since otherwise lead to some
weird infinite recursions etc
2016-08-26 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.6.0-1) unstable; urgency=medium
* Fresh upstream release
- variety of bugfixes, e.g. compatibility with scipy 0.17.1, nibabel 2.1
* debian/control
- policy boost to 3.9.8
2016-07-08 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.5.0-2) unstable; urgency=medium
* debian/control
- swap order of swig2.0 and swig in build-depends to please buildds
(Closes: #830394)
2016-05-11 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.5.0-1) unstable; urgency=medium
* Fresh upstream feature release
2016-03-14 - Yaroslav Halchenko <debian@onerussian.com>
pymvpa2 (2.4.3-1) unstable; urgency=medium
* debian/control
- recommends python-duecredit
- do not require (absent atm) optional statsmodels on s390x

See Also

Package Description
python-mvpa2_2.6.4-2_all.deb multivariate pattern analysis with Python v. 2
python-mwparserfromhell_0.4.2-1.1build3_i386.deb Outrageously powerful parser for MediaWiki wikicode
python-myghty_1.1-6_all.deb Python based templating framework originally based on HTML::Mason
python-myghtyutils_0.52-5_all.deb Set of utility classes used by Myghty templating
python-mygpoclient_1.8-1_all.deb Client library for the gpodder.net web service
python-mysql.connector_2.1.6-1_all.deb pure Python implementation of MySQL Client/Server protocol
python-nacl_1.1.2-1build1_i386.deb Python bindings to libsodium (Python 2)
python-nagiosplugin_1.2.4-1_all.deb Python class library for writing Nagios (Icinga) plugins (Python 2)
python-nameparser_0.5.6-1_all.deb Python module for parsing names into individual components
python-nanomsg_1.0-2build1_i386.deb Python wrapper for nanomsg (Python 2)
python-napalm-base_0.25.0-1_all.deb abstraction layer for multivendor network automation - base package
python-napalm-eos_0.6.1-1_all.deb abstraction layer for multivendor network automation - EOS support
python-napalm-fortios_0.4.0-1_all.deb abstraction layer for multivendor network automation - FortiOS support
python-napalm-ios_0.8.1-1_all.deb abstraction layer for multivendor network automation - IOS support
python-napalm-iosxr_0.5.6-1_all.deb abstraction layer for multivendor network automation - IOS-XR support
Advertisement
Advertisement