python-mpmath_1.0.0-1_all.deb


Advertisement

Description

python-mpmath - library for arbitrary-precision floating-point arithmetic

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-mpmath_1.0.0-1_all.deb
Package name python-mpmath
Package version 1.0.0
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage http://www.mpmath.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 386.57 KB
Installed size 1.90 MB
Mpmath is a pure-Python library for multiprecision floating-point
arithmetic. It provides an extensive set of transcendental functions,
unlimited exponent sizes, complex numbers, interval arithmetic,
numerical integration and differentiation, root-finding, linear
algebra, and much more. Almost any calculation can be performed just
as well at 10-digit or 1000-digit precision, and in many cases mpmath
implements asymptotically fast algorithms that scale well for
extremely high precision work.
If available, mpmath will (optionally) use gmpy to speed up high
precision operations. If matplotlib is available, mpmath also
provides a convenient plotting interface.
Its features include:
* Fair performance -- typically 10-100x faster than Python's
decimal library
* Transcendental functions -- all functions from Python's math and
cmath modules, plus a few more like gamma, factorial, erf
* Complex numbers -- with support for transcendental functions
* Directed rounding -- floor, ceiling, down, up, half-down,
half-up, half-even
* Unlimited exponents -- no overflow or underflow

Alternatives

Package Version Architecture Repository
python-mpmath_1.0.0-1_all.deb 1.0.0 all Ubuntu Universe
python-mpmath - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-mpmath_1.0.0-1_all.deb
Source Package mpmath

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-mpmath deb package:
    # sudo apt-get install python-mpmath

Files

Path
/usr/lib/python2.7/dist-packages/mpmath-1.0.0.egg-info
/usr/lib/python2.7/dist-packages/mpmath/__init__.py
/usr/lib/python2.7/dist-packages/mpmath/conftest.py
/usr/lib/python2.7/dist-packages/mpmath/ctx_base.py
/usr/lib/python2.7/dist-packages/mpmath/ctx_fp.py
/usr/lib/python2.7/dist-packages/mpmath/ctx_iv.py
/usr/lib/python2.7/dist-packages/mpmath/ctx_mp.py
/usr/lib/python2.7/dist-packages/mpmath/ctx_mp_python.py
/usr/lib/python2.7/dist-packages/mpmath/function_docs.py
/usr/lib/python2.7/dist-packages/mpmath/identification.py
/usr/lib/python2.7/dist-packages/mpmath/math2.py
/usr/lib/python2.7/dist-packages/mpmath/rational.py
/usr/lib/python2.7/dist-packages/mpmath/usertools.py
/usr/lib/python2.7/dist-packages/mpmath/visualization.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/__init__.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/approximation.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/calculus.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/differentiation.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/extrapolation.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/inverselaplace.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/odes.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/optimization.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/polynomials.py
/usr/lib/python2.7/dist-packages/mpmath/calculus/quadrature.py
/usr/lib/python2.7/dist-packages/mpmath/functions/__init__.py
/usr/lib/python2.7/dist-packages/mpmath/functions/bessel.py
/usr/lib/python2.7/dist-packages/mpmath/functions/elliptic.py
/usr/lib/python2.7/dist-packages/mpmath/functions/expintegrals.py
/usr/lib/python2.7/dist-packages/mpmath/functions/factorials.py
/usr/lib/python2.7/dist-packages/mpmath/functions/functions.py
/usr/lib/python2.7/dist-packages/mpmath/functions/hypergeometric.py
/usr/lib/python2.7/dist-packages/mpmath/functions/orthogonal.py
/usr/lib/python2.7/dist-packages/mpmath/functions/qfunctions.py
/usr/lib/python2.7/dist-packages/mpmath/functions/rszeta.py
/usr/lib/python2.7/dist-packages/mpmath/functions/theta.py
/usr/lib/python2.7/dist-packages/mpmath/functions/zeta.py
/usr/lib/python2.7/dist-packages/mpmath/functions/zetazeros.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/__init__.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/backend.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/gammazeta.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/libelefun.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/libhyper.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/libintmath.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/libmpc.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/libmpf.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/libmpi.py
/usr/lib/python2.7/dist-packages/mpmath/libmp/six.py
/usr/lib/python2.7/dist-packages/mpmath/matrices/__init__.py
/usr/lib/python2.7/dist-packages/mpmath/matrices/calculus.py
/usr/lib/python2.7/dist-packages/mpmath/matrices/eigen.py
/usr/lib/python2.7/dist-packages/mpmath/matrices/eigen_symmetric.py
/usr/lib/python2.7/dist-packages/mpmath/matrices/linalg.py
/usr/lib/python2.7/dist-packages/mpmath/matrices/matrices.py
/usr/lib/python2.7/dist-packages/mpmath/tests/__init__.py
/usr/lib/python2.7/dist-packages/mpmath/tests/extratest_bessel.py
/usr/lib/python2.7/dist-packages/mpmath/tests/extratest_zeta.py
/usr/lib/python2.7/dist-packages/mpmath/tests/runtests.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_basic_ops.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_bitwise.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_calculus.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_compatibility.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_convert.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_diff.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_division.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_eigen.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_eigen_symmetric.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_elliptic.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_fp.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_functions.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_functions2.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_gammazeta.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_hp.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_identify.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_interval.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_levin.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_linalg.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_matrices.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_mpmath.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_ode.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_pickle.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_power.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_quad.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_rootfinding.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_special.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_str.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_summation.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_trig.py
/usr/lib/python2.7/dist-packages/mpmath/tests/test_visualization.py
/usr/share/doc/python-mpmath/changelog.Debian.gz
/usr/share/doc/python-mpmath/copyright

Changelog

2017-11-26 - Sandro Tosi <morph@debian.org>
mpmath (1.0.0-1) unstable; urgency=medium
[ Sandro Tosi ]
* New upstream release
* debian/watch
- update to use github tags, so the tarball will contain code and doc source
* debian/copyright
- extend packaging copyright years
- update upstream copyright years
* debian/compat
- bump to compat level 9
* debian/control
- bump Standards-Version to 4.1.1 (no changes needed)
- add dh-python to b-d
* Use python3-sphinx to build doc
* debian/rules
- run tests from inside the mpmath directory
[ Ondřej Nový ]
* Fixed VCS URL (https)
* d/copyright: Changed licence shortname BSD -> BSD-3-clause
2015-08-15 - Sandro Tosi <morph@debian.org>
mpmath (0.19-3) unstable; urgency=medium
* upload to unstable
2015-04-10 - Sandro Tosi <morph@debian.org>
mpmath (0.19-2) experimental; urgency=medium
* debian/control
- switch me to Maintainer (team to Uploaders)
- bump Standards-Version to 3.9.6 (no changes needed)
* debian/watch
- use PyPI redirector
* debian/patches/93b3e5ed85feeafcfeb36f3d90524c57871daba3.patch
- fix polyroots with error=True; thanks to Richard B. Kreckel for the
report; Closes: #781222
2014-07-27 - Sandro Tosi <morph@debian.org>
mpmath (0.19-1) unstable; urgency=medium
* New upstream release
* debian/control
- replace b-d on python-codespeak-lib to python-py; thanks to Michael
Tautschnig for the report; Closes: #749435
* debian/{control, copyright}
- update upstream homepage URL
* debian/watch
- update download URL
* debian/copyright
- switch to DEP-5 format
- updated upstream & packaging copyright years
* Switch to dh_python2
2014-01-01 - Sandro Tosi <morph@debian.org>
mpmath (0.18-1) unstable; urgency=low
* New upstream release
* debian/control
- switch to gmpy2; thanks to Martin Kelly for the report; Closes: #731205
- bump Standards-Version to 3.9.5 (no changes needed)
* debian/watch
- changed to new download location
* debian/copyright
- extended upstream and packaging copyright years
2013-09-29 - Sandro Tosi <morph@debian.org>
mpmath (0.17-3) unstable; urgency=low
[ Sandro Tosi ]
* debian/copyright
- extend packaging copyright years
* debian/source/format
- switch to '3.0 (quilt)' source format
* debian/README.source
- removed, not needed anymore
* debian/control
- bump Standards-Version to 3.9.4 (no changes needed)
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2012-08-19 - Sandro Tosi <morph@debian.org>
mpmath (0.17-2) experimental; urgency=low
* debian/control
- remove Ondrej from Uploaders; thanks!
- removed DM-U-A flag
- bump Standards-Version to 3.9.3 (no changes needed)
- add python-pytest to b-d-i, needed to run tests
* debian/{control, rules}
- use dh_sphinxdoc
- convert to dh sequencer
- provide the Python 3 package; Closes: #624101
* debian/rules
- remove files not compatible with python2 from python-mpmath package;
Closes: #679200, #624105
2011-04-25 - Sandro Tosi <morph@debian.org>
mpmath (0.17-1) unstable; urgency=low
* New upstream release
* debian/rules
- don't compress objects.inv; thanks to Michael Fladischer for the report;
Closes: #608762
- use --install-layout=deb when installing
* debian/control
- bump Standards-Version to 3.9.2 (no changes needed)
- set XS-Python-Version to 'all'
2010-12-14 - Sandro Tosi <morph@debian.org>
mpmath (0.16-1) experimental; urgency=low
* New upstream release
* debian/watch
- updated to fetch the full (code+doc) tarball
* debian/control
- bump Standards-Version to 3.9.1 (no changes needed)
2010-06-21 - Sandro Tosi <morph@debian.org>
mpmath (0.15-1) unstable; urgency=low
[ Sameer Rahmani ]
* Watch file fixed.
[ Sandro Tosi ]
* New upstream release
* debian/control
- added texlive-latex-extra to b-d, needed to build documentation

See Also

Package Description
python-mpop_1.5.0-1ubuntu2_all.deb Meteorological Post-Processing Package (MPoP)
python-mrjob_0.3.3.2-1_all.deb MapReduce framework for writing and running Hadoop Streaming jobs
python-mrtparse_1.6-1_all.deb read and analyze the MRT format data (Python 2.x module)
python-msrest_0.4.14-1_all.deb AutoRest Swagger generator for Python 2.x
python-msrestazure_0.4.13-1_all.deb Runtime library for AutoRest generated Python 2.x clients
python-mtbl_0.4.0-1_i386.deb immutable sorted string table library (Python bindings)
python-multi-key-dict_2.0.3-1_all.deb multi key dictionary implementation - Python 2.7
python-multicorn_1.3.4-1_i386.deb multicorn utility module for postgresql-X.Y-python-multicorn
python-multipartposthandler_0.1.0-2_all.deb handler for urllib2 to enable multipart form uploading
python-multipletau-doc_0.1.9+ds-1_all.deb documentation for multipletau Python module
python-multipletau_0.1.9+ds-1_all.deb multiple-tau algorithm for Python/NumPy
python-munkres_1.0.12+ds-1_all.deb munkres algorithm for the Assignment Problem - Python 2.x library
python-murano-dashboard_5.0.0-0ubuntu1.1_all.deb cloud-ready application catalog - dashboard plugin
python-murano-pkg-check-doc_0.3.0-0ubuntu4_all.deb Murano package validator (common documentation)
python-murano-pkg-check_0.3.0-0ubuntu4_all.deb Murano package validator (Python 2)
Advertisement
Advertisement