python-mailutils_3.4-1_i386.deb


Advertisement

Description

python-mailutils - GNU Mail abstraction library (Python interface)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-mailutils_3.4-1_i386.deb
Package name python-mailutils
Package version 3.4
Package release 1
Package architecture i386
Package type deb
Category universe/python
Homepage https://www.gnu.org/software/mailutils/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.48 KB
Installed size 531.00 KB
GNU Mailutils is a rich and powerful protocol-independent mail framework.
It contains a series of useful mail libraries, clients, and servers.
This is the Python interface to the Mailutils library.

Alternatives

Package Version Architecture Repository
python-mailutils_3.4-1_amd64.deb 3.4 amd64 Ubuntu Universe
python-mailutils - - -

Requires

Name Value
libc6 >= 2.1.3
libmailutils5 -
mailutils-common = 1:3.4-1
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-mailutils -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-mailutils_3.4-1_i386.deb
Source Package mailutils

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-mailutils deb package:
    # sudo apt-get install python-mailutils

Files

Path
/usr/lib/python2.7/dist-packages/mailutils/__init__.py
/usr/lib/python2.7/dist-packages/mailutils/address.py
/usr/lib/python2.7/dist-packages/mailutils/attribute.py
/usr/lib/python2.7/dist-packages/mailutils/auth.py
/usr/lib/python2.7/dist-packages/mailutils/body.py
/usr/lib/python2.7/dist-packages/mailutils/c_api.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/mailutils/envelope.py
/usr/lib/python2.7/dist-packages/mailutils/error.py
/usr/lib/python2.7/dist-packages/mailutils/filter.py
/usr/lib/python2.7/dist-packages/mailutils/folder.py
/usr/lib/python2.7/dist-packages/mailutils/header.py
/usr/lib/python2.7/dist-packages/mailutils/mailbox.py
/usr/lib/python2.7/dist-packages/mailutils/mailcap.py
/usr/lib/python2.7/dist-packages/mailutils/mailer.py
/usr/lib/python2.7/dist-packages/mailutils/message.py
/usr/lib/python2.7/dist-packages/mailutils/mime.py
/usr/lib/python2.7/dist-packages/mailutils/nls.py
/usr/lib/python2.7/dist-packages/mailutils/registrar.py
/usr/lib/python2.7/dist-packages/mailutils/secret.py
/usr/lib/python2.7/dist-packages/mailutils/sieve.py
/usr/lib/python2.7/dist-packages/mailutils/stream.py
/usr/lib/python2.7/dist-packages/mailutils/url.py
/usr/lib/python2.7/dist-packages/mailutils/util.py
/usr/share/doc/python-mailutils/AUTHORS
/usr/share/doc/python-mailutils/NEWS.gz
/usr/share/doc/python-mailutils/README.gz
/usr/share/doc/python-mailutils/THANKS
/usr/share/doc/python-mailutils/TODO
/usr/share/doc/python-mailutils/changelog.Debian.gz
/usr/share/doc/python-mailutils/copyright

Changelog

2017-11-07 - Jordi Mallach <jordi@debian.org>
mailutils (1:3.4-1) unstable; urgency=medium
* New upstream release.
2017-10-27 - Jordi Mallach <jordi@debian.org>
mailutils (1:3.3-1) unstable; urgency=medium
* New upstream release.
* Make mailutils-guile depend on the non-virtual guile-2.0 as first option.
* Add explicit --with-guile to configure as the build should fail if guile
support is left out.
* Remove all patches, all are obsolete with the new upstream.
* Add patch to fix a -Wformat-security FTBFS in mimeview/lexer.l.
* Remove all references to sieve2scm, which has removed upstream.
* Use HTTPS URLs in manpages, copyright file and watch.
* Update Standards-Version to 4.1.1.
2017-09-11 - Jordi Mallach <jordi@debian.org>
mailutils (1:3.2-1) unstable; urgency=medium
* New upstream release.
* Oops, correct Vcs-Svn to read Vcs-Git instead.
* Drop tokyocabinet_dependencies.patch, guile_bindir.patch, readline.patch,
10_guile-snarf-CPP.patch, sieve2scm_help_output.patch, hurd.patch: all
merged upstream.
* Update texinfo_fixes.patch, part of it has been merged upstream too.
* Add mu_assoc_ref_fix.patch: Remove a stray call to mu_assoc_ref.
* Add imap4d_list_format-security.patch: fix a build failure when building
with -Werror=format-security.
* Add missing Build-Dependency on dh-python.
* Update shlibs.
* Remove obsolete configure flag and associated comment in README.Debian.
2016-12-25 - Jordi Mallach <jordi@debian.org>
mailutils (1:3.1.1-1) unstable; urgency=medium
* New upstream release.
* Drop libmailutils_format-security_ftbfs.patch: merged upstream.
* Point watch file to ftp.gnu.org, to track stable releases.
2016-12-12 - Jordi Mallach <jordi@debian.org>
mailutils (1:3.0-1) unstable; urgency=medium
* New upstream stable release.
* Acknowledge 2.99.99-1.1 NMU.
* Add debian/gbp.conf to set pristine-tar = true.
* Update Vcs-* URLs after a svn → git migration and moving to collab-maint.
* Update packaging for soname bump to libmailutils5.
* Drop fix_linking.patch, obsolete.
* Refresh gettext_update.patch, with the result of a gettextize -f call.
* Update libmysqlclient-dev dependencies to default-libmysqlclient-dev
(closes: #845873).
* Bump Standards-Version to 3.9.8.
* Update to debhelper compat v10, and drop explicit Build-Deps on autopoint
and dh-autoreconf.
* Do not cleanup testsuite/testsuite on clean anymore.
* Add libmailutils_format-security_ftbfs.patch: fix a build failure caused
by a format string error when using -Wformat-security.
* Drop all obsolete Conflicts and Replaces.
* Fix whatis entries for mailutils and mailutils-config.
* Drop mailutils-dbg and ensure an automatic migration to -dbgsym by
passing --dbgsym-migration to dh_strip.
2016-08-09 - Mattia Rizzolo <mattia@debian.org>
mailutils (1:2.99.99-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Add patch from James Clarke to fix build on hurd-i386.  Closes: #828904
2016-02-01 - Jordi Mallach <jordi@debian.org>
mailutils (1:2.99.99-1) unstable; urgency=medium
* New upstream release.
- Replaces obsolete GnuTLS code with defaults, fixing FTBFS and
usage of unsafe protocols and cyphers (closes: #812848)
* Refresh debian/patches/texinfo_fixes.patch.
* Drop pop3d_auth_crash.patch, fixed upstream.
* Add gettext_update.patch, to workaround gettext infrastructure mismatch.
* Add fix_linking.patch: from git, fix linking of libmuaux.
* Update shlibs for libmailutils4.
* Install libmu_argp.so.4 (closes: #789149).
* mu-tool has been renamed to mailutils. Update accordingly.
* Generate a mailutils-config(1) manpage.
* Add signature check support to watch, and bump to version 4.
* Add Sergey's GnuPG public key to debian/upstream/signing-key.asc.
* Make Vcs-Browser field use https (lintian).
* Add guile as an alternate dependency to guile-2.0.

See Also

Package Description
python-mandrill_1.0.57-1_all.deb CLI client and Python API library for Mandrill
python-manila-ui_2.13.0-0ubuntu1_all.deb OpenStack shared file system as a service - Dashboard plugin
python-manila_6.0.0-0ubuntu1_all.deb Manila Python libraries
python-manuel_1.8.0-5_all.deb Python library for testable documents and documented tests
python-map-msgs_1.13.0-5_all.deb Python code for map-related ROS Messages
python-mapbox-vector-tile_0.5.0+ds-5_all.deb Mapbox Vector Tile library for Python 2
python-mapi_8.5.5-0ubuntu1_i386.deb Complete and feature rich groupware solution - Python MAPI bindings
python-mapnik_0.0~20180130-804a7947d-1_i386.deb Python 2 interface to the mapnik library
python-mapproxy_1.11.0-1_all.deb open source proxy for geospatial data - Python 2 module
python-mapscript_7.0.7-1build2_i386.deb Python library for MapServer
python-marathon-doc_0.8.10-0ubuntu1_all.deb Library interface to Mesos marathon Rest API (common docuemtation)
python-marathon_0.8.10-0ubuntu1_all.deb Library interface to Mesos marathon Rest API (Python 2)
python-marisa_0.2.4-8build12_i386.deb Python bindings for MARISA
python-markdown-doc_2.6.9-1_all.deb text-to-HTML conversion library/tool (documentation)
python-markdown_2.6.9-1_all.deb text-to-HTML conversion library/tool (Python 2 version)
Advertisement
Advertisement