python-magic_0.4.15-1_all.deb


Advertisement

Description

python-magic - python2 interface to the libmagic file type identification library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-magic_0.4.15-1_all.deb
Package name python-magic
Package version 0.4.15
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/ahupp/python-magic/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.98 KB
Installed size 42.00 KB
python-magic is a Python interface to the libmagic file type
identification library. libmagic identifies file types by checking
their headers according to a predefined list of file types. This
functionality is exposed to the command line by the Unix command file.
This package provides the Python 2 version of the python-magic module.

Alternatives

Package Version Architecture Repository
python-magic_0.4.15-1_all.deb 0.4.15 all Ubuntu Universe
python-magic - - -

Requires

Name Value
libmagic1 -
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-magic -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-magic_0.4.15-1_all.deb
Source Package python-magic

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-magic deb package:
    # sudo apt-get install python-magic

Files

Path
/usr/lib/python2.7/dist-packages/magic/__init__.py
/usr/lib/python2.7/dist-packages/magic/compat.py
/usr/lib/python2.7/dist-packages/python_magic-0.4.16.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/python_magic-0.4.16.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/python_magic-0.4.16.egg-info/top_level.txt
/usr/share/doc/python-magic/changelog.Debian.gz
/usr/share/doc/python-magic/copyright

Changelog

2018-02-04 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
python-magic (2:0.4.15-1) unstable; urgency=low
* Upload to unstable
2018-01-19 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
python-magic (2:0.4.15-1~exp2) experimental; urgency=medium
* Update libmagic compatibility to the latest upstream commit
2018-01-08 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
python-magic (2:0.4.15-1~exp1) experimental; urgency=medium
* Initial packaging. Closes: #877849
* Upload to experimental to ease tests of packages that use
python-magic from src:file

See Also

Package Description
python-magics++_3.0.0-1_i386.deb python support for Magics++
python-magnum_6.1.0-0ubuntu1_all.deb OpenStack containers as a service - Python library
python-mailer_0.8.1-2_all.deb Python module that simplifies sending email (Python 2)
python-mailmanclient-doc_3.1.1-5_all.deb Python bindings for Mailman3 REST API (Documentation)
python-mailmanclient_3.1.1-5_all.deb Python bindings for Mailman3 REST API (Python 2 version)
python-mailutils_3.4-1_i386.deb GNU Mail abstraction library (Python interface)
python-mandrill_1.0.57-1_all.deb CLI client and Python API library for Mandrill
python-manila-ui_2.13.0-0ubuntu1_all.deb OpenStack shared file system as a service - Dashboard plugin
python-manila_6.0.0-0ubuntu1_all.deb Manila Python libraries
python-manuel_1.8.0-5_all.deb Python library for testable documents and documented tests
python-map-msgs_1.13.0-5_all.deb Python code for map-related ROS Messages
python-mapbox-vector-tile_0.5.0+ds-5_all.deb Mapbox Vector Tile library for Python 2
python-mapi_8.5.5-0ubuntu1_i386.deb Complete and feature rich groupware solution - Python MAPI bindings
python-mapnik_0.0~20180130-804a7947d-1_i386.deb Python 2 interface to the mapnik library
python-mapproxy_1.11.0-1_all.deb open source proxy for geospatial data - Python 2 module
Advertisement
Advertisement