python-lldb-5.0_5.0.1-4_i386.deb


Advertisement

Description

python-lldb-5.0 - Next generation, high-performance debugger, python lib

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-lldb-5.0_5.0.1-4_i386.deb
Package name python-lldb-5.0
Package version 5.0.1
Package release 4
Package architecture i386
Package type deb
Category universe/python
Homepage http://www.llvm.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 90.31 KB
Installed size 731.00 KB
LLDB is a next generation, high-performance debugger. It is built as a set of
reusable components which highly leverage existing libraries in the larger LLVM
Project, such as the Clang expression parser and LLVM disassembler.
This binding package provides access to lldb.

Alternatives

Package Version Architecture Repository
python-lldb-5.0_5.0.1-4_amd64.deb 5.0.1 amd64 Ubuntu Universe
python-lldb-5.0 - - -

Requires

Name Value
liblldb-5.0-dev -
python -
python-six -

Provides

Name Value
python-lldb-x.y -

Conflicts

Name Value
python-lldb-3.8 -
python-lldb-3.9 -
python-lldb-x.y -

Replaces

Name Value
python-lldb-x.y -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-lldb-5.0_5.0.1-4_i386.deb
Source Package llvm-toolchain-5.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-lldb-5.0 deb package:
    # sudo apt-get install python-lldb-5.0

Files

Path
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/__init__.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/_lldb.so
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/embedded_interpreter.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/libLLVM-5.0.1.so.1
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/libLLVM-5.0.so.1
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/lldb-argdumper
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/Logger.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/__init__.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/attrib_fromdict.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/cache.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/metrics.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/synth.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/cpp/__init__.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/cpp/gnu_libstdcpp.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/formatters/cpp/libcxx.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/runtime/__init__.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/utils/__init__.py
/usr/lib/llvm-5.0/lib/python2.7/site-packages/lldb/utils/symbolication.py
/usr/lib/python2.7/dist-packages/lldb
/usr/share/doc/python-lldb-5.0/NEWS.Debian.gz
/usr/share/doc/python-lldb-5.0/changelog.Debian.gz
/usr/share/doc/python-lldb-5.0/copyright

Changelog

2018-03-21 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1-4) unstable; urgency=medium
* Fix the FTBFS with glibc 2.27
2018-03-20 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1-3) unstable; urgency=medium
* Move the VCS to git.
Many thanks to James Clarke for doing the conversion
* Ignore the test tools/gold/X86/comdat.ll
until https://bugs.llvm.org/show_bug.cgi?id=36166
is fixed.
Will fix the ftbfs on x86
* Create the directory before having the manpages generated
* clang-tidy-5.0: depends on libclang-common-5.0-dev
(Closes: #891999)
* clang-tidy-5.0 also depends on clang-tools-5.0 for, at least
clang-apply-replacements (Closes: #893600)
* Update of the clang-tools-X.Y description
* Fix the libclang1-X.Y.symbols.in file (two spaces)
(Closes: #889035)
[ John Paul Adrian Glaubitz ]
* Add proposed upstream patch by James Clarke to add the
missing __tls_get_addr symbol to the symbol table for
TLS calls on SPARC (Closes: #890401)
[ James Clarke ]
* Disable LLDB on powerpcspe
2017-12-22 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1-2) unstable; urgency=medium
* Bring back the libedit support in lldb
Fix upstream bug https://bugs.llvm.org/show_bug.cgi?id=35291
* Fix the path detection to lib fuzzer
https://bugs.llvm.org/show_bug.cgi?id=33248
* Add a symlink to fix lldb-X.Y - for real (Closes: #881993)
2017-12-09 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1-1) unstable; urgency=medium
* New stable release
* test-keep-alive.diff: Display more information during the test suite run
to avoid the FTBFS on mips*
2017-12-08 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1~+rc3-1~exp1) experimental; urgency=medium
* New testing release
2017-11-30 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1~+rc2-1~exp1) experimental; urgency=medium
* New testing release
* Add a symlink to fix lldb-X.Y (Closes: #881993)
* liblld-5.0-dev depends on liblld-5.0 (Closes: #856545)
2017-11-28 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1~+rc1-1~exp2) experimental; urgency=medium
* Create clang-tools-5.0 and move the various clang tools into it
clang-tools-5.0 depends on clang-5.0. This might affect some packages.
(Closes: #836397)
* Take a patch for a stack alignment on sparc64 for rust
Thanks to John Paul Adrian Glaubitz for the work (Closes: #880221)
* Update of the clang description
* Standards-Version updated to 4.1.1
* Remove some old breaks/replaces/conflicts (<3.8)
* Fix some wrong-section-according-to-package-name and
priority-extra-is-replaced-by-priority-optional issues
* liblld-4.0-dev depends on liblld-4.0 (Closes: #856545)
* Use ?= for some variables declarations
* Remove the hardcoded declarations of llvm version in debian/rules
* add /usr/lib/cuda to the CUDA toolkit search paths
Thanks to Andreas Beckmann for the patch (Closes: #882505) (LP: #1706326)
* Fix the fix-scan-view-path.diff path
* Move libomp-dev from Suggests to Recommends (Closes: #882781)
* Do not ship liblld-5.0-dbg as we are not shipping the .so in this version
2018-02-11 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-5.0 (1:5.0.1~+rc1-1~exp1) experimental; urgency=medium
* New testing release
* Update of the copyright file (Closes: #878502)
Thanks to Nicholas D Steeves for the work
* Try to fix the mipsel FTBFS (Closes: #877567)
I am trying the first option from the bug:
- gsplit-dward on 32 bits archs
- -g everywhere
Many thanks to Adrian Bunk for that
* Fix the fix-scan-view-path.diff path (Closes: #885827)
* Move libomp-dev from Suggests to Recommends (Closes: #882781)
* Do not ship liblld-4.0-dbg for now (Closes: #889269)

See Also

Package Description
python-lldb-6.0_6.0-1ubuntu2_i386.deb Next generation, high-performance debugger, python lib
python-llfuse-doc_1.3.3+dfsg-3_all.deb Python bindings for the low-level FUSE API (documentation)
python-llfuse_1.3.3+dfsg-3_i386.deb Python bindings for the low-level FUSE API
python-llvmlite_0.19.0-2_i386.deb LLVM Python binding for writing JIT compilers
python-lmdb_0.86-1build4_i386.deb Python binding for LMDB Lightning Memory-Mapped Database
python-lmfit-doc_0.9.7+dfsg-1_all.deb Least-Squares Minimization with Constraints (Documentation)
python-lmfit_0.9.7+dfsg-1_all.deb Least-Squares Minimization with Constraints (Python 2)
python-logbook-doc_0.12.3-1_all.deb logging system for Python that replaces the standard library's module (doc)
python-logbook_0.12.3-1_all.deb logging system for Python that replaces the standard library's module
python-logging-tree_1.4-1_all.deb introspect and display the logging tree in Python
python-loggingx_0.1.3-1.1build1_all.deb Generic utilities for the Python logging facility
python-logilab-common_1.4.1-1_all.deb useful miscellaneous modules used by Logilab projects
python-logilab-constraint_0.5.0-2_all.deb constraints satisfaction solver in Python
python-logsparser_0.4-1_all.deb Python library for log parsing, tagging and analysis
python-loofah_0.1-1_all.deb debile helper to rebuild a set of existing packages
Advertisement
Advertisement