python-lldb-3.9_3.9.1-19ubuntu1_i386.deb


Advertisement

Description

python-lldb-3.9 - Next generation, high-performance debugger, python lib

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-lldb-3.9_3.9.1-19ubuntu1_i386.deb
Package name python-lldb-3.9
Package version 3.9.1
Package release 19ubuntu1
Package architecture i386
Package type deb
Category universe/python
Homepage http://www.llvm.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 88.11 KB
Installed size 699.00 KB
LLDB is a next generation, high-performance debugger. It is built as a set of
reusable components which highly leverage existing libraries in the larger LLVM
Project, such as the Clang expression parser and LLVM disassembler.
This binding package provides access to lldb.

Alternatives

Package Version Architecture Repository
python-lldb-3.9_3.9.1-19ubuntu1_amd64.deb 3.9.1 amd64 Ubuntu Universe
python-lldb-3.9 - - -

Requires

Name Value
liblldb-3.9-dev -
python -
python-six -

Conflicts

Name Value
python-lldb-3.4 -
python-lldb-3.5 -
python-lldb-3.6 -
python-lldb-3.7 -
python-lldb-3.8 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-lldb-3.9_3.9.1-19ubuntu1_i386.deb
Source Package llvm-toolchain-3.9

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-lldb-3.9 deb package:
    # sudo apt-get install python-lldb-3.9

Files

Path
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/__init__.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/_lldb.so
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/embedded_interpreter.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/libLLVM-3.9.1.so.1
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/libLLVM-3.9.so.1
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/lldb-argdumper
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/Logger.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/__init__.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/attrib_fromdict.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/cache.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/metrics.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/cpp/__init__.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/cpp/gnu_libstdcpp.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/formatters/cpp/libcxx.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/runtime/__init__.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/utils/__init__.py
/usr/lib/llvm-3.9/lib/python2.7/site-packages/lldb/utils/symbolication.py
/usr/lib/python2.7/dist-packages/lldb
/usr/share/doc/python-lldb-3.9/NEWS.Debian.gz
/usr/share/doc/python-lldb-3.9/changelog.Debian.gz
/usr/share/doc/python-lldb-3.9/copyright

Changelog

2017-12-26 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-19ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Drop python-lldb-3.9 from lldb-3.9 depends because it's in universe. 
2017-12-22 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.9 (1:3.9.1-19) unstable; urgency=medium
* Standards-Version updated to 4.1.1
* Add the keep alive to hopefully fix the armhf timeout
* Try to fix the mipsel FTBFS (Closes: #877567)
I am trying the first option from the bug:
- gsplit-dward on 32 bits archs
- -g everywhere
Many thanks to Adrian Bunk for that
2017-10-27 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-18ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Drop python-lldb-3.9 from lldb-3.9 depends because it's in universe. 
2017-10-13 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.9 (1:3.9.1-18) unstable; urgency=medium
* Force the deactivation of ocaml until the transition is done
* Standards-Version: 4.1.0
2017-10-02 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-17ubuntu1) artful; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Drop python-lldb-3.9 from lldb-3.9 depends because it's in universe. 
2017-10-01 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-3.9 (1:3.9.1-17) unstable; urgency=medium
* Remove the -Wl option to call gold instead of the normal linker
(Closes: #876787)
[ Gianfranco Costamagna ]
* Fixup previous upload, adding -NDEBUG to build flags,
lost in the -g -> -g1 switch
2017-09-21 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-16ubuntu5) artful; urgency=medium
* Fixup previous upload, adding -NDEBUG
2017-09-21 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-16ubuntu4) artful; urgency=medium
* Try to use NDEBUG, this seems to be the culprit for the amd64 build
failure (and related to clamav failure)
- g1 is needed to avoid debug builds > 1.2GB in size
2017-09-20 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-16ubuntu3) artful; urgency=medium
* Enable opt_flags (-g1) for arm64 only
2017-09-20 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-3.9 (1:3.9.1-16ubuntu2) artful; urgency=medium
* Drop opt_flags, it seems to be breaking clamav (cfr lp: 1717574)

See Also

Package Description
python-lldb-4.0_4.0.1-10_i386.deb Next generation, high-performance debugger, python lib
python-lldb-5.0_5.0.1-4_i386.deb Next generation, high-performance debugger, python lib
python-lldb-6.0_6.0-1ubuntu2_i386.deb Next generation, high-performance debugger, python lib
python-llfuse-doc_1.3.3+dfsg-3_all.deb Python bindings for the low-level FUSE API (documentation)
python-llfuse_1.3.3+dfsg-3_i386.deb Python bindings for the low-level FUSE API
python-llvmlite_0.19.0-2_i386.deb LLVM Python binding for writing JIT compilers
python-lmdb_0.86-1build4_i386.deb Python binding for LMDB Lightning Memory-Mapped Database
python-lmfit-doc_0.9.7+dfsg-1_all.deb Least-Squares Minimization with Constraints (Documentation)
python-lmfit_0.9.7+dfsg-1_all.deb Least-Squares Minimization with Constraints (Python 2)
python-logbook-doc_0.12.3-1_all.deb logging system for Python that replaces the standard library's module (doc)
python-logbook_0.12.3-1_all.deb logging system for Python that replaces the standard library's module
python-logging-tree_1.4-1_all.deb introspect and display the logging tree in Python
python-loggingx_0.1.3-1.1build1_all.deb Generic utilities for the Python logging facility
python-logilab-common_1.4.1-1_all.deb useful miscellaneous modules used by Logilab projects
python-logilab-constraint_0.5.0-2_all.deb constraints satisfaction solver in Python
Advertisement
Advertisement