python-link-grammar_5.3.16-2_i386.deb


Advertisement

Description

python-link-grammar - Carnegie Mellon University's link grammar parser (Python 2)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-link-grammar_5.3.16-2_i386.deb
Package name python-link-grammar
Package version 5.3.16
Package release 2
Package architecture i386
Package type deb
Category universe/python
Homepage http://www.abisource.com/projects/link-grammar/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 34.47 KB
Installed size 171.00 KB
In Sleator, D. and Temperley, D. "Parsing English with a Link Grammar"
(1991), the authors defined a new formal grammatical system called a
"link grammar". A sequence of words is in the language of a link
grammar if there is a way to draw "links" between words in such a way
that the local requirements of each word are satisfied, the links do
not cross, and the words form a connected graph. The authors encoded
English grammar into such a system, and wrote this program to parse
English using this grammar.
link-grammar can be used for linguistic parsing for information
retrieval or extraction from natural language documents. It can also be
used as a grammar checker.
This package contains a Python 2 library for using link-grammar.

Alternatives

Package Version Architecture Repository
python-link-grammar_5.3.16-2_amd64.deb 5.3.16 amd64 Ubuntu Universe
python-link-grammar - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
liblink-grammar5 >= 5.3.14
libpython2.7 >= 2.7
libstdc++6 >= 4.1.1
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-link-grammar_5.3.16-2_i386.deb
Source Package link-grammar

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-link-grammar deb package:
    # sudo apt-get install python-link-grammar

Files

Path
/usr/lib/python2.7/dist-packages/linkgrammar/__init__.py
/usr/lib/python2.7/dist-packages/linkgrammar/_clinkgrammar.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/linkgrammar/clinkgrammar.py
/usr/lib/python2.7/dist-packages/linkgrammar/linkgrammar.py
/usr/share/doc/python-link-grammar/changelog.Debian.gz
/usr/share/doc/python-link-grammar/copyright

Changelog

2017-06-26 - Adrian Bunk <bunk@debian.org>
link-grammar (5.3.16-2) unstable; urgency=medium
* QA upload.
* Apply patch from Steve Langasek adding the missing test
dependency on default-jdk. (Closes: #865902)
2017-06-19 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.16-1) unstable; urgency=medium
* New upstream release
* debian/docs: README was renamed to README.md
2017-01-19 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.14-1) unstable; urgency=medium
* QA upload
* New upstream release
* debian/liblink-grammar5.symbols: Add new symbols
* debian/link-grammar-dictionaries-en.install:
- Install new "ady" language
2016-12-18 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.13-1) unstable; urgency=medium
* QA upload
* New upstream release
* Add python3-link-grammar package
* Move python examples to new python-link-grammar-examples package
* Drop debian/patches/git_link-with-libstdcc.patch, applied in
new version
2016-10-04 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.11-2) unstable; urgency=medium
* QA upload
* debian/rules:
- Try to make the 'delete *.la' rule smarter to not break autopkgtest
- Fix build failures on architectures that don't build
liblink-grammar-java
* Add debian/patches/git_link-with-libstdcc.patch:
- Cherry-pick commit to try to fix build log check warning
about not linking against libstdc++
2016-09-28 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.11-1) unstable; urgency=medium
* QA upload
* New upstream release
* debian/control:
- (Build-)Depend on minisat instead of using bundled copy
- Build-Depend on zlib1g-dev
* debian/rules:
- Use dh_install --fail-missing
2016-09-14 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.10-1) unstable; urgency=medium
* QA upload.
* New upstream release.
2016-08-29 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.9-1) unstable; urgency=medium
* QA upload
* New upstream release
* Bump dh compat to 10
2016-08-17 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.8-2) unstable; urgency=medium
* QA upload
* debian/rules:
- Fix override_dh_auto_clean typo, thanks lintian 2.5.46!
* debian/tests/control:
- Depend on build-essential for autopkgtest build test
2016-08-16 - Jeremy Bicha <jbicha@ubuntu.com>
link-grammar (5.3.8-1) unstable; urgency=medium
* QA upload
* New upstream release
- Includes "reproducible builds" patch from Chris Lamb (Closes: #829011)
* Drop all patches since they've been applied in new release 
* debian/tests/control: Add Restrictions: build-needed
* Have autopkgtest run upstream python tests too
* Add python-link-grammar.examples
* Have python-link-grammar recommend link-grammar-dictionaries-all
since it's needed for the examples

See Also

Package Description
python-linop-doc_0.8.2-3_all.deb Linear mathematical operators in Python (documentation)
python-linop_0.8.2-3_i386.deb Linear mathematical operators in Python (Python 2)
python-livereload-doc_2.5.1-1_all.deb automatic browser refresher (documentation)
python-livereload_2.5.1-1_all.deb automatic browser refresher
python-lldb-3.9_3.9.1-19ubuntu1_i386.deb Next generation, high-performance debugger, python lib
python-lldb-4.0_4.0.1-10_i386.deb Next generation, high-performance debugger, python lib
python-lldb-5.0_5.0.1-4_i386.deb Next generation, high-performance debugger, python lib
python-lldb-6.0_6.0-1ubuntu2_i386.deb Next generation, high-performance debugger, python lib
python-llfuse-doc_1.3.3+dfsg-3_all.deb Python bindings for the low-level FUSE API (documentation)
python-llfuse_1.3.3+dfsg-3_i386.deb Python bindings for the low-level FUSE API
python-llvmlite_0.19.0-2_i386.deb LLVM Python binding for writing JIT compilers
python-lmdb_0.86-1build4_i386.deb Python binding for LMDB Lightning Memory-Mapped Database
python-lmfit-doc_0.9.7+dfsg-1_all.deb Least-Squares Minimization with Constraints (Documentation)
python-lmfit_0.9.7+dfsg-1_all.deb Least-Squares Minimization with Constraints (Python 2)
python-logbook-doc_0.12.3-1_all.deb logging system for Python that replaces the standard library's module (doc)
Advertisement
Advertisement