python-libuser_0.62~dfsg-0.1ubuntu2_i386.deb


Advertisement

Description

python-libuser - user and group account administration library - Python 2.7 bindings

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-libuser_0.62~dfsg-0.1ubuntu2_i386.deb
Package name python-libuser
Package version 0.62~dfsg
Package release 0.1ubuntu2
Package architecture i386
Package type deb
Category universe/admin
Homepage https://fedorahosted.org/libuser/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.75 KB
Installed size 65.00 KB
The libuser library implements a standardized interface for manipulating
and administering user and group accounts.  The library uses pluggable
back-ends to interface to its data sources.
This package contains the Python 2.7 bindings for the library.

Alternatives

Package Version Architecture Repository
python-libuser_0.62~dfsg-0.1ubuntu2_amd64.deb 0.62~dfsg amd64 Ubuntu Universe
python-libuser - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.24.0
libuser1 >= 1:0.60~dfsg
python >= 2.7~
python << 2.8
python:any >= 2.7~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-libuser_0.62~dfsg-0.1ubuntu2_i386.deb
Source Package libuser

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-libuser deb package:
    # sudo apt-get install python-libuser

Files

Path
/usr/lib/python2.7/dist-packages/libuser.i386-linux-gnu.so
/usr/share/doc/python-libuser/changelog.Debian.gz
/usr/share/doc/python-libuser/copyright

Changelog

2016-10-05 - Matthias Klose <doko@ubuntu.com>
libuser (1:0.62~dfsg-0.1ubuntu2) yakkety; urgency=medium
* Build using dpkg-dev's hardening support.
2016-07-09 - Steve Langasek <steve.langasek@ubuntu.com>
libuser (1:0.62~dfsg-0.1ubuntu1) yakkety; urgency=medium
* Build-depend on hardening-wrapper to support the 'hardening' build flag.
2016-05-27 - Mattia Rizzolo <mattia@debian.org>
libuser (1:0.62~dfsg-0.1) unstable; urgency=high
* Non-maintainer upload.
* Imported Upstream version 0.62~dfsg.
+ CVE-2015-3245 (Lack of validation of GECOS field contents) (low/local)
+ CVE-2015-3246 (Race condition in passwd file update) (high/local)
+ Closes: #793465
* d/copyright:
+ convert to copyright-format 1.0.
+ add a Files-Excluded field to drop docs/rfc2307.txt from the orig tarball.
+ add myself to the copyright for the debian part.
* Add watch file.
* Run wrap-and-sort -ast.
* d/control:
+ add build-dependency on dh-python.
+ move python-libuser to section python, as it contains python bindings.
+ bump Standards-Version to 3.9.8, no changes needed.
+ add Vcs-* fields.
* d/patches:
+ 0002-Try-harder-to-ignore-the-retunrn-of-ftuncate.patch: drop as obsolete.
+ use-pkg-config-for-python-include: add, otherwise it fails to look up the
python headers.
+ refresh them all.
* d/rules:
+ drop what seems to be useless code.
+ enable parallel build.
+ more robust .la removal using find(1).
+ enable DH_VERBOSE.
+ enable hardening.
+ use dh_install --fail-missing.
* d/symbols:
+ rename to d/libuser1.symbols, so it is actually picked up and used.
+ update: add new symbols that have been there since at least 1:0.60~dfsg.
* d/libuser.install: install /etc/libuser.conf.  LP: #1387274
2014-12-29 - Dimitri John Ledkov <dimitri.j.ledkov@linux.intel.com>
libuser (1:0.60~dfsg-1.2) unstable; urgency=medium
* Non-maintainer upload.
* Revert previous upload, does not solve the root cause.
* Rename lid to libuser-lid, as there are no users in debian packages of
that command.  lid from id-util's is used by seascope. (Closes:
#748728)
2014-12-09 - Micha Lenk <micha@debian.org>
libuser (1:0.60~dfsg-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Add Conflict: id-utils to libuser (closes: #748728).
* Lower the priority of binary package libuser to 'extra' to have the
Conflicts: id-utils in compliance with Debian Policy 2.5 ('optional
packages should not conflict with each other').
2014-04-28 - Tzafrir Cohen <tzafrir@debian.org>
libuser (1:0.60~dfsg-1) unstable; urgency=low
* complete repackaging (Closes: #670663).
* New upstream release (Closes: #705690).
* Remove Conflict with python2.3-libuser that was never in a stable release.
* Standard version 3.9.5.
2011-06-02 - Luk Claes <luk@debian.org>
libuser (1:0.56.9.dfsg.1-1.2) unstable; urgency=low
* Non-maintainer upload.
* Remove references to other libraries from dependency_libs field
Closes: #620594
2011-02-09 - Anibal Monsalve Salazar <anibal@debian.org>
libuser (1:0.56.9.dfsg.1-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix CVE-2011-0002
Mark the LDAP default password value as encrypted
Patch taken from libuser-0.56.18-3.fc14.src.rpm
Add 02libuser-0.56.18-default-pw.dpatch
Closes: 610034
* Fix binary-or-shlib-defines-rpath
2008-05-02 - Ghe Rivero <ghe@debian.org>
libuser (1:0.56.9.dfsg.1-1) unstable; urgency=low
* New upstream release
2008-03-11 - Ghe Rivero <ghe@debian.org>
libuser (1:0.56.8.dfsg.1-1) unstable; urgency=low
* New upstream release
* New download homepage at copyright file
* Lintian clean: copyright-without-copyright-notice

See Also

Package Description
python-libvhdi_20170223-3_i386.deb Virtual Hard Disk image format access library -- Python 2 bindings
python-libvmdk_20170226-3_i386.deb VMWare Virtual Disk format access library -- Python 2 bindings
python-libvoikko_4.1.1-1.1_all.deb transitional dummy package for Python bindings for libvoikko
python-libvshadow_20170902-2_i386.deb Volume Shadow Snapshot format access library -- Python 2 bindings
python-libvslvm_20160110-3_i386.deb Linux LVM volume system format access library -- Python 2 bindings
python-libwfut-0.2_0.2.3-5_i386.deb WorldForge Update Tool (Python bindings)
python-libxmp-doc_2.0.1+git20140309.5437b0a-5_all.deb Python library for XMP metadata - documentation
python-libxmp_2.0.1+git20140309.5437b0a-5_all.deb Python library for XMP metadata
python-lightblue_0.3.2-5build1_i386.deb cross-platform Bluetooth API for Python
python-limits-doc_1.2.1-1_all.deb Rate limiting utilities for Python - Documentation
python-limits_1.2.1-1_all.deb Rate limiting utilities for Python - Python 2.X
python-linaro-image-tools_2016.05-1.1_all.deb Python library for the manipulation of Linaro bootable media
python-link-grammar-examples_5.3.16-2_all.deb CMU's link grammar parser (Python examples)
python-link-grammar_5.3.16-2_i386.deb Carnegie Mellon University's link grammar parser (Python 2)
python-linop-doc_0.8.2-3_all.deb Linear mathematical operators in Python (documentation)
Advertisement
Advertisement