python-ldtp_2.3.1-1.1_all.deb


Advertisement

Description

python-ldtp - Python bindings for LDTP

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-ldtp_2.3.1-1.1_all.deb
Package name python-ldtp
Package version 2.3.1
Package release 1.1
Package architecture all
Package type deb
Category universe/devel
Homepage http://ldtp.freedesktop.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 10.72 KB
Installed size 65.00 KB
Linux Desktop Testing Project is aimed at producing high quality test
automation framework and cutting-edge tools that can be used to test GNU/Linux
Desktop and improve it. It uses the Accessibility libraries to poke through
the applications user interface.
This package provides a Python library for LDTP.

Alternatives

Package Version Architecture Repository
python-ldtp_2.3.1-1.1_all.deb 2.3.1 all Ubuntu Universe
python-ldtp - - -

Requires

Name Value
gir1.2-glib-2.0 -
gir1.2-gtk-3.0 -
gir1.2-wnck-3.0 -
ldtp >= 2.3.1-1.1
python << 2.8
python >= 2.7
python-gobject -
python-pyatspi -
python-twisted-web -
python:any >= 2.6.6-7~

Provides

Name Value
python2.7-ldtp -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-ldtp_2.3.1-1.1_all.deb
Source Package ldtp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ldtp deb package:
    # sudo apt-get install python-ldtp

Files

Path
/usr/lib/python2.7/dist-packages/ldtp/__init__.py
/usr/lib/python2.7/dist-packages/ldtp/client.py
/usr/lib/python2.7/dist-packages/ldtp/client_exception.py
/usr/lib/python2.7/dist-packages/ldtp/log.py
/usr/lib/python2.7/dist-packages/ldtp/state.py
/usr/lib/python2.7/dist-packages/ldtputils/__init__.py
/usr/lib/python2.7/dist-packages/ooldtp/__init__.py
/usr/lib/python2.7/dist-packages/ooldtp/_context.py
/usr/share/doc/python-ldtp/AUTHORS
/usr/share/doc/python-ldtp/README
/usr/share/doc/python-ldtp/changelog.Debian.gz
/usr/share/doc/python-ldtp/copyright

Changelog

2017-11-22 - Jeremy Bicha <jbicha@debian.org>
ldtp (2.3.1-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Depend on python-pyatspi instead of obsolete transitional package
(Closes: #881351)
2012-02-27 - Kartik Mistry <kartik@debian.org>
ldtp (2.3.1-1) unstable; urgency=low
* New upstream release:
+ ldtp-doc is now generated by ldtp source package.
* debian/control:
+ Added ldtp-doc binary.
+ Updated to Standards-Version 3.9.3
+ Updated short and long descriptions.
* debian/rules, debian/*.install, debian/*.docs:
+ Fixed for ldtp-doc changes.
* debian/copyright:
+ Updated for copyright-format 1.0
2012-01-10 - Kartik Mistry <kartik@debian.org>
ldtp (2.2.0-2) unstable; urgency=low
* Sync from Ubuntu.
* debian/control:
+ Depend on python-pyatspi2 instead of python-pyatspi.
+ Update dependencies to refer to gir1.2 packages.
* debian/patches/fix-twisted.patch:
+ Fix 'import ldtp' with latest twisted. Patch from Upstream+Ubuntu.
* debian/copyright:
+ Updated as per latest DEP-5 format.
+ Fixed duplicated License paragraph.
2011-09-22 - Kartik Mistry <kartik@debian.org>
ldtp (2.2.0-1) unstable; urgency=low
* New upstream release.
* Migrated package to dh_python2.
* debian/control:
+ Updated to Standards-Version 3.9.2 (no changes needed).
* debian/copyright:
+ Updated as per latest DEP-5 format.
2011-03-23 - Kartik Mistry <kartik@debian.org>
ldtp (2.1.1-2) unstable; urgency=low
* Uploaded to unstable
2011-03-16 - Kartik Mistry <kartik@debian.org>
ldtp (2.1.1-1) experimental; urgency=low
* New upstream release
2011-01-04 - Kartik Mistry <kartik@debian.org>
ldtp (2.1.0-1) experimental; urgency=low
* New upstream release (Closes: #608870)
* debian/control:
+ Updated to Standards-Version 3.9.1 (no changes needed)
* debian/copyright:
+ Updated as per DEP-5 format
+ Updated copyright year for upstream and debian packaging
2010-04-15 - Kartik Mistry <kartik@debian.org>
ldtp (2.0.6-1) unstable; urgency=low
* New upstream release
* debian/pyversions:
+ Set to 2.5-
2010-04-07 - Kartik Mistry <kartik@debian.org>
ldtp (2.0.5-1) unstable; urgency=low
* New upstream release
2010-03-26 - Kartik Mistry <kartik@debian.org>
ldtp (2.0.4-1) unstable; urgency=low
* New upstream release
* debian/rules:
+ Installed examples provided from upstream

See Also

Package Description
python-leather-doc_0.3.3-1_all.deb documentation for leather
python-ledger_3.1.2~pre1+g3a00e1c+dfsg1-5build5_i386.deb command-line double-entry accounting program (python extension)
python-lepl_5.1.3-2_all.deb recursive descent parser library
python-lesscpy_0.13.0+ds-1_all.deb LessCss Compiler for Python 2.x
python-leveldb_0~svn68-3build3_i386.deb Python wrapper for LevelDB (Python 2)
python-levenshtein_0.12.0-2build3_i386.deb extension for computing string similarities and edit distances
python-lfc_1.10.0-2_i386.deb LCG File Catalog (LFC) python2 bindings
python-lhapdf_5.9.1-6_i386.deb Python Bindings for LHAPDF
python-libapparmor_2.12-4ubuntu5_i386.deb AppArmor library Python bindings
python-libarchive-c_2.1-3.1_all.deb Python interface to libarchive
python-libavg_1.8.2-1_i386.deb High-level development platform for media-centric applications
python-libbde_20170902-2_i386.deb BitLocker Drive Encryption access library -- Python 2 bindings
python-libbtbb-pcapdump_2017.03.R2-1_all.deb pcapdump is a Python module for pcap delivered by libbtbb
python-libcec_4.0.2+dfsg1-2ubuntu1_i386.deb Python bindings for USB CEC Adaptor
python-libcharmstore_0.0.3-0ubuntu1_all.deb Python library to access Juju charmstore data
Advertisement
Advertisement