python-laditools_1.1.0-2_all.deb


Advertisement

Description

python-laditools - Python module to control and monitor the LADI system

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-laditools_1.1.0-2_all.deb
Package name python-laditools
Package version 1.1.0
Package release 2
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/alessio/laditools
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.82 KB
Installed size 77.00 KB
LADITools is a set of tools aiming to achieve the goals of the LADI
project to improve desktop integration and user workflow of Linux
audio system based on JACK and ladish. Those tools take advantage of
the D-Bus interfaces recently added to JACK and ladish to ease the
configuration and use of those two great programs.
This package provides the Python module to communicate with JACK,
ladish and A2J.

Alternatives

Package Version Architecture Repository
python-laditools_1.1.0-2_all.deb 1.1.0 all Ubuntu Universe
python-laditools - - -

Requires

Name Value
jackd2 -
python-dbus -
python-enum34 -
python-gi -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-laditools_1.1.0-2_all.deb
Source Package laditools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-laditools deb package:
    # sudo apt-get install python-laditools

Files

Path
/usr/lib/python2.7/dist-packages/laditools-1.1.0_.git.egg-info
/usr/lib/python2.7/dist-packages/laditools/__init__.py
/usr/lib/python2.7/dist-packages/laditools/a2j.py
/usr/lib/python2.7/dist-packages/laditools/application.py
/usr/lib/python2.7/dist-packages/laditools/config.py
/usr/lib/python2.7/dist-packages/laditools/controller.py
/usr/lib/python2.7/dist-packages/laditools/jack.py
/usr/lib/python2.7/dist-packages/laditools/ladish.py
/usr/lib/python2.7/dist-packages/laditools/manager.py
/usr/lib/python2.7/dist-packages/laditools/gtk/__init__.py
/usr/lib/python2.7/dist-packages/laditools/gtk/a2jmenu.py
/usr/lib/python2.7/dist-packages/laditools/gtk/manager.py
/usr/lib/python2.7/dist-packages/laditools/gtk/menu.py
/usr/lib/python2.7/dist-packages/laditools/gtk/utils.py
/usr/share/doc/python-laditools/changelog.Debian.gz
/usr/share/doc/python-laditools/copyright

Changelog

2016-03-10 - Ross Gammon <rossgammon@mail.dk>
laditools (1.1.0-2) unstable; urgency=medium
* Port from python-enum to python-enum34
(Closes: #800805) (LP: #1498345)
* Add myself to uploaders
* Bump standards version, no changes required
* Use secure uri for Vcs
* Patch desktop files to add keywords entries
* Add patch to fix spelling error in manpage
2015-09-13 - Alessio Treglia <alessio@debian.org>
laditools (1.1.0-1) unstable; urgency=medium
[ Sebastian Ramacher ]
* Fix bug number
[ Alessio Treglia ]
* New upstream release.
- Fix VTE's feed() call (Closes: #770076)
* Drop patches as they've been applied upstream
* Fix deian/docs:
- README -> README.md
* Fix debian/watch, project's moved to Github
* Update Homepage
2015-09-07 - Sebastian Ramacher <sramacher@debian.org>
laditools (1.0.1-3) unstable; urgency=medium
* Team upload.
[ Iain Lane ]
* debian/patches/vte-feed: Pass the correct parameters to VteTerminal.feed()
(Closes: #770076)
* debian/control: Depend on gir1.2-vte-2.91. (Closes: #788033)
[ Sebastian Ramacher ]
* debian/control:
- Bump Standards-Version.
- Fix errors in Description. (Closes: #745308)
- Update Vcs-* fields.
- B-D on dh-python for dh_python2 and bump debhelper to >= 9.
* debian/compat: Bump to 9.
2012-07-10 - Alessio Treglia <alessio@debian.org>
laditools (1.0.1-2) unstable; urgency=low
* Depends on python-gi-cairo.
Thanks to Stefaan Himpe for the report. (Closes: #680750)
2012-05-19 - Alessio Treglia <alessio@debian.org>
laditools (1.0.1-1) unstable; urgency=low
* New upstream release:
- Fix crashes in ladi-controler-center (Closes: #671366).
- Replace rsvg with rsvg-convert (Closes: #666478).
- Translations update.
* Drop patches, applied upstream.
2012-05-18 - Alessio Treglia <alessio@debian.org>
laditools (1.0-2) unstable; urgency=medium
* Needs python >= 2.7.
* Fix GtkTreeView's set_cursor call to avoid ladi-control-center
crashes. (Closes: #671366)
2012-03-24 - Alessio Treglia <alessio@debian.org>
laditools (1.0-1) unstable; urgency=low
* Upload to unstable.
* First stable release "Lady 'O'":
- Some executables have been renamed:
+ ladicontrol -> ladi-control-center
+ ladilog     -> ladi-system-log
+ laditray    -> ladi-system-tray
- New main front-end: ladi-player.
- PyGTK+ -> GObject Introspection migration (and then GTK+2 -> GTK+3).
- Stable API for developing applications using python-laditools.
- Added gettext support.
- Various bugfixes and improvements.
* Split laditools:
- python-laditools to provide Python modules.
- laditools to provide the applications.
* Add dependency on python-enum.
* Use bzip2 tarballs.
* Remove Debian manpages, they were merged upstream.
2012-03-21 - Alessio Treglia <alessio@debian.org>
laditools (1.0~rc8-1) experimental; urgency=low
* Imported Upstream version 1.0~rc8
* Build-depend on librsvg2-bin.
* Update dh_links control file.
* Update debian/copyright.
* Update package description.
* Don't provide README.source anymore, it's unnecessary now.
* Delete old patches, they are no longer necessary.
2012-03-08 - Alessio Treglia <alessio@debian.org>
laditools (1.0~rc7-1) experimental; urgency=low
* New upstream RC release.
* Migrate from GTK2 to GTK3, properly update the Depends field.
* Build-depend on python-distutils-extra.
* Drop old patches, all adopted upstream.
* Disable intltool support, it's broken.
* Drop AUTHORS file from debian/laditools.docs
* Update debian/copyright.
* Update watch file.
* Bump Standards.
2011-12-07 - Alessio Treglia <alessio@debian.org>
laditools (1.0~rc2+20100724.gitf4d4a2-5) unstable; urgency=low
* debian/control:
- Replace LASH with ladish.
- Update Homepage field.

See Also

Package Description
python-lamson_1.0pre11-1.3_all.deb A pure Python SMTP server
python-landslide_1.1.3-0.0_all.deb Lightweight markup language-based html5 slideshow generator
python-langdetect_1.0.7-2_all.deb Python library for language-detection (Python 2)
python-larch_1.20151025-1_all.deb B-tree library for Python
python-lasagne_0.1+git20160728.8b66737-4_all.deb deep learning library build on the top of Theano (Python2 modules)
python-laser-geometry_1.6.4-2build6_all.deb Robot OS laser geometry package - Python bindings
python-lasso_2.5.1-0ubuntu1_i386.deb Library for Liberty Alliance and SAML protocols - Python bindings
python-latexcodec-doc_1.0.5-1_all.deb LaTeX lexer and codec library for Python (docs)
python-latexcodec_1.0.5-1_all.deb LaTeX lexer and codec library for Python
python-launchpadlib-toolkit_2.3_all.deb convenience library for launchpadlib
python-lazr.batchnavigator_1.2.10-0ubuntu2_all.deb A helper to navigate batched results in a web page
python-lazr.config-doc_2.2-1_all.deb ini-file format handling supporting schemas and inheritance
python-lazr.config_2.2-1_all.deb ini-file format handling supporting schemas and inheritance
python-lazr.delegates-doc_2.0.3-1build1_all.deb easily write objects that delegate behavior
python-lazr.delegates_2.0.3-1build1_all.deb easily write objects that delegate behavior
Advertisement
Advertisement