python-hy_0.12.1-2_all.deb


Advertisement

Description

python-hy - Lisp (s-expression) based frontend to Python

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-hy_0.12.1-2_all.deb
Package name python-hy
Package version 0.12.1
Package release 2
Package architecture all
Package type deb
Category universe/python
Homepage http://hylang.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 49.63 KB
Installed size 295.00 KB
Hy is a wonderful dialect of Lisp that's embedded in Python.
Since Hy transforms its Lisp code into the Python Abstract Syntax Tree, you
have the whole beautiful world of Python at your fingertips, in Lisp form!
This package contains Python 2 bindings only.

Alternatives

Package Version Architecture Repository
python-hy_0.12.1-2_all.deb 0.12.1 all Ubuntu Universe
python-hy - - -

Requires

Name Value
python-astor -
python-clint -
python-rply -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-hy_0.12.1-2_all.deb
Source Package hy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-hy deb package:
    # sudo apt-get install python-hy

Files

Path
/usr/bin/hy2
/usr/bin/hy2py2
/usr/bin/hyc2
/usr/lib/python2.7/dist-packages/hy/__init__.py
/usr/lib/python2.7/dist-packages/hy/__main__.py
/usr/lib/python2.7/dist-packages/hy/_compat.py
/usr/lib/python2.7/dist-packages/hy/cmdline.py
/usr/lib/python2.7/dist-packages/hy/compiler.py
/usr/lib/python2.7/dist-packages/hy/completer.py
/usr/lib/python2.7/dist-packages/hy/errors.py
/usr/lib/python2.7/dist-packages/hy/importer.py
/usr/lib/python2.7/dist-packages/hy/macros.py
/usr/lib/python2.7/dist-packages/hy-unknown.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/hy-unknown.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/hy-unknown.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/hy-unknown.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/hy-unknown.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/hy/contrib/__init__.py
/usr/lib/python2.7/dist-packages/hy/contrib/botsbuildbots.hy
/usr/lib/python2.7/dist-packages/hy/contrib/loop.hy
/usr/lib/python2.7/dist-packages/hy/contrib/multi.hy
/usr/lib/python2.7/dist-packages/hy/contrib/profile.hy
/usr/lib/python2.7/dist-packages/hy/contrib/sequences.hy
/usr/lib/python2.7/dist-packages/hy/contrib/walk.hy
/usr/lib/python2.7/dist-packages/hy/core/__init__.py
/usr/lib/python2.7/dist-packages/hy/core/bootstrap.hy
/usr/lib/python2.7/dist-packages/hy/core/language.hy
/usr/lib/python2.7/dist-packages/hy/core/macros.hy
/usr/lib/python2.7/dist-packages/hy/core/reserved.hy
/usr/lib/python2.7/dist-packages/hy/core/shadow.hy
/usr/lib/python2.7/dist-packages/hy/extra/__init__.py
/usr/lib/python2.7/dist-packages/hy/extra/anaphoric.hy
/usr/lib/python2.7/dist-packages/hy/lex/__init__.py
/usr/lib/python2.7/dist-packages/hy/lex/exceptions.py
/usr/lib/python2.7/dist-packages/hy/lex/lexer.py
/usr/lib/python2.7/dist-packages/hy/lex/parser.py
/usr/lib/python2.7/dist-packages/hy/models/__init__.py
/usr/lib/python2.7/dist-packages/hy/models/complex.py
/usr/lib/python2.7/dist-packages/hy/models/cons.py
/usr/lib/python2.7/dist-packages/hy/models/dict.py
/usr/lib/python2.7/dist-packages/hy/models/expression.py
/usr/lib/python2.7/dist-packages/hy/models/float.py
/usr/lib/python2.7/dist-packages/hy/models/integer.py
/usr/lib/python2.7/dist-packages/hy/models/keyword.py
/usr/lib/python2.7/dist-packages/hy/models/list.py
/usr/lib/python2.7/dist-packages/hy/models/set.py
/usr/lib/python2.7/dist-packages/hy/models/string.py
/usr/lib/python2.7/dist-packages/hy/models/symbol.py
/usr/share/doc/python-hy/changelog.Debian.gz
/usr/share/doc/python-hy/copyright

Changelog

2017-03-10 - Tianon Gravi <tianon@debian.org>
hy (0.12.1-2) unstable; urgency=medium
* Fix installed binary names and alternatives (Closes: #857308);
thanks Abhijit and Andreas!
2017-03-08 - Tianon Gravi <tianon@debian.org>
hy (0.12.1-1) unstable; urgency=medium
* Update to 0.12.1 upstream release
* Update Vcs-* to use https
2016-01-15 - Tianon Gravi <tianon@debian.org>
hy (0.11.1-1) unstable; urgency=medium
* Update to 0.11.1 upstream release (Closes: #811142).
2015-11-16 - Tianon Gravi <tianon@debian.org>
hy (0.11.0-4) unstable; urgency=medium
* Fix FTBFS due to rply trying to write to HOME during sphinx-build.
* Fix build repeatability with proper override_dh_auto_clean.
* Fix FTBFS now that the tests actually run (Closes: #805204).
* Add "hyc" and "hy2py" as slaves to the "hy" alternative.
* Add alternatives to python-hy package also (to make testing easier).
2015-08-21 - Tianon Gravi <tianon@debian.org>
hy (0.11.0-3) unstable; urgency=medium
* Fix FTBFS by adding python-clint to Build-Depends (Closes: #796434).
Thanks, Chris!
2015-05-20 - Tianon Gravi <admwiggin@gmail.com>
hy (0.11.0-1) unstable; urgency=medium
* Update to 0.11.0 upstream release.
2015-05-05 - Tianon Gravi <admwiggin@gmail.com>
hy (0.10.1-2) unstable; urgency=medium
* Update Vcs-* fields to point to the correct repositoriy.
* Remove copyninja from Uploaders per request. (Thanks for your help/support!)
* Use changelog date in man page for reproducible builds (Closes: #782385).
2014-10-10 - Tianon Gravi <admwiggin@gmail.com>
hy (0.10.1-1) unstable; urgency=medium
* Update to 0.10.1 upstream release!
2014-07-15 - Paul Tagliamonte <paultag@debian.org>
hy (0.10.0-2) unstable; urgency=medium
* Add CC0 to debian/copyright, even though they explicitly don't hold
copyright and is not a license (to make it clear these files aren't covered
by Expat or any copyright holders).
2014-07-15 - Tianon Gravi <admwiggin@gmail.com>
hy (0.10.0-1) unstable; urgency=medium
* Initial release (Closes: #731059).

See Also

Package Description
python-hydroffice.bag_0.2.15-1_all.deb manage Bathymetric Attributed Grid (BAG) data files (Python 2)
python-hyperframe_5.1.0-1_all.deb Pure-Python HTTP/2 framing code
python-hypothesis-doc_3.44.1-2ubuntu1_all.deb advanced Quickcheck style testing library (documentation)
python-hypothesis_3.44.1-2ubuntu1_all.deb advanced Quickcheck style testing library for Python 2
python-iapws_1.2-4_all.deb Python implementation of the international APWS-IF97 steam tables
python-ibm-db-sa_2.0.5-0ubuntu2_all.deb SQLAlchemy support for IBM Data Servers - Python 2.x
python-icalendar-doc_4.0.0-1_all.deb parser/generator of iCalendar files for use with Python -- docs
python-icalendar_4.0.0-1_all.deb parser/generator of iCalendar files for use with Python2
python-id3_1.2-6.3_all.deb Python module for id3-tags manipulation
python-ieee1284_0.2.11-13_i386.deb Python bindings to libieee1284
python-igraph_0.7.1.post6-5_i386.deb High performance graph data structures and algorithms (Python 2)
python-ijson_2.3-1_all.deb event-driven JSON parser (Python 2 version)
python-image-geometry_1.12.3+ds-2_all.deb image_geometry Robot OS package - Python bindings
python-imageio-doc_2.2.0-1_all.deb documentation for imageio
python-imageio_2.2.0-1_all.deb library for reading and writing image data (Python 2)
Advertisement
Advertisement