python-gtk2_2.24.0-5.1ubuntu2_i386.deb


Advertisement

Description

python-gtk2 - Python bindings for the GTK+ widget set

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-gtk2_2.24.0-5.1ubuntu2_i386.deb
Package name python-gtk2
Package version 2.24.0
Package release 5.1ubuntu2
Package architecture i386
Package type deb
Category universe/python
Homepage http://www.pygtk.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 578.44 KB
Installed size 3.22 MB
This archive contains modules that allow you to use GTK+ in Python
programs.
This package is deprecated, you should migrate to using
gobject-introspection (GIR) based python bindings instead (PyGObject).
https://wiki.gnome.org/Projects/PyGObject/IntrospectionPorting

Alternatives

Package Version Architecture Repository
python-gtk2_2.24.0-5.1ubuntu2_amd64.deb 2.24.0 amd64 Ubuntu Universe
python-gtk2 - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.4
libcairo2 >= 1.2.4
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.24.0
libgtk2.0-0 >= 2.24.0
libpango-1.0-0 >= 1.22.0
libpangocairo-1.0-0 >= 1.21.4
python >= 2.7
python << 2.8
python-cairo >= 1.0.2-1.1
python-gobject-2 >= 2.21.3
python:any >= 2.6.6-7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-gtk2_2.24.0-5.1ubuntu2_i386.deb
Source Package pygtk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gtk2 deb package:
    # sudo apt-get install python-gtk2

Files

Path
/usr/lib/python2.7/dist-packages/gtk-2.0/atk.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gtkunixprint.so
/usr/lib/python2.7/dist-packages/gtk-2.0/pango.so
/usr/lib/python2.7/dist-packages/gtk-2.0/pangocairo.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/_gtk.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/_lazyutils.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/compat.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/deprecation.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/keysyms.py
/usr/share/doc/python-gtk2/MAPPING.gz
/usr/share/doc/python-gtk2/NEWS.gz
/usr/share/doc/python-gtk2/README
/usr/share/doc/python-gtk2/README.Debian
/usr/share/doc/python-gtk2/THREADS.gz
/usr/share/doc/python-gtk2/TODO
/usr/share/doc/python-gtk2/changelog.Debian.gz
/usr/share/doc/python-gtk2/copyright

Changelog

2017-11-22 - Jeremy Bicha <jbicha@ubuntu.com>
pygtk (2.24.0-5.1ubuntu2) bionic; urgency=medium
* No-change rebuild against latest pycairo
2017-02-27 - FanJun Kong <fanjun.kong@canonical.com>
pygtk (2.24.0-5.1ubuntu1) zesty; urgency=medium
* Merge with Debian unstable (LP: #1662101). Remaining changes:
- Build-Depend on adwaita-icon-theme instead of gnome-icon-theme.
adwaita-icon-theme is the successor.
2016-10-07 - James Clarke <jrtc27@jrtc27.com>
pygtk (2.24.0-5.1) unstable; urgency=medium
* Non-maintainer upload.
* 05_Fix_GdkColor_pixel_parse.patch: Fix bus error on sparc64.
Closes: #839867.
2016-07-22 - Emilio Pozuelo Monfort <pochu@debian.org>
pygtk (2.24.0-5) unstable; urgency=medium
* Add build-indep and build-arch targets. Closes: #831945.
2015-05-18 - Iain Lane <iain@orangesquash.org.uk>
pygtk (2.24.0-4ubuntu1) wily; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/patches/bugzilla_leak_fix.patch: patch from Owen Taylor to fix a
leak issue in pango's create_layout()
- Build-Depend on adwaita-icon-theme instead of gnome-icon-theme.
adwaita-icon-theme is the successor.
2014-08-24 - Andreas Henriksson <andreas@fatal.se>
pygtk (2.24.0-4) unstable; urgency=low
* Team upload.
[ Josselin Mouette ]
* Add missing epoch on libglade build-dependency.
[ Andreas Henriksson ]
* Fix Vcs-* URLs, pygtk is in attic (not packages/unstable).
* Add deprecated notice to all package descriptions.
[ Erwan Prioul ]
* Use dh-autoreconf to fix FTBFS on ppc64el (Closes: #750663)
[ Aurelien Jarno ]
* Add -a to xvfb-run invokations to fix parallell build.
2015-01-29 - Iain Lane <iain@orangesquash.org.uk>
pygtk (2.24.0-3ubuntu4) vivid; urgency=medium
* Build-Depend on adwaita-icon-theme instead of gnome-icon-theme.
adwaita-icon-theme is the successor.
2014-02-23 - Matthias Klose <doko@ubuntu.com>
pygtk (2.24.0-3ubuntu3) trusty; urgency=medium
* Rebuild to drop files installed into /usr/share/pyshared.
2013-12-15 - William Grant <wgrant@ubuntu.com>
pygtk (2.24.0-3ubuntu2) trusty; urgency=medium
* Build with dh-autoreconf for new libtool.
2013-04-04 - Sebastien Bacher <seb128@ubuntu.com>
pygtk (2.24.0-3ubuntu1) raring; urgency=low
* debian/patches/bugzilla_leak_fix.patch: uploaded patch from Owen Taylor
to fix a leak issue in pango's create_layout() (lp: #981376)

See Also

Package Description
python-gtkglext1_1.1.0-9.1_i386.deb GtkGLext python bindings
python-gtksourceview2_2.10.1-3_i386.deb Python bindings for the GtkSourceView widget
python-gtkspellcheck-doc_4.0.5-1_all.deb Python GTK+ Spellcheck common documentation
python-gtkspellcheck_4.0.5-1_all.deb Python 2 spellchecking library GTK+ based on Enchant
python-gts_0.3.1-6_i386.deb Python wrapper for the GNU Triangulated Surface library (GTS)
python-gtts-token_1.1.1-1_all.deb Calculates a token to run the Google Translate text to speech (Python 2)
python-gtts_1.2.0-1_all.deb Wrapper for the Google TTS (Text-to-Speech) API (Python 2)
python-guacamole_0.9.2-2_all.deb framework for creating command line applications (Python 2)
python-guessit_0.11.0-2_all.deb library for guessing information from video filenames (Python 2)
python-guestfs_1.36.13-1ubuntu3_i386.deb guest disk image management system - Python bindings
python-guidata-doc_1.7.6-1_all.deb dataset manipulation GUI generator - Documentation
python-guidata_1.7.6-1_all.deb dataset manipulation GUI generator - Python 2
python-guiqwt-doc_3.0.3-2ubuntu1_all.deb efficient 2D data-plotting library - Documentation
python-guiqwt_3.0.3-2ubuntu1_i386.deb efficient 2D data-plotting library - Python 2
python-gumbo_0.10.1+dfsg-2.1_all.deb pure-C HTML5 parser Python bindings
Advertisement
Advertisement