python-gribapi_1.25.0-1_i386.deb


Advertisement

Description

python-gribapi - Python module for the ECMWF GRIB API library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-gribapi_1.25.0-1_i386.deb
Package name python-gribapi
Package version 1.25.0
Package release 1
Package architecture i386
Package type deb
Category universe/python
Homepage https://software.ecmwf.int/wiki/display/GRIB/Home
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 58.84 KB
Installed size 287.00 KB
The ECMWF GRIB API is an application program interface accessible from C and
FORTRAN programs developed for encoding and decoding WMO FM-92 GRIB edition 1
and edition 2 messages.
This is a Python wrapper for the GRIB API library.
ECMWF is the European Centre for Medium-Range Weather Forecasts.

Alternatives

Package Version Architecture Repository
python-gribapi_1.25.0-1_amd64.deb 1.25.0 amd64 Ubuntu Universe
python-gribapi - - -

Requires

Name Value
libc6 >= 2.4
libgomp1 >= 4.4
libgrib-api0 >= 1.14.3
libpython2.7 >= 2.7
python << 2.8
python >= 2.7~
python-numpy >= 1:1.13.1
python-numpy-abi9 -
python:any << 2.8
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-gribapi -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-gribapi_1.25.0-1_i386.deb
Source Package grib-api

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gribapi deb package:
    # sudo apt-get install python-gribapi

Files

Path
/usr/lib/python2.7/dist-packages/gribapi/__init__.py
/usr/lib/python2.7/dist-packages/gribapi/_gribapi_swig.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/gribapi/gribapi.py
/usr/lib/python2.7/dist-packages/gribapi/gribapi_swig.py
/usr/share/doc/python-gribapi/changelog.Debian.gz
/usr/share/doc/python-gribapi/copyright

Changelog

2018-01-03 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.25.0-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.1.2; no changes required
2017-11-28 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.24.0-3) unstable; urgency=medium
* Make grib-api-tools depend on libeccodes-data. Files needed.
Closes: #882995
* Mark libgrib-api-doc as M-A: foreign
2017-10-12 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.24.0-2) unstable; urgency=medium
* Remove build path from cmake, grib-api_ecbuild-config.h files for
bit-reproducibility
* Drop B-D on curl
2017-10-04 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.24.0-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.1.1; no changes required
2017-08-13 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.23.1-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.0.1
2017-08-03 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.23.0-3) unstable; urgency=medium
* Remove symlink. Closes: #870583
* Conflict: python3-gribapi and python3-eccodes
2017-08-02 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.23.0-2) unstable; urgency=medium
* Add link /usr/share/grib_api -> /usr/share/eccodes and _really_
dont ship the data
* Fix regression on python3.6 support in rules
2017-02-21 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.23.0-1) unstable; urgency=medium
* New upstream release
* S-V: 4.0.0; no changes required
2016-11-28 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.19.0-1) unstable; urgency=medium
* New upstream release
* Make libgrib-api-tools conflict with libeccodes-tools
2016-11-03 - Alastair McKinstry <mckinstry@debian.org>
grib-api (1.18.0-2) unstable; urgency=medium
* Build --no-parallel for FTBFS on some systems

See Also

Package Description
python-grokcore.component_2.5-0ubuntu1_all.deb Grok-like configuration for basic components
python-gssapi_1.4.1-1_i386.deb Python interface to GSSAPI
python-gst-1.0_1.14.0-1_i386.deb GStreamer GObject Introspection overrides for Python
python-gtextfsm_0.2.1-1_all.deb template based state machine for parsing semi-formatted text
python-gtk-gnash_0.8.11~git20160608-1.4_i386.deb GNU Shockwave Flash (SWF) player - Python bindings
python-gtk-vnc_0.7.2-1_i386.deb VNC viewer widget for GTK+2 (Python binding)
python-gtk2-dev_2.24.0-5.1ubuntu2_all.deb GTK+ bindings: devel files
python-gtk2-doc_2.24.0-5.1ubuntu2_all.deb Python bindings for the GTK+ widget set - documentation
python-gtk2_2.24.0-5.1ubuntu2_i386.deb Python bindings for the GTK+ widget set
python-gtkglext1_1.1.0-9.1_i386.deb GtkGLext python bindings
python-gtksourceview2_2.10.1-3_i386.deb Python bindings for the GtkSourceView widget
python-gtkspellcheck-doc_4.0.5-1_all.deb Python GTK+ Spellcheck common documentation
python-gtkspellcheck_4.0.5-1_all.deb Python 2 spellchecking library GTK+ based on Enchant
python-gts_0.3.1-6_i386.deb Python wrapper for the GNU Triangulated Surface library (GTS)
python-gtts-token_1.1.1-1_all.deb Calculates a token to run the Google Translate text to speech (Python 2)
Advertisement
Advertisement