python-gps_3.17-5_i386.deb


Advertisement

Description

python-gps - Global Positioning System - Python libraries

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-gps_3.17-5_i386.deb
Package name python-gps
Package version 3.17
Package release 5
Package architecture i386
Package type deb
Category universe/python
Homepage http://www.catb.org/gpsd/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 60.65 KB
Installed size 234.00 KB
The gpsd service daemon can monitor one or more GPS devices connected to
a host computer, making all data on the location and movements of the
sensors available to be queried on TCP port 2947.
This package contains a Python interface to connect to gpsd, together with
a module providing a controlled testing environment. It also ships two tools
which utilize the interface: gpsprof for latency-profiling, and gpsfake to
simulate a GPS by playing back a logfile.

Alternatives

Package Version Architecture Repository
python-gps_3.17-5_amd64.deb 3.17 amd64 Ubuntu Universe
python-gps - - -

Requires

Name Value
libc6 >= 2.4
python << 2.8
python >= 2.7
python:any >= 2.6.6-7~

Provides

Name Value
python2.7-gps -

Conflicts

Name Value
python-json -

Replaces

Name Value
gpsd-clients << 2.34.dfsg-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-gps_3.17-5_i386.deb
Source Package gpsd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gps deb package:
    # sudo apt-get install python-gps

Files

Path
/usr/bin/gpscat
/usr/bin/gpsfake
/usr/bin/gpsprof
/usr/lib/python2.7/dist-packages/gps-3.17.egg-info
/usr/lib/python2.7/dist-packages/gps/__init__.py
/usr/lib/python2.7/dist-packages/gps/client.py
/usr/lib/python2.7/dist-packages/gps/clienthelpers.so
/usr/lib/python2.7/dist-packages/gps/fake.py
/usr/lib/python2.7/dist-packages/gps/gps.py
/usr/lib/python2.7/dist-packages/gps/misc.py
/usr/lib/python2.7/dist-packages/gps/packet.so
/usr/share/doc/python-gps/changelog.Debian.gz
/usr/share/doc/python-gps/copyright
/usr/share/man/man1/gpscat.1.gz
/usr/share/man/man1/gpsfake.1.gz
/usr/share/man/man1/gpsprof.1.gz

Changelog

2017-12-28 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.17-5) unstable; urgency=medium
* [fd1e83f9] Add pkg-config as Build-Dependency.
Went missing somehow :(
* [6d0e69e3] Build with default compiler standard
* [8994d7cb] Actually change control.in, not control.
Needs an extra check to make sure I don't forget again :)
* [a744cad9] Updating debian/control from debian/control.in
2017-12-26 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.17-4) unstable; urgency=medium
* [cbbe97a4] Build against QT5.
Thanks to Lisandro Damián Nicanor Pérez Meyer (Closes: #874905)
* [aed76eeb] Depend on python-gi. (Closes: #885297)
2017-10-27 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.17-3) unstable; urgency=medium
* [2638b3e] Avoid duplicate ppscheck installation.
Thanks to Andreas Beckmann (Closes: #879951)
2017-10-26 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.17-2) unstable; urgency=medium
* Uploading to unstable.
* [a13df427] Fixing last changelog entry.
Some lines went missing, oops.
2017-10-21 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.17-1) experimental; urgency=medium
* [d21fbf15] Updated version 3.17 from 'upstream/3.17'
with Debian dir 3099dc33257e902647917f2ad7e67eec078b0b42
* [913ea95c] Fix SConstruct.
* [d9d7b300] Python dbg _d.so files are not built anymore.
* [f0ea0948] Install ppscheck + manpage
* [7df3aa0a] Updating symbols files
2016-11-04 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.16-4) unstable; urgency=medium
* [2405f456] Fix debug symbol handling.
Debug symbols went missing when upstream switched the strip
option name.
Thanks to Andre Naujoks (Closes: #842792)
* [74c3cd07] Updating debian/control from debian/control.in
* [b66410da] hadle debian/control creation a bit better
* [06a9623f] Use gz compression for now.
* [44376877] Remove obsolete build dependency on hardening-includes.
2016-09-24 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.16-3) unstable; urgency=medium
* [aa43cc65] Various patches were applied upstream.
Take them from there, removing our version.
* [1444f940] Build with -std=gnu++98. (Closes: #830993)
* [505d032a] Remove netbase/systemd-sysv dependency.
Not needed anymore. (Closes: #768100)
* [b53473f0] Migrate to github.
* [cb624dcb] Add travis.yml build stuff.
* [1c3c3463] Updating gbp.conf to ignore travis.yml for debuild.
* [d870a5c6] Don't rebuild for the static library.
2016-05-15 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.16-2) unstable; urgency=medium
* [5001c11a] Do not start gpsd.service by default.
We use socket based activation only.
If one needs a running gpsd.service at boot - without being started by
gpsd.socket - you'll have to configure systemd to start it.
Too many people have gpsd installed as dependency and do not need yet
another running process.
2016-04-30 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.16-1) unstable; urgency=medium
* [c3d16637] Merge tag 'upstream/3.16'
Upstream version 3.16
* [29863f7a] Snapshot changelog.
* [e61a749f] refreshing patches.
* [ddc25e61] Pick some patches from upstream.
- Fix test_gpsmm building
- Fix FTBFS on hurd (Closes: #821804)
* [67d9aca8] Fix check for clock_gettime.
* [67b39606] Update git-buildpackage config.
2015-10-31 - Bernd Zeimetz <bzed@debian.org>
gpsd (3.15-2) unstable; urgency=medium
* Uploading to unstable

See Also

Package Description
python-gpxpy_1.1.2-1_all.deb GPX file parser and GPS track manipulation library (Python 2)
python-gpyfft-doc_0.7.0-1_all.deb Wrapper for the OpenCL FFT library clFFT (common documentation)
python-gpyfft_0.7.0-1_i386.deb Wrapper for the OpenCL FFT library clFFT (Python 2)
python-grapefruit-doc_0.1~a3+dfsg-1_all.deb Python module to manipulate color information easily - documentation
python-grapefruit_0.1~a3+dfsg-1_all.deb Python module to manipulate color information easily
python-graphy_1.0+dfsg-3build1_all.deb chart generation library for Python
python-graypy_0.2.14-1_all.deb Python logging handler that sends messages in GELF (Python 2)
python-grib-doc_2.0.2-3_all.deb Documentation and examples for Python GRIB
python-grib_2.0.2-3_i386.deb Python module for reading and writing GRIB files
python-gribapi_1.25.0-1_i386.deb Python module for the ECMWF GRIB API library
python-grokcore.component_2.5-0ubuntu1_all.deb Grok-like configuration for basic components
python-gssapi_1.4.1-1_i386.deb Python interface to GSSAPI
python-gst-1.0_1.14.0-1_i386.deb GStreamer GObject Introspection overrides for Python
python-gtextfsm_0.2.1-1_all.deb template based state machine for parsing semi-formatted text
python-gtk-gnash_0.8.11~git20160608-1.4_i386.deb GNU Shockwave Flash (SWF) player - Python bindings
Advertisement
Advertisement