python-git_2.1.8-1_all.deb


Advertisement

Description

python-git - Python library to interact with Git repositories - Python 2.7

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-git_2.1.8-1_all.deb
Package name python-git
Package version 2.1.8
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/gitpython-developers/GitPython
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 294.12 KB
Installed size 1.61 MB
python-git provides object model access to a Git repository, so Python can be
used to manipulate it. Repository objects can be opened or created, which can
then be traversed to find parent commit(s), trees, blobs, etc.
This package provides the Python 2.7 module.

Alternatives

Package Version Architecture Repository
python-git_2.1.8-1_all.deb 2.1.8 all Ubuntu Universe
python-git - - -

Requires

Name Value
git >= 1:1.7
git-core >= 1:1.5.3.7
python-gitdb >= 2
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-git_2.1.8-1_all.deb
Source Package python-git

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-git deb package:
    # sudo apt-get install python-git

Files

Path
/usr/lib/python2.7/dist-packages/GitPython-2.1.8.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/GitPython-2.1.8.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/GitPython-2.1.8.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/GitPython-2.1.8.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/GitPython-2.1.8.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/git/__init__.py
/usr/lib/python2.7/dist-packages/git/cmd.py
/usr/lib/python2.7/dist-packages/git/compat.py
/usr/lib/python2.7/dist-packages/git/config.py
/usr/lib/python2.7/dist-packages/git/db.py
/usr/lib/python2.7/dist-packages/git/diff.py
/usr/lib/python2.7/dist-packages/git/exc.py
/usr/lib/python2.7/dist-packages/git/odict.py
/usr/lib/python2.7/dist-packages/git/remote.py
/usr/lib/python2.7/dist-packages/git/util.py
/usr/lib/python2.7/dist-packages/git/index/__init__.py
/usr/lib/python2.7/dist-packages/git/index/base.py
/usr/lib/python2.7/dist-packages/git/index/fun.py
/usr/lib/python2.7/dist-packages/git/index/typ.py
/usr/lib/python2.7/dist-packages/git/index/util.py
/usr/lib/python2.7/dist-packages/git/objects/__init__.py
/usr/lib/python2.7/dist-packages/git/objects/base.py
/usr/lib/python2.7/dist-packages/git/objects/blob.py
/usr/lib/python2.7/dist-packages/git/objects/commit.py
/usr/lib/python2.7/dist-packages/git/objects/fun.py
/usr/lib/python2.7/dist-packages/git/objects/tag.py
/usr/lib/python2.7/dist-packages/git/objects/tree.py
/usr/lib/python2.7/dist-packages/git/objects/util.py
/usr/lib/python2.7/dist-packages/git/objects/submodule/__init__.py
/usr/lib/python2.7/dist-packages/git/objects/submodule/base.py
/usr/lib/python2.7/dist-packages/git/objects/submodule/root.py
/usr/lib/python2.7/dist-packages/git/objects/submodule/util.py
/usr/lib/python2.7/dist-packages/git/refs/__init__.py
/usr/lib/python2.7/dist-packages/git/refs/head.py
/usr/lib/python2.7/dist-packages/git/refs/log.py
/usr/lib/python2.7/dist-packages/git/refs/reference.py
/usr/lib/python2.7/dist-packages/git/refs/remote.py
/usr/lib/python2.7/dist-packages/git/refs/symbolic.py
/usr/lib/python2.7/dist-packages/git/refs/tag.py
/usr/lib/python2.7/dist-packages/git/repo/__init__.py
/usr/lib/python2.7/dist-packages/git/repo/base.py
/usr/lib/python2.7/dist-packages/git/repo/fun.py
/usr/lib/python2.7/dist-packages/git/test/__init__.py
/usr/lib/python2.7/dist-packages/git/test/test_actor.py
/usr/lib/python2.7/dist-packages/git/test/test_base.py
/usr/lib/python2.7/dist-packages/git/test/test_blob.py
/usr/lib/python2.7/dist-packages/git/test/test_commit.py
/usr/lib/python2.7/dist-packages/git/test/test_config.py
/usr/lib/python2.7/dist-packages/git/test/test_db.py
/usr/lib/python2.7/dist-packages/git/test/test_diff.py
/usr/lib/python2.7/dist-packages/git/test/test_docs.py
/usr/lib/python2.7/dist-packages/git/test/test_exc.py
/usr/lib/python2.7/dist-packages/git/test/test_fun.py
/usr/lib/python2.7/dist-packages/git/test/test_git.py
/usr/lib/python2.7/dist-packages/git/test/test_index.py
/usr/lib/python2.7/dist-packages/git/test/test_reflog.py
/usr/lib/python2.7/dist-packages/git/test/test_refs.py
/usr/lib/python2.7/dist-packages/git/test/test_remote.py
/usr/lib/python2.7/dist-packages/git/test/test_repo.py
/usr/lib/python2.7/dist-packages/git/test/test_stats.py
/usr/lib/python2.7/dist-packages/git/test/test_submodule.py
/usr/lib/python2.7/dist-packages/git/test/test_tree.py
/usr/lib/python2.7/dist-packages/git/test/test_util.py
/usr/lib/python2.7/dist-packages/git/test/fixtures/blame
/usr/lib/python2.7/dist-packages/git/test/fixtures/blame_binary
/usr/lib/python2.7/dist-packages/git/test/fixtures/blame_complex_revision
/usr/lib/python2.7/dist-packages/git/test/fixtures/blame_incremental
/usr/lib/python2.7/dist-packages/git/test/fixtures/blame_incremental_2.11.1_plus
/usr/lib/python2.7/dist-packages/git/test/fixtures/cat_file.py
/usr/lib/python2.7/dist-packages/git/test/fixtures/cat_file_blob
/usr/lib/python2.7/dist-packages/git/test/fixtures/cat_file_blob_nl
/usr/lib/python2.7/dist-packages/git/test/fixtures/cat_file_blob_size
/usr/lib/python2.7/dist-packages/git/test/fixtures/commit_invalid_data
/usr/lib/python2.7/dist-packages/git/test/fixtures/commit_with_gpgsig
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_2
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_2f
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_abbrev-40_full-index_M_raw_no-color
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_f
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_file_with_spaces
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_i
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_index_patch
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_index_raw
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_initial
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_mode_only
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_new_mode
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_numstat
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_p
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_patch_binary
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_patch_unsafe_paths
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_raw_binary
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_rename
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_rename_raw
/usr/lib/python2.7/dist-packages/git/test/fixtures/diff_tree_numstat_root
/usr/lib/python2.7/dist-packages/git/test/fixtures/for_each_ref_with_path_component
/usr/lib/python2.7/dist-packages/git/test/fixtures/git_config
/usr/lib/python2.7/dist-packages/git/test/fixtures/git_config-inc.cfg
/usr/lib/python2.7/dist-packages/git/test/fixtures/git_config_global
/usr/lib/python2.7/dist-packages/git/test/fixtures/git_config_with_comments
/usr/lib/python2.7/dist-packages/git/test/fixtures/git_config_with_empty_value
/usr/lib/python2.7/dist-packages/git/test/fixtures/git_file
/usr/lib/python2.7/dist-packages/git/test/fixtures/index
/usr/lib/python2.7/dist-packages/git/test/fixtures/index_merge
/usr/lib/python2.7/dist-packages/git/test/fixtures/issue-301_stderr
/usr/lib/python2.7/dist-packages/git/test/fixtures/ls_tree_a
/usr/lib/python2.7/dist-packages/git/test/fixtures/ls_tree_b
/usr/lib/python2.7/dist-packages/git/test/fixtures/ls_tree_commit
/usr/lib/python2.7/dist-packages/git/test/fixtures/ls_tree_empty
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_HEAD
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_invalid_date
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_invalid_email
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_invalid_newsha
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_invalid_oldsha
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_invalid_sep
/usr/lib/python2.7/dist-packages/git/test/fixtures/reflog_master
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_bisect_all
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_commit_diffs
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_commit_idabbrev
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_commit_stats
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_count
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_delta_a
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_delta_b
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_list_single
/usr/lib/python2.7/dist-packages/git/test/fixtures/rev_parse
/usr/lib/python2.7/dist-packages/git/test/fixtures/show_empty_commit
/usr/lib/python2.7/dist-packages/git/test/fixtures/uncommon_branch_prefix_FETCH_HEAD
/usr/lib/python2.7/dist-packages/git/test/fixtures/uncommon_branch_prefix_stderr
/usr/lib/python2.7/dist-packages/git/test/lib/__init__.py
/usr/lib/python2.7/dist-packages/git/test/lib/asserts.py
/usr/lib/python2.7/dist-packages/git/test/lib/helper.py
/usr/lib/python2.7/dist-packages/git/test/performance/__init__.py
/usr/lib/python2.7/dist-packages/git/test/performance/lib.py
/usr/lib/python2.7/dist-packages/git/test/performance/test_commit.py
/usr/lib/python2.7/dist-packages/git/test/performance/test_odb.py
/usr/lib/python2.7/dist-packages/git/test/performance/test_streams.py
/usr/share/doc/python-git/TODO.Debian
/usr/share/doc/python-git/changelog.Debian.gz
/usr/share/doc/python-git/copyright
/usr/share/doc/python-git/_static/jquery.js

Changelog

2018-01-20 - TANIGUCHI Takaki <takaki@debian.org>
python-git (2.1.8-1) unstable; urgency=medium
* New upstream version 2.1.8 (Closes: #880446)
- Fix "Incompatible with git 2.15?" (Closes: #879452)
* debian/control: Replace python3-sphinx instead of python2-sphinx
* delete debian/patches/0001-recognize-the-new-packed-ref-header-format.patch
Upstream merged
2017-11-06 - Yaroslav Halchenko <debian@onerussian.com>
python-git (2.1.7-1) unstable; urgency=medium
* New upstream release
2017-09-26 - Yaroslav Halchenko <debian@onerussian.com>
python-git (2.1.6-1) unstable; urgency=medium
* New upstream release
- fixes for submodules with names consisting of numbers and bools
- worktree support
2017-06-27 - TANIGUCHI Takaki <takaki@debian.org>
python-git (2.1.5-1) unstable; urgency=medium
* New upstream version 2.1.5
* Bump Standards-Verision to 4.0.0 (without changes). 
2017-06-05 - Yaroslav Halchenko <debian@onerussian.com>
python-git (2.1.3-1) experimental; urgency=medium
* Fresh bugfix upstream release
- upstreamed debian/patches/exe_exception.patch
2017-03-09 - TANIGUCHI Takaki <takaki@debian.org>
python-git (2.1.1-2) unstable; urgency=medium
* debian/patches/exe_exception.patch: Fix "import of git can cause import
failures of unrelated modules due to undefined variable" (Closes: #857171)
2017-02-02 - TANIGUCHI Takaki <takaki@debian.org>
python-git (2.1.1-1) unstable; urgency=medium
* New upstream version 2.1.1
2016-11-02 - Yaroslav Halchenko <debian@onerussian.com>
python-git (2.1.0-1) unstable; urgency=medium
* Fresh upstream release (necessary for upcoming release of datalad)
* Require smmap and gitdb >= 2
* Enable build-time testing back while building NeuroDebian backports
2016-10-17 - TANIGUCHI Takaki <takaki@debian.org>
python-git (2.0.9-1) unstable; urgency=medium
[ Yaroslav Halchenko ]
* debian/TODO to reincarnate testing
[ TANIGUCHI Takaki ]
* New upstream version 2.0.9
2016-09-22 - Yaroslav Halchenko <debian@onerussian.com>
python-git (2.0.8-1) unstable; urgency=medium
* New upstream version
* No custom patches any longer -- absorbed upstream

See Also

Package Description
python-gitdb_2.0.3-1_all.deb pure-Python git object database (Python 2)
python-github_1.26.0-1_all.deb Access to full Github API v3 from Python2
python-gitlab-doc_1.3.0-2_all.deb Python 3 GitLab API client library - documentation
python-gitlab_1.3.0-2_all.deb Python GitLab API client library
python-glade2_2.24.0-5.1ubuntu2_i386.deb GTK+ bindings: Glade support
python-glare_0.4.1-3ubuntu1_all.deb OpenStack Artifact Repository - Python 2.7 library
python-glareclient-doc_0.5.2-0ubuntu1_all.deb Client library for Openstack glare server - doc
python-glareclient_0.5.2-0ubuntu1_all.deb Client library for Openstack glare server - Python 2.x
python-glob2_0.5-2_all.deb Enhanced glob module for Python
python-glue_0.9.1+dfsg-1_all.deb Python 2 library for data interaction
python-gmplot_1.1.1-1_all.deb matplotlib-like interface to plotting data with Google Maps
python-gmpy-doc_1.17-3_all.deb interfaces GMP to Python for fast, unbound-precision computations
python-gmpy2-common_2.0.8-2build3_all.deb interfaces GMP to Python for fast, unbound-precision computations
python-gmpy2-doc_2.0.8-2build3_all.deb interfaces GMP to Python for fast, unbound-precision computations
python-gmpy2_2.0.8-2build3_i386.deb interfaces GMP to Python 2 for fast, unbound-precision computations
Advertisement
Advertisement