python-ftdi1_1.4-1build1_i386.deb


Advertisement

Description

python-ftdi1 - Python module to control and program the FTDI USB controllers

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-ftdi1_1.4-1build1_i386.deb
Package name python-ftdi1
Package version 1.4
Package release 1build1
Package architecture i386
Package type deb
Category universe/python
Homepage https://www.intra2net.com/en/developer/libftdi/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 43.75 KB
Installed size 277.00 KB
This library could talk to FTDI's FT232BM, FT245BM, FT2232C, FT2232D, FT245R,
FT232H and FT230X type USB chips from userspace. It uses libusb 1.0 to
communicate with the chips.
Functionalities include the possibility to use the chips in standard
mode, in bitbang mode, and to read or write the serial EEPROM.
This package provides the ftdi1 module on the Python 2 module path. It
is complemented by python3-ftdi1.

Alternatives

Package Version Architecture Repository
python-ftdi1_1.4-1build1_amd64.deb 1.4 amd64 Ubuntu Universe
python-ftdi1 - - -

Requires

Name Value
libc6 >= 2.4
libftdi1-2 >= 1.4
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-ftdi1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-ftdi1_1.4-1build1_i386.deb
Source Package libftdi1

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ftdi1 deb package:
    # sudo apt-get install python-ftdi1

Files

Path
/usr/lib/python2.7/dist-packages/_ftdi1.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/ftdi1.py
/usr/share/doc/python-ftdi1/changelog.Debian.gz
/usr/share/doc/python-ftdi1/copyright

Changelog

2017-12-06 - Matthias Klose <doko@ubuntu.com>
libftdi1 (1.4-1build1) bionic; urgency=medium
* No-change rebuild for libconfuse soname change.
2017-11-26 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.4-1) unstable; urgency=medium
* New upstream version:
- Update libftdi1-2 symbols file.
- Rename libftdipp1-2v5 into libftdi1pp-3 following soname change.
* debian/control: update to use https link.
* debian/copyright: update to use https link.
* Add debian/upstream/signing-key.asc.
* Switch to debhelper 10.
* Bumped Standards-Version to 4.1.1.
2016-08-04 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.3-2) unstable; urgency=medium
* debian/patches/01-cmake-multiarch.diff: update to also fix
LIBFTDI_USE_FILE in multiarch systems. Thanks to Jochen Sprickerhof
for the patch (closes: #832617).
* debian/rules: enable the C++ library even for the python builds so
that LibFTDI1Config.cmake contains both LIBFTDI_PYTHON_MODULE_PATH
and LIBFTDIPP* entries.
2016-06-01 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.3-1) unstable; urgency=medium
* New upstream version.
* Stop building -dbg packages, please use the -dbgsym packages instead.
* Move the documentation from libftdi1-dev to libftdi1-doc as
recommended by recent policy versions.
* Bumped Standards-Version to 3.9.8.
2015-10-24 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.2-5) unstable; urgency=medium
* Don't link python extensions with the python interpreter (closes:
#802809).
2015-08-03 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.2-4) unstable; urgency=medium
* Rename libftdipp1-2 into libftdipp1-2v5 for the GCC 5 ABI transition.
* Build-depends on g++ (>= 4:5.2) and boost (>= 1.58).
* Force C++ standard to c++11 to prepare for the GCC 6 transition.
2015-07-29 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.2-3) unstable; urgency=medium
* Upstream uses SWIG + CMake to build the Python bindings, and TTBOMK
this gives no easy way to install a Python shared library whose name
includes the ABI. To fix the installation with multiple Python
versions, rename the shared library to include the ABI just after
calling "make install" (closes: #793830).
2015-07-18 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.2-2) unstable; urgency=medium
* Fix 01-cmake-multiarch.diff to correctly generate libftdi1.pc.
2015-04-27 - Aurelien Jarno <aurel32@debian.org>
libftdi1 (1.2-1) unstable; urgency=low
* New package based on libftdi providing a new upstream version with
an incompatible API (closes: #706301, #766582, #781545).

See Also

Package Description
python-fte_0.1.0-1_i386.deb encryption library to thwart deep packet inspection censorship
python-ftp-cloudfs_0.35-0ubuntu1_all.deb FTP interface to Rackspace Cloud Files and OpenStack - Python lib
python-fudge-doc_1.1.0-1_all.deb Python module for using fake objects for tests, documentation package
python-fudge_1.1.0-1_all.deb Python 2 module for using fake objects for tests
python-funcparserlib_0.3.6-7_all.deb Recursive descent parsing library based on functional combinators
python-fuse_0.2.1-16_i386.deb Python bindings for FUSE (Filesystems in USErspace)
python-fusepy_2.0.4-1_all.deb simple Python interface to FUSE (Python 2)
python-fuzzywuzzy_0.16.0-1_all.deb Python module for fuzzy string matching
python-fysom_2.1.5-1_all.deb pYthOn Finite State Machine
python-gabbi-doc_1.40.0-0ubuntu1_all.deb declarative HTTP testing library - doc
python-gabbi_1.40.0-0ubuntu1_all.deb declarative HTTP testing library - Python 2.x
python-gadfly_1.0.0-16_all.deb SQL database and parser generator for Python
python-galpy_1.3.0-1_i386.deb Python 2 package for Galactic Dynamics
python-gamera-dev_3.4.2+git20160808.1725654-2_all.deb framework for document analysis applications (header files)
python-gamera.toolkits.greekocr_1.0.1-10_all.deb toolkit for building OCR systems for polytonal Greek
Advertisement
Advertisement