python-epr_0.9.3-5_i386.deb


Advertisement

Description

python-epr - Python ENVISAT Product Reader API (Python 2)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-epr_0.9.3-5_i386.deb
Package name python-epr
Package version 0.9.3
Package release 5
Package architecture i386
Package type deb
Category universe/python
Homepage https://avalentino.github.com/pyepr
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 94.88 KB
Installed size 373.00 KB
PyEPR provides Python bindings for the ENVISAT Product Reader C API
(EPR API) for reading satellite data from ENVISAT ESA (European Space
Agency) mission.
PyEPR, as well as the EPR API for C, supports ENVISAT MERIS, AATSR
Level 1B and Level 2 and also ASAR data products. It provides access
to the data either on a geophysical (decoded, ready-to-use pixel
samples) or on a raw data layer. The raw data access makes it possible
to read any data field contained in a product file.
This is the Python 2 version of the package.

Alternatives

Package Version Architecture Repository
python-epr_0.9.3-5_amd64.deb 0.9.3 amd64 Ubuntu Universe
python-epr - - -

Requires

Name Value
libc6 >= 2.4
libepr-api2 >= 2.2
python << 2.8
python >= 2.7~
python-numpy >= 1:1.13.1
python-numpy-abi9 -
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-epr_0.9.3-5_i386.deb
Source Package pyepr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-epr deb package:
    # sudo apt-get install python-epr

Files

Path
/usr/lib/python2.7/dist-packages/epr.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/pyepr-0.9.3.egg-info
/usr/share/doc/python-epr/NEWS.txt.gz
/usr/share/doc/python-epr/changelog.Debian.gz
/usr/share/doc/python-epr/copyright

Changelog

2018-02-26 - Bas Couwenberg <sebastic@debian.org>
pyepr (0.9.3-5) unstable; urgency=medium
* Team upload.
* Add Breaks/Replaces to python-epr-doc for files moved from python-epr.
(closes: #891514)
2018-02-25 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.9.3-4) unstable; urgency=medium
[ Bas Couwenberg ]
* Change priority from extra to optional.
* Bump Standards-Version to 4.1.0, changes: priority.
* Add python3-sphinx to build dependencies.
* Strip trailing whitespace from changelog.
* Add autopkgtest to test installability.
* Add upstream metadata.
[ Antonio Valentino ]
* Bump Standards-Version to 4.1.3, no changes.
* Set compat to 11.
* debian/control
- use secure URL for HomePage
- fix python2-epr-dbg recommends to point to python3-numpy-dbg
* debian/rules
- fix doc installation
- remove unnecessary dh argument: --parallel
2017-08-15 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.9.3-3) unstable; urgency=medium
* Restore -dbg packages
2017-08-08 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.9.3-2) unstable; urgency=medium
[ Bas Couwenberg ]
* Team upload.
* Add gbp.conf to use pristine-tar by default.
* Override dh_python{2,3} to call dh_numpy{,3} too.
* Drop .0 from GPL license shortnames.
[ Antonio Valentino ]
* remove dbg packages form the control file (now they are generated
automatically)
* switch to pybuild
* refresh all patches
* debian/copyright
- fix format URL
* debian/control
- standard version bumped to 4.0.0 (no change)
- remove un-necessary version specification
- update VCS URLs
- reformat using cme
- add Multi-Arch specifiers
* debian/rules
- no longer parse debian changelog (fix lintian warning)
- enable hardening flags
- enable parallel build
* debian/links file removed (no longer necessary)
2015-08-15 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.9.3-1) unstable; urgency=medium
* New upstream release
* debian/watch file fixed
* Refresh all patches
* Build-depends on python3-doc innstead of python-doc
* Update copyright file
* HTML doc is no longer compressed
* Make the package build reproducible (closes: #788246)
2015-01-10 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.8.2-1) unstable; urgency=medium
* New upstream release
* debian/control
- added an explicit build dependency from dh-python
- Standard version bumped to 3.9.6 (no changes)
- fix Vcs-Browser URL
* debian/patches
- updated 0001-Only-use-local-files-for-generating-sphinx-doc.patch:
do not include links to the ohloh and travis-ci widgets
2014-05-18 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.8.1-2) unstable; urgency=medium
* Standards-Version bumped to 3.9.5 (no change)
* Fixed file conflicts in binary packages (Closes: #748237)
* debian/control
- build-depend on the new libepr-api-dev instead of
libepr-api2-dev
2013-10-26 - Antonio Valentino <antonio.valentino@tiscali.it>
pyepr (0.8.1-1) unstable; urgency=low
* New upstream release
* Compat set to 9
* debian/control
- Build-depend from debhelper (>= 9)
- Removed unnecessary versioned dependency from libepr-api2-dev (>= 2.2)
- Removed unnecessary "${sphinxdoc:Depends}" from non-doc packages
- Added build dependencies from python-doc and python-numpy-doc.
It is necessary to make the package build self-contained.
* debian/copyright
- Updated copyright dates
- Fixed formatting of copyright file
* debian/patches:
- Only use local files for generating sphinx doc.
Set the "intersphinx_mapping" parameter in the doc/conf.py to
point to local object.inv files.
This makes the package self contained and no download attempt
happens any longer (Closes: #726859).

See Also

Package Description
python-epsilon_0.7.1-1_all.deb Python utility modules commonly used by Divmod.org project
python-epydoc_3.0.1+dfsg-17_all.deb tool for documenting Python modules
python-escript-doc_5.1-5_all.deb Documentation for Escript/Finley
python-escript-mpi_5.1-5_i386.deb Escript/Finley finite elements Python2 system (OpenMP + MPI)
python-escript_5.1-5_i386.deb Escript/Finley finite elements Python2 system (with OpenMP)
python-esmre_0.3.1-3build3_i386.deb Regular expression acceleration in Python2
python-espeak_0.5-1build5_i386.deb Python bindings for eSpeak
python-et-xmlfile_1.0.1-2_all.deb low memory library for creating large XML files (Python 2)
python-etcd3gw-doc_0.2.1-1_all.deb client for etcd3 grpc-gateway v3 API - doc
python-etcd3gw_0.2.1-1_all.deb client for etcd3 grpc-gateway v3 API - Python 2.7
python-etcd_0.4.3-2_all.deb Python Etcd client library
python-ethtool_0.12-1.1_i386.deb Python bindings for the ethtool kernel interface
python-evdev-doc_0.7.0+dfsg-2_all.deb Python bindings for the Linux input subsystem (docs)
python-evdev_0.7.0+dfsg-2_i386.deb Python bindings for the Linux input subsystem
python-evemu_2.6.0-0.1_i386.deb Linux Input Event Device Emulation Library - Python bindings
Advertisement
Advertisement