python-elasticsearch-curator_5.2.0-1_all.deb


Advertisement

Description

python-elasticsearch-curator - Python library for managing Elasticsearch time-series indices

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-elasticsearch-curator_5.2.0-1_all.deb
Package name python-elasticsearch-curator
Package version 5.2.0
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/elasticsearch/curator
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 56.63 KB
Installed size 361.00 KB
Elasticsearch Curator helps manage Elasticsearch time-series indices. It
consists of a Python library and a CLI tool providing a high-level interface
to Elasticsearch administration tasks, such as:
- Management of index aliases
- Index optimization
- Changing the replica count
- Modifying the shard/index allocation using routing tags
- Index snapshotting
This package contains the Python 2 version of the library.

Alternatives

Package Version Architecture Repository
python-elasticsearch-curator_5.2.0-1_all.deb 5.2.0 all Ubuntu Universe
python-elasticsearch-curator - - -

Requires

Name Value
python-certifi -
python-click -
python-elasticsearch >= 5.0.0
python-elasticsearch << 6.0.0
python-pkg-resources -
python-voluptuous -
python-yaml -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-elasticsearch-curator_5.2.0-1_all.deb
Source Package elasticsearch-curator

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-elasticsearch-curator deb package:
    # sudo apt-get install python-elasticsearch-curator

Files

Path
/usr/lib/python2.7/dist-packages/curator/__init__.py
/usr/lib/python2.7/dist-packages/curator/__main__.py
/usr/lib/python2.7/dist-packages/curator/_version.py
/usr/lib/python2.7/dist-packages/curator/actions.py
/usr/lib/python2.7/dist-packages/curator/cli.py
/usr/lib/python2.7/dist-packages/curator/config_utils.py
/usr/lib/python2.7/dist-packages/curator/curator_cli.py
/usr/lib/python2.7/dist-packages/curator/exceptions.py
/usr/lib/python2.7/dist-packages/curator/indexlist.py
/usr/lib/python2.7/dist-packages/curator/logtools.py
/usr/lib/python2.7/dist-packages/curator/repomgrcli.py
/usr/lib/python2.7/dist-packages/curator/singletons.py
/usr/lib/python2.7/dist-packages/curator/snapshotlist.py
/usr/lib/python2.7/dist-packages/curator/utils.py
/usr/lib/python2.7/dist-packages/curator/defaults/__init__.py
/usr/lib/python2.7/dist-packages/curator/defaults/client_defaults.py
/usr/lib/python2.7/dist-packages/curator/defaults/filter_elements.py
/usr/lib/python2.7/dist-packages/curator/defaults/filtertypes.py
/usr/lib/python2.7/dist-packages/curator/defaults/option_defaults.py
/usr/lib/python2.7/dist-packages/curator/defaults/settings.py
/usr/lib/python2.7/dist-packages/curator/validators/__init__.py
/usr/lib/python2.7/dist-packages/curator/validators/actions.py
/usr/lib/python2.7/dist-packages/curator/validators/config_file.py
/usr/lib/python2.7/dist-packages/curator/validators/filters.py
/usr/lib/python2.7/dist-packages/curator/validators/options.py
/usr/lib/python2.7/dist-packages/curator/validators/schemacheck.py
/usr/lib/python2.7/dist-packages/elasticsearch_curator-5.2.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/elasticsearch_curator-5.2.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/elasticsearch_curator-5.2.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/elasticsearch_curator-5.2.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/elasticsearch_curator-5.2.0.egg-info/top_level.txt
/usr/share/doc/python-elasticsearch-curator/NEWS.Debian.gz
/usr/share/doc/python-elasticsearch-curator/changelog.Debian.gz
/usr/share/doc/python-elasticsearch-curator/copyright

Changelog

2017-10-17 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (5.2.0-1) unstable; urgency=medium
[ Aggelos Avgerinos ]
* Bump standards version; no changes needed
* Bump compat and debhelper versions; no changes needed
* d/control: Bump python-elasticsearch dependency version
[ Apollon Oikonomopoulos ]
* New upstream version. (Closes: #865288)
* Add Aggelos to Uploaders.
* B-D on python3-sphinx.
2017-01-02 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (4.2.5-1) unstable; urgency=medium
* New upstream release
2016-12-16 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (4.2.4-1) unstable; urgency=medium
* New upstream release
* Build and ship asciidoc documentation as reference.txt.gz
* B-D on python{3,}-voluptuous and python{3,}-yaml; required for building
the sphinx documentation.
* Add curator_cli(1) manpage
* Update the curator(1) and es_repo_mgr(1) manpages
2016-09-10 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (4.1.0-1) unstable; urgency=medium
* New upstream release.
2016-09-07 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (4.0.6-1) unstable; urgency=medium
* New upstream release
* Set elasticsearch-curator's Section to admin (Closes: #832206)
2016-07-22 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (4.0.1-2) unstable; urgency=medium
* Restrict intersphinx from downloading object inventory data (Closes:
#830550):
+ sphinx: use local inventory references for intersphinx
+ B-D on python3-doc and python-elasticsearch-doc
2016-06-29 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (4.0.1-1) unstable; urgency=medium
* New upstream release.
* The 'DebConf16' upload.
* Bump Standards to 3.9.8; no changes needed.
* d/watch: uversionmangle upstream's alphas and betas.
2016-03-21 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (3.5.1-1) unstable; urgency=medium
* New upstream release.
2016-02-12 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (3.4.1-1) unstable; urgency=medium
* New upstream release.
* Bump standards to 3.9.7; no changes needed.
* d/control: Use HTTPS in Vcs-Git.
* d/copyright: extend to 2016.
2015-11-04 - Apollon Oikonomopoulos <apoikos@debian.org>
elasticsearch-curator (3.4.0-1) unstable; urgency=medium
* New upstream release
+ Elasticsearch 2.0 support
* Add B-D on python{,3}-click (Closes: #802962)
* Add DEP-8 tests
* d/watch: mangle upstream RC versions

See Also

Package Description
python-elasticsearch-doc_5.4.0-1_all.deb Python client for Elasticsearch (Documentation)
python-elasticsearch_5.4.0-1_all.deb Python client for Elasticsearch
python-elements_0.13+svn20090823.230+dfsg-2.1_all.deb A 2D Physics API for Python
python-elementtidy_1.0-8build1_i386.deb An HTML tree builder for ElementTree based on Tidy
python-elib.intl_0.0.3~git20110809-5_all.deb enhanced internationalization (I18N) for Python
python-elixir_0.7.1-4build1_all.deb declarative mapper for SQLAlchemy
python-emcee_2.2.1-1_all.deb Affine-invariant ensemble MCMC sampling for Python
python-empy-doc_3.3.2-1build1_all.deb documentation for python-empy
python-empy_3.3.2-1build1_all.deb templating system for Python (Python 2)
python-enable_4.5.1-4_i386.deb Drawing and interaction packages
python-enchant_2.0.0-1_all.deb spellchecking library for Python
python-enet_0.0~vcs.2017.05.26.git-2_i386.deb Python2 wrapper for the ENet library
python-enki2_1.6.0-5_i386.deb Python bindings for the library libenki2
python-enthoughtbase_3.1.0-2build1_all.deb Core packages for the Enthought Tool Suite
python-entrypoints_0.2.3-1_all.deb Discover and load entry points from installed packages (Python 2)
Advertisement
Advertisement