python-ecflow_4.8.0-1_i386.deb


Advertisement

Description

python-ecflow - Python libraries for ecFlow workflow tools

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-ecflow_4.8.0-1_i386.deb
Package name python-ecflow
Package version 4.8.0
Package release 1
Package architecture i386
Package type deb
Category universe/python
Homepage https://software.ecmwf.int/wiki/display/ECFLOW/The+ECFLOW+Pre-processor
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.08 MB
Installed size 11.61 MB
ecFlow is a meteorological work flow package that enables
users to run a large number of programs ( with dependencies
on each other and on time) in a controlled environment.
This package contains Python modules used in writing ecflow scripts.

Alternatives

Package Version Architecture Repository
python-ecflow_4.8.0-1_amd64.deb 4.8.0 amd64 Ubuntu Universe
python-ecflow - - -

Requires

Name Value
libboost-date-time1.65.1 -
libboost-filesystem1.65.1 -
libboost-program-options1.65.1 -
libboost-python1.65.1 -
libboost-serialization1.65.1 -
libboost-system1.65.1 -
libc6 >= 2.9
libecflow-view0d = 4.8.0-1
libgcc1 >= 1:4.2
libpython2.7 >= 2.7
libstdc++6 >= 5.2
python >= 2.7~
python << 2.8
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-ecflow_4.8.0-1_i386.deb
Source Package ecflow

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ecflow deb package:
    # sudo apt-get install python-ecflow

Files

Path
/usr/lib/python2.7/dist-packages/ecflow/__init__.py
/usr/lib/python2.7/dist-packages/ecflow/ecf.py
/usr/lib/python2.7/dist-packages/ecflow/ecflow.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/ecflow/sms2ecf.py
/usr/share/doc/python-ecflow/changelog.Debian.gz
/usr/share/doc/python-ecflow/copyright

Changelog

2018-02-02 - Alastair McKinstry <mckinstry@debian.org>
ecflow (4.8.0-1) unstable; urgency=medium
* New upstream release
* Build-depend on libqt5svg5-dev
* Standards-Version: 4.1.3
* Move VCS to salsa
* Patch for boost::python:tuple ambiguity with new stdc::tuple
* Drop ecflow_migrate: not installed upstream
2017-11-20 - Alastair McKinstry <mckinstry@debian.org>
ecflow (4.7.1+dfsg.1-2) unstable; urgency=medium
* Set -DDISABLE_OS_CHECK=ON for Hurd build
2017-11-12 - Alastair McKinstry <mckinstry@debian.org>
ecflow (4.7.1+dfsg.1-1) unstable; urgency=medium
* New upstream release
* Don't use slurm (optional) on hurd, kfreebsd (not available there)
2017-10-14 - Alastair McKinstry <mckinstry@debian.org>
ecflow (4.7.0-1) unstable; urgency=medium
* Compile -fPIC on hppa. Closes: #875464
* Standards-Version: 4.1.1; no changes required
* Updates to auto_ptr.patch
* Compile with -DNO_REGEXP to cope with regexp.h changes in glibc
* Patch for typo in ecflow_logsvr
2017-09-09 - Alastair McKinstry <mckinstry@debian.org>
ecflow (4.6.1-2) unstable; urgency=medium
* Fix FTBFS with g++7. Closes: #873834
* Standards-Version: 4.1.0; no changes required
* Fix missing "from __future__ " clause in python3 patch. Closes: #874734
2017-07-17 - Alastair McKinstry <mckinstry@debian.org>
ecflow (4.6.1-1) unstable; urgency=medium
* Initial release. (Closes: #679237)

See Also

Package Description
python-ecryptfs_111-0ubuntu5_i386.deb ecryptfs cryptographic filesystem (python)
python-editobj_0.5.7-12_all.deb Python object editor
python-editor_0.4-4_all.deb programmatically open an editor, capture the result - Python 2.7
python-editorconfig_0.12.1-1_all.deb library for working with EditorConfig — Python 2
python-efilter_1.5-2_all.deb EFILTER query language (Python 2)
python-elasticsearch-curator-doc_5.2.0-1_all.deb Python library for managing Elasticsearch time-series indices (documentation)
python-elasticsearch-curator_5.2.0-1_all.deb Python library for managing Elasticsearch time-series indices
python-elasticsearch-doc_5.4.0-1_all.deb Python client for Elasticsearch (Documentation)
python-elasticsearch_5.4.0-1_all.deb Python client for Elasticsearch
python-elements_0.13+svn20090823.230+dfsg-2.1_all.deb A 2D Physics API for Python
python-elementtidy_1.0-8build1_i386.deb An HTML tree builder for ElementTree based on Tidy
python-elib.intl_0.0.3~git20110809-5_all.deb enhanced internationalization (I18N) for Python
python-elixir_0.7.1-4build1_all.deb declarative mapper for SQLAlchemy
python-emcee_2.2.1-1_all.deb Affine-invariant ensemble MCMC sampling for Python
python-empy-doc_3.3.2-1build1_all.deb documentation for python-empy
Advertisement
Advertisement