python-dicoclient_2.4-1_all.deb


Advertisement

Description

python-dicoclient - RFC 2229 compliant dictionary client module and shell

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-dicoclient_2.4-1_all.deb
Package name python-dicoclient
Package version 2.4
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage http://puszcza.gnu.org.ua/software/dico/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 10.42 KB
Installed size 47.00 KB
GNU Dico is an implementation of the DICT protocol as defined in RFC 2229.
It is fully modular: the daemon itself (dicod) provides only the server
functionality, and knows nothing about database formats. Actual searches
are performed by functions supplied in loadable modules. A single module
can serve one or more databases.
This package contains a Python module that provides a Dico client and a simple
interactive shell.

Alternatives

Package Version Architecture Repository
python-dicoclient_2.4-1_all.deb 2.4 all Ubuntu Universe
python-dicoclient - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-dicoclient_2.4-1_all.deb
Source Package dico

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-dicoclient deb package:
    # sudo apt-get install python-dicoclient

Files

Path
/usr/lib/python2.7/dist-packages/dicoclient-1.0.egg-info
/usr/lib/python2.7/dist-packages/dicoclient.py
/usr/lib/python2.7/dist-packages/dicoshell.py
/usr/share/doc/python-dicoclient/changelog.Debian.gz
/usr/share/doc/python-dicoclient/copyright

Changelog

2017-10-12 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@users.sourceforge.net>
dico (2.4-1) unstable; urgency=medium
* New upstream release.
* Add django_1.10.diff patch to support Django 1.10. Thanks to Marc Dequènes
(Duck) <duck@duckcorp.org> (Closes: #868832)
* Remove obsolete patches
* debian/dicod.{prerm,postinst}: check for update-inetd using which instead
of checking hard coded path
* Replace upstream-signing-key.pgp with upstream/signing-key.asc
* Removed fix-ftbfs-format-string.patch patch, as it is applied upstream
* Update symbols file
* Re-enable Guile tests
* Bumped compat level to 10
+ No need to specify autotools-dev
+ wordnet.diff patch: patch configure.ac & modules/wordnet/Makefile.am
instead of configure & modules/guile/Makefile.in
* Bump Standards-Version to 4.1.1
* Update copyright years
* debian/dicoweb.links:
+ fix passenger_wsgi.py symlink (Closes: #868830)
+ add symlink to /etc/dicoweb/templates in /var/lib/dicoweb/passenger
* Added fix_manpage.diff to fix section of dicod manpage
* dicod.install: add usr/lib/*/idxgcide
* Remove manpages created by maintainer as upstream now provides manpages
* Install metaphone2 plugin in dicod
2017-03-23 - Ritesh Raj Sarraf <rrs@debian.org>
dico (2.3-2) unstable; urgency=medium
* Drop broken link to non-existent file.
Thanks to Andreas Beckmann (Closes: #858511)
* Add dependency on lsb-base for SysV init script
2016-09-15 - Ritesh Raj Sarraf <rrs@debian.org>
dico (2.3-1) unstable; urgency=medium
* [6fcf6ad] New upstream version 2.3 (Closes: #819835)
* [70fa481] Drop patches (mostly merged upstream) and refresh others
* [0756a82] Add python-six to build depends
* [dc7cc1d] Disable failing Guile sub-test
* [2af696f] Update dico-dev example install files
* [f48cda1] Fix FTBFS for string format
* [bd729d7] Update symbols list for 2.3
* [5f1d5ff] Add dh-python to build depends
* [667bab7] Fix Vcs URLs
* [bbf2276] Add myself as Maintainer. With permission from previous
maintainer, Ahed El-Mahmoudy
* [7eb24e8] Update Standards Version to 3.9.8. No changes required
2015-05-08 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@users.sourceforge.net>
dico (2.2-9) unstable; urgency=medium
* Add -E to LDFLAGS for mips64el arch. to fix FTBFS.
Thanks to James Cowgill <james410@cowgill.org.uk> (Closes: #775426)
* Update my email address
* debian/copyright: Update copyright years.
2014-10-19 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@users.sourceforge.net>
dico (2.2-8) unstable; urgency=medium
* Use autotools-dev to update config.{sub,guess} for new archs.
(Closes: #765202)
* debian/control:
+ Bumped Standards-Version to 3.9.6
+ Update email address.

See Also

Package Description
python-dicom-doc_0.9.9-3_all.deb DICOM medical file reading and writing (documentation)
python-dicom_0.9.9-3_all.deb DICOM medical file reading and writing (Python 2)
python-dictclient_1.0.3.2_all.deb Python client library for DICT (RFC2229) protocol
python-dictdlib_2.0.4.1+nmu1build1_all.deb Python library for generating dictd dictionaries
python-dictobj_0.4-1.2_all.deb Python dictionary where keys can be accessed as instance attributes
python-dicttoxml_1.7.4-1_all.deb Python module for converting dict into a XML string
python-diff-match-patch_20121119-3_all.deb robust algorithms for synchronizing plain text (Python 2 module)
python-digitalocean-doc_1.13.2-1_all.deb Python bindings for the DigitalOcean API (common documentation)
python-digitalocean_1.13.2-1_all.deb Python bindings for the DigitalOcean API (Python 2)
python-dijitso_2017.2.0.0-2_all.deb distributed just-in-time building of shared libraries (Python 2)
python-dill_0.2.7.1-1_all.deb Serialize all of Python (almost)
python-dingus_0.3.4-1_all.deb A record-then-assert mocking library
python-dipy-doc_0.13.0-2_all.deb Python library for the analysis of diffusion MRI datasets -- documentation
python-dipy-lib_0.13.0-2_i386.deb Python library for the analysis of diffusion MRI datasets -- extensions
python-dipy_0.13.0-2_all.deb Python library for the analysis of diffusion MRI datasets
Advertisement
Advertisement