python-construct_2.8.16-0.2_all.deb


Advertisement

Description

python-construct - powerful declarative parser (and builder) for binary data

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-construct_2.8.16-0.2_all.deb
Package name python-construct
Package version 2.8.16
Package release 0.2
Package architecture all
Package type deb
Category universe/python
Homepage http://construct.readthedocs.org/en/latest/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 56.35 KB
Installed size 297.00 KB
Construct is a python library for parsing and building of data structures
(binary or textual).
It is based on the concept of defining data structures in a declarative
manner, rather than procedural code: more complex constructs are composed of
a hierarchy of simpler ones. It's the first library that makes parsing
fun, instead of the usual headache it is today.

Alternatives

Package Version Architecture Repository
python-construct_2.8.16-0.2_all.deb 2.8.16 all Ubuntu Universe
python-construct - - -

Requires

Name Value
python << 2.8
python >= 2.7
python-six -
python:any >= 2.6.6-7~

Provides

Name Value
python2.7-construct -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-construct_2.8.16-0.2_all.deb
Source Package construct

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-construct deb package:
    # sudo apt-get install python-construct

Files

Path
/usr/lib/python2.7/dist-packages/construct/__init__.py
/usr/lib/python2.7/dist-packages/construct/core.py
/usr/lib/python2.7/dist-packages/construct/debug.py
/usr/lib/python2.7/dist-packages/construct/expr.py
/usr/lib/python2.7/dist-packages/construct/version.py
/usr/lib/python2.7/dist-packages/construct-2.8.16.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/construct-2.8.16.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/construct-2.8.16.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/construct/examples/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/data/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/data/cap.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/data/snoop.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/executable/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/executable/elf32.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/executable/pe32.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/filesystem/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/filesystem/ext2.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/filesystem/fat16.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/filesystem/mbr.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/graphics/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/graphics/bmp.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/graphics/emf.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/graphics/gif.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/graphics/png.py
/usr/lib/python2.7/dist-packages/construct/examples/formats/graphics/wmf.py
/usr/lib/python2.7/dist-packages/construct/examples/protocols/__init__.py
/usr/lib/python2.7/dist-packages/construct/examples/protocols/ipstack.py
/usr/lib/python2.7/dist-packages/construct/lib/__init__.py
/usr/lib/python2.7/dist-packages/construct/lib/binary.py
/usr/lib/python2.7/dist-packages/construct/lib/bitstream.py
/usr/lib/python2.7/dist-packages/construct/lib/container.py
/usr/lib/python2.7/dist-packages/construct/lib/hex.py
/usr/lib/python2.7/dist-packages/construct/lib/py3compat.py
/usr/share/doc/python-construct/README.rst.gz
/usr/share/doc/python-construct/changelog.Debian.gz
/usr/share/doc/python-construct/copyright

Changelog

2017-11-29 - Sebastien Delafond <seb@debian.org>
construct (2.8.16-0.2) unstable; urgency=medium
* Non-maintainer upload
* Add versioned Breaks for packages not compatible with >2.5. Thanks
Hilko Bengen for the patch (Closes: #882808)
2017-11-09 - Sebastien Delafond <seb@debian.org>
construct (2.8.16-0.1) unstable; urgency=medium
* Non-maintainer upload
* New upstream release (Closes: #849634)
2017-02-04 - Sebastien Delafond <seb@debian.org>
construct (2.8.8+really2.5.2-0.1) unstable; urgency=medium
* Downgrade back to 2.5.2, since the API in construct 2.8.8 changed
considerably and thus breaks other packages (Closes: #853082)
2017-01-25 - Sebastien Delafond <seb@debian.org>
construct (2.8.8-0.1) unstable; urgency=medium
* Non-maintainer upload
* New upstream release (Closes: #849634)
2015-07-31 - Hilko Bengen <bengen@debian.org>
construct (2.5.2-0.1) unstable; urgency=medium
* Non-maintainer upload
* New upstream version (Closes: #793424)
2013-09-02 - Jonathan Wiltshire <jmw+debian@tiger-computing.co.uk>
construct (2.5.1-1) unstable; urgency=low
* Initial release (Closes: #686396)

See Also

Package Description
python-contract_1.4-4_all.deb Programming by contract for Python
python-convoy_0.2.1+bzr39-1_all.deb WSGI app for loading multiple files in the same request
python-cookiecutter-doc_1.6.0-2_all.deb create projects from project templates (documentation)
python-cookiecutter_1.6.0-2_all.deb create projects from project templates (Python 2 module)
python-cookies_2.2.1-1_all.deb Python RFC 6265-compliant cookie parser and renderer
python-coreapi_2.3.3-2_all.deb Python client library for Core API
python-corepywrap_1.005-5build1_i386.deb library that exports C++ mmCIF accessors to Python
python-coreschema_0.0.4-1_all.deb Python utilities to describe an abstract data schema to coreapi
python-couchdb_0.10-1.1_all.deb library for working with Apache CouchDB
python-couchdbkit_0.6.5-2_all.deb Trying to improve couchdb experience in Python
python-couleur_0.5.0-4_all.deb tool to play around with ANSI features in a unix terminal
python-cov-core_1.15.0-2_all.deb plugin core for use by pytest-cov, nose-cov and nose2-cov
python-coverage-doc_4.5+dfsg.1-3_all.deb code coverage tool for Python — documentation
python-coverage-test-runner_1.13.1-1_all.deb fail Python program unit tests unless they test everything
python-coverage_4.5+dfsg.1-3_i386.deb code coverage tool for Python 2
Advertisement
Advertisement