python-brotli_1.0.3-1ubuntu1_i386.deb


Advertisement

Description

python-brotli - lossless compression algorithm and format (Python 2 version)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-brotli_1.0.3-1ubuntu1_i386.deb
Package name python-brotli
Package version 1.0.3
Package release 1ubuntu1
Package architecture i386
Package type deb
Category universe/python
Homepage https://github.com/google/brotli
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 257.39 KB
Installed size 751.00 KB
Brotli is a generic-purpose lossless compression algorithm
that compresses data using a combination of a modern variant
of the LZ77 algorithm, Huffman coding and 2nd order context modeling,
with a compression ratio comparable to the best currently available
general-purpose compression methods. It is similar in speed with
deflate but offers more dense compression.
This package installs a Python 2 module.

Alternatives

Package Version Architecture Repository
python-brotli_1.0.3-1ubuntu1.2_i386.deb 1.0.3 i386 Ubuntu Updates Universe
python-brotli_1.0.3-1ubuntu1.2_amd64.deb 1.0.3 amd64 Ubuntu Updates Universe
python-brotli_1.0.3-1ubuntu1_amd64.deb 1.0.3 amd64 Ubuntu Universe
python-brotli - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libstdc++6 >= 4.1.1
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-brotli_1.0.3-1ubuntu1_i386.deb
Source Package brotli

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-brotli deb package:
    # sudo apt-get install python-brotli

Files

Path
/usr/lib/python2.7/dist-packages/_brotli.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/brotli.py
/usr/lib/python2.7/dist-packages/Brotli-1.0.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Brotli-1.0.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Brotli-1.0.4.egg-info/top_level.txt
/usr/share/doc/python-brotli/changelog.Debian.gz
/usr/share/doc/python-brotli/copyright
/usr/share/lintian/overrides/python-brotli

Changelog

2018-04-06 - Matthias Klose <doko@ubuntu.com>
brotli (1.0.3-1ubuntu1) bionic; urgency=medium
* Apply pull requests #651, #656 to fix alignment issues on armhf.
2018-03-06 - Tomasz Buchert <tomasz@debian.org>
brotli (1.0.3-1) unstable; urgency=medium
* New upstream version 1.0.3
* Drop obsolete patches
2018-01-31 - Tomasz Buchert <tomasz@debian.org>
brotli (1.0.2-3) unstable; urgency=medium
[ Jeremy Bicha ]
* Use dh_missing --fail-missing (Closes: #888950)
[ Tomasz Buchert ]
* d/copyright: remove appveyor path (Closes: #888947)
* Bump debhelper compat to 11
2017-12-07 - Tomasz Buchert <tomasz@debian.org>
brotli (1.0.2-2) unstable; urgency=medium
* Upload to unstable
2017-12-03 - Tomasz Buchert <tomasz@debian.org>
brotli (1.0.2-1~exp0) experimental; urgency=medium
* New upstream version 1.0.2
* Updated std-ver to 4.1.0 (no changes needed)
2017-09-22 - Tomasz Buchert <tomasz@debian.org>
brotli (1.0.0-1~exp0) experimental; urgency=medium
* New upstream version 1.0.0
* d/*: migrate 0.6.0 to 1.0.0
* d/symbols: fix symbols file (Closes: #870831)
* d/patches: refresh
* Upload to experimental
2017-06-28 - Ondřej Surý <ondrej@debian.org>
brotli (0.6.0-2~exp0) experimental; urgency=medium
[Tomasz Buchert]
* d/gbp.conf: remove obsolete gbp.conf
* d/control: add Ondřej to Uploaders
* debian: provide shared libs pkgs
* d/control: bump Standards-Version to 4 (no changes needed)
[Ondřej Surý]
* Use SOVERSION in libbrotli package name and add symbols file
* Rewrite smoke_test.sh as autopkgtests
* Upload to experimental
* Add missing cmake to Build-Depends
* Fix libbrotli0.6.0.symbols to refer to correct package
* Add lintian override for amalgated libbrotli0.6.0 package
2017-04-23 - Tomasz Buchert <tomasz@debian.org>
brotli (0.6.0-1) unstable; urgency=medium
* d/*: debhelper 10 and uscan 4
* New upstream version 0.6.0
2016-12-18 - Tomasz Buchert <tomasz@debian.org>
brotli (0.5.2+dfsg-2) unstable; urgency=medium
* Make object list deterministic (Closes: #845780)
2016-10-25 - Tomasz Buchert <tomasz@debian.org>
brotli (0.5.2+dfsg-1) unstable; urgency=medium
* Imported Upstream version 0.5.2+dfsg (Closes: #842016)
* Update debian/rules to use new build system

See Also

Package Description
python-btchip_0.1.24-1_all.deb Python library to communicate with BTChip dongle
python-btrees-doc_4.3.1-1build2_all.deb scalable persistent object containers for Python - documentation
python-btrees_4.3.1-1build2_i386.deb scalable persistent object containers for Python
python-buffy_0.16build4_i386.deb Python wrapper for the libbuffy library
python-bugzilla_2.1.0-1_all.deb Python library for interacting with Bugzilla (Python 2)
python-bumps-doc_0.7.6-3_all.deb data fitting and Bayesian uncertainty modeling for inverse problems (docs)
python-bumps_0.7.6-3_all.deb data fitting and Bayesian uncertainty modeling for inverse problems (Python 2)
python-bunch_1.0.1-1_all.deb Dot-accessible Python dictionary (a la JavaScript objects)
python-burrito_0.9.1-2_all.deb Python 2 framework for wrapping and controlling command-line applications
python-buzhug_1.8-3_all.deb pure-Python database engine, using a Pythonic, no-SQL syntax
python-bz2file_0.98-1_all.deb Python library for reading and writing bzip2-compressed files
python-bzrlib.tests_2.7.0+bzr6622-10_all.deb distributed version control system - testsuite
python-cachecontrol_0.11.7-1_all.deb caching algorithms in httplib2 for use with requests
python-cached-property_1.3.1-1_all.deb Provides cached-property for decorating methods in classes (Python 2)
python-cairocffi-doc_0.8.0-0ubuntu2_all.deb cffi-based cairo bindings for Python - Documentation
Advertisement
Advertisement