python-breathe_4.7.3-1_all.deb


Advertisement

Description

python-breathe - Sphinx autodox support for languages with doxygen support (Python 2)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-breathe_4.7.3-1_all.deb
Package name python-breathe
Package version 4.7.3
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage http://github.com/michaeljones/breathe/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 53.71 KB
Installed size 476.00 KB
Breathe provides a bridge between the Sphinx and doxygen documentation
systems. It enables Sphinx to generate autodoc for languages other than Python
with the help of doxygen. It also allows one to embed reStructuredText in
doxygen markup.
This package provides the module for Python 2.

Alternatives

Package Version Architecture Repository
python-breathe_4.7.3-1_all.deb 4.7.3 all Ubuntu Universe
python-breathe - - -

Requires

Name Value
doxygen -
python-docutils -
python-six >= 1.4
python-sphinx -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-breathe_4.7.3-1_all.deb
Source Package breathe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-breathe deb package:
    # sudo apt-get install python-breathe

Files

Path
/usr/bin/python2-breathe-apidoc
/usr/lib/python2.7/dist-packages/breathe/__init__.py
/usr/lib/python2.7/dist-packages/breathe/apidoc.py
/usr/lib/python2.7/dist-packages/breathe/directives.py
/usr/lib/python2.7/dist-packages/breathe/exception.py
/usr/lib/python2.7/dist-packages/breathe/node_factory.py
/usr/lib/python2.7/dist-packages/breathe/process.py
/usr/lib/python2.7/dist-packages/breathe/project.py
/usr/lib/python2.7/dist-packages/breathe-4.7.3.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/breathe-4.7.3.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/breathe-4.7.3.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/breathe-4.7.3.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/breathe-4.7.3.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/breathe-4.7.3.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/breathe/directive/__init__.py
/usr/lib/python2.7/dist-packages/breathe/directive/base.py
/usr/lib/python2.7/dist-packages/breathe/directive/file.py
/usr/lib/python2.7/dist-packages/breathe/directive/index.py
/usr/lib/python2.7/dist-packages/breathe/finder/__init__.py
/usr/lib/python2.7/dist-packages/breathe/finder/base.py
/usr/lib/python2.7/dist-packages/breathe/finder/compound.py
/usr/lib/python2.7/dist-packages/breathe/finder/core.py
/usr/lib/python2.7/dist-packages/breathe/finder/index.py
/usr/lib/python2.7/dist-packages/breathe/parser/__init__.py
/usr/lib/python2.7/dist-packages/breathe/parser/compound.py
/usr/lib/python2.7/dist-packages/breathe/parser/compoundsuper.py
/usr/lib/python2.7/dist-packages/breathe/parser/index.py
/usr/lib/python2.7/dist-packages/breathe/parser/indexsuper.py
/usr/lib/python2.7/dist-packages/breathe/renderer/__init__.py
/usr/lib/python2.7/dist-packages/breathe/renderer/base.py
/usr/lib/python2.7/dist-packages/breathe/renderer/filter.py
/usr/lib/python2.7/dist-packages/breathe/renderer/mask.py
/usr/lib/python2.7/dist-packages/breathe/renderer/sphinxrenderer.py
/usr/lib/python2.7/dist-packages/breathe/renderer/target.py
/usr/share/doc/python-breathe/changelog.Debian.gz
/usr/share/doc/python-breathe/copyright

Changelog

2017-10-09 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.7.3-1) unstable; urgency=medium
* New upstream release.
- Use CPPEnumeratorObject provided by Sphinx. (Closes: #877021)
* debian/control: Bump Standards-Version.
2017-08-20 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.7.2-1) unstable; urgency=medium
* New upstream release.
2017-08-15 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.7.0-2) unstable; urgency=medium
* debian/{control,compat}: Bump debhelper compat to 10.
* debian/control: Add B-D on latexmk. (Closes: #872156)
2017-08-12 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.7.0-1) unstable; urgency=medium
* New upstream release.
* debian/control: Bump Standards-Version.
2017-02-26 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.6.0-1) unstable; urgency=medium
* New upstream release.
2017-02-17 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.5.0-1) unstable; urgency=medium
* New upstream release.
2016-11-16 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.4.0-1) unstable; urgency=medium
* New upstream release.
2016-11-07 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.3.1-1) unstable; urgency=medium
* New upstream release.
* debian/control:
- Bump B-D on sphinx to >= 1.4.
- Update Description.
* debian/patches/sphinx-1.4.patch: Removed, included upstream.
2016-07-10 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.2.0-3) unstable; urgency=medium
[ Jeremy Bicha ]
* Add texlive-generic-extra to autopkgtest Depends (Closes: #830103)
2016-06-21 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.2.0-2) unstable; urgency=medium
* debian/control:
- Bump Standards-Version.
- Add texlive-generic-extra to Build-Depends.
* debian/patches/sphinx-1.4.patch: Apply upstream patch to fix Sphinx 1.4
compatibility (Closes: #827804)

See Also

Package Description
python-breezy.tests_3.0.0~bzr6852-1_all.deb distributed version control system - testsuite
python-breezy_3.0.0~bzr6852-1_i386.deb distributed version control system - python library
python-brial_1.2.0-2_i386.deb polynomials over Boolean Rings, Python module
python-brian-doc_1.4.3-1_all.deb simulator for spiking neural networks - documentation
python-brian-lib_1.4.3-1_i386.deb simulator for spiking neural networks -- extensions
python-brian_1.4.3-1_all.deb simulator for spiking neural networks
python-brlapi_5.5-4ubuntu2_i386.deb Braille display access via BRLTTY - Python bindings
python-broccoli_0.62-1_i386.deb Python bindings for Broccoli
python-brotli_1.0.3-1ubuntu1_i386.deb lossless compression algorithm and format (Python 2 version)
python-btchip_0.1.24-1_all.deb Python library to communicate with BTChip dongle
python-btrees-doc_4.3.1-1build2_all.deb scalable persistent object containers for Python - documentation
python-btrees_4.3.1-1build2_i386.deb scalable persistent object containers for Python
python-buffy_0.16build4_i386.deb Python wrapper for the libbuffy library
python-bugzilla_2.1.0-1_all.deb Python library for interacting with Bugzilla (Python 2)
python-bumps-doc_0.7.6-3_all.deb data fitting and Bayesian uncertainty modeling for inverse problems (docs)
Advertisement
Advertisement