python-appindicator_12.10.1+18.04.20180322.1-0ubuntu1_i386.deb


Advertisement

Description

python-appindicator - Python bindings for libappindicator

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename python-appindicator_12.10.1+18.04.20180322.1-0ubuntu1_i386.deb
Package name python-appindicator
Package version 12.10.1+18.04.20180322.1
Package release 0ubuntu1
Package architecture i386
Package type deb
Category universe/python
Homepage https://launchpad.net/libappindicator
License -
Maintainer Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Download size 7.76 KB
Installed size 52.00 KB
This package provides Python bindings so that you can use libappindicator from
a Python program.

Alternatives

Package Version Architecture Repository
python-appindicator_12.10.1+18.04.20180322.1-0ubuntu1_amd64.deb 12.10.1+18.04.20180322.1 amd64 Ubuntu Universe
python-appindicator - - -

Requires

Name Value
libappindicator1 = 12.10.1+18.04.20180322.1-0ubuntu1
libc6 >= 2.4
libglib2.0-0 >= 2.35.4
libgtk2.0-0 >= 2.12.0
python << 2.8
python >= 2.7
python-gobject -
python:any >= 2.6.6-7~

Provides

Name Value
python2.7-appindicator -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-appindicator_12.10.1+18.04.20180322.1-0ubuntu1_i386.deb
Source Package libappindicator

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-appindicator deb package:
    # sudo apt-get install python-appindicator

Files

Path
/usr/lib/python2.7/dist-packages/appindicator/__init__.py
/usr/lib/python2.7/dist-packages/appindicator/_appindicator.so
/usr/share/doc/python-appindicator/changelog.Debian.gz
/usr/share/doc/python-appindicator/copyright
/usr/share/pygtk/2.0/defs/appindicator.defs

Changelog

2018-03-22 - Jeremy Bicha <jbicha@ubuntu.com>
libappindicator (12.10.1+18.04.20180322.1-0ubuntu1) bionic; urgency=medium
[ Unit 193 ]
* Have -dev package depend on libgtk2.0-dev or libgk-3-dev according
to its pkgconfig file (LP: #1757574) (LP: #1757574)
2018-03-20 - Marco Trevisan (Treviño) <mail@3v1n0.net>
libappindicator (12.10.1+18.04.20180320-0ubuntu1) bionic; urgency=medium
[ Olivier Tilloy ]
* Fix build failures on bionic, (LP: #1757121)
2017-07-19 - Didier Roche <didrocks@ubuntu.com>
libappindicator (12.10.1+17.04.20170215-0ubuntu2) artful; urgency=medium
* debian/control:
- Downgrade libappindicator* recommending the indicator-application
service to suggests. Only some sessions wants it, while we still
link against the lib in multiple apps.
2017-02-15 - Marco Trevisan (Treviño) <mail@3v1n0.net>
libappindicator (12.10.1+17.04.20170215-0ubuntu1) zesty; urgency=medium
* app-indicator: don't append the snap prefix if the icon is saved in
a well known readable path
2017-02-13 - Marco Trevisan (Treviño) <mail@3v1n0.net>
libappindicator (12.10.1+17.04.20170213-0ubuntu1) zesty; urgency=medium
* AppIndicator: don't emit label cahanges when guide is still empty
2016-11-29 - Marco Trevisan (Treviño) <mail@3v1n0.net>
libappindicator (12.10.1+17.04.20161129-0ubuntu1) zesty; urgency=medium
* AppIndicator: fix icon and theme paths when running in $SNAP
environment (LP: #1600136)
2016-09-05 - Dmitry Shachnev <mitya57@ubuntu.com>
libappindicator (12.10.1+16.10.20160905-0ubuntu1) yakkety; urgency=medium
[ Alberts Muktupāvels ]
* Handle watcher service appearing and disappearing.
[ Dmitry Shachnev ]
* Make test-simple-app really working.
2014-11-10 - Ubuntu daily release <ps-jenkins@lists.canonical.com>
libappindicator (12.10.1+15.04.20141110-0ubuntu1) vivid; urgency=low
[ Lars Uebernickel ]
* scroll-event: change parameter to the right type
2014-02-23 - Matthias Klose <doko@ubuntu.com>
libappindicator (12.10.1+13.10.20130920-0ubuntu4) trusty; urgency=medium
* Rebuild to drop files installed into /usr/share/pyshared.
2013-12-19 - Matthias Klose <doko@ubuntu.com>
libappindicator (12.10.1+13.10.20130920-0ubuntu3) trusty; urgency=medium
* Build with -Wno-error=deprecated-declarations.
* Don't build the mono bindings on ppc64el, not available.
* Disable building the example, vala build error.

See Also

Package Description
python-application_1.4.1-1_all.deb Basic building blocks for Python applications
python-applicationinsights_0.11.0-1_all.deb Azure Application Insights API for Python 2.x
python-apport_2.20.9-0ubuntu7_all.deb Python library for Apport crash report handling
python-apptools_4.3.0-1_all.deb ETS Application Tools
python-apscheduler_3.4.0-2ubuntu1_all.deb In-process task scheduler with Cron-like capabilities
python-apsw-doc_3.16.2-r1-2build2_all.deb documentation for python-apsw
python-apsw_3.16.2-r1-2build2_i386.deb another Python SQLite 3 wrapper
python-aptdaemon.gtk3widgets_1.1.1+bzr982-0ubuntu19_all.deb Python 2 GTK+ 3 widgets to run an aptdaemon client
python-aptdaemon_1.1.1+bzr982-0ubuntu19_all.deb Python 2 module for the server and client of aptdaemon
python-aptly_0.12.10-1_all.deb Aptly REST API client and useful tooling - Python 2.7
python-argcomplete_1.8.1-1ubuntu1_all.deb bash tab completion for argparse
python-argh_0.26.2-1_all.deb simple argparse wrapper (Python 2)
python-args_0.1.0-2_all.deb Command Arguments for Humans (Python 2)
python-argvalidate_0.9.0-2_all.deb simple argument validator library
python-ariapy_2.8.0+repack-1.2ubuntu1_i386.deb C++ library for MobileRobots/ActivMedia robots (Python bindings)
Advertisement
Advertisement