pypy-tk_5.10.0+dfsg-3build2_i386.deb


Advertisement

Description

pypy-tk - Tkinter module for PyPy (an alternative Python interpreter)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename pypy-tk_5.10.0+dfsg-3build2_i386.deb
Package name pypy-tk
Package version 5.10.0+dfsg
Package release 3build2
Package architecture i386
Package type deb
Category universe/python
Homepage http://pypy.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 24.77 KB
Installed size 128.00 KB
A module for writing portable GUI applications with PyPy using Tk.
Also known as Tkinter.
PyPy is a fast, compliant alternative implementation of the Python language
(2.7).

Alternatives

Package Version Architecture Repository
pypy-tk_5.10.0+dfsg-3build2_amd64.deb 5.10.0+dfsg amd64 Ubuntu Universe
pypy-tk - - -

Requires

Name Value
dpkg >= 1.15.6~
libc6 >= 2.3.6-6~
libtcl8.6 >= 8.6.0
libtk8.6 >= 8.6.0
pypy = 5.10.0+dfsg-3build2

Replaces

Name Value
pypy-lib << 2.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-tk_5.10.0+dfsg-3build2_i386.deb
Source Package pypy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-tk deb package:
    # sudo apt-get install pypy-tk

Files

Path
/usr/lib/pypy/lib_pypy/_tkinter/__init__.py
/usr/lib/pypy/lib_pypy/_tkinter/app.py
/usr/lib/pypy/lib_pypy/_tkinter/tclobj.py
/usr/lib/pypy/lib_pypy/_tkinter/tklib_build.py
/usr/lib/pypy/lib_pypy/_tkinter/tklib_cffi.pypy-41-i386-linux-gnu.so
/usr/share/doc/pypy-tk/changelog.Debian.gz
/usr/share/doc/pypy-tk/copyright

Changelog

2018-02-06 - Dimitri John Ledkov <xnox@ubuntu.com>
pypy (5.10.0+dfsg-3build2) bionic; urgency=high
* No change rebuild against openssl1.1.
2018-02-02 - Gianfranco Costamagna <locutusofborg@debian.org>
pypy (5.10.0+dfsg-3build1) bionic; urgency=medium
* Rebuild against new libgdbm5.
2018-01-20 - Stefano Rivera <stefanor@debian.org>
pypy (5.10.0+dfsg-3) unstable; urgency=medium
* Patch: dots-stackcheck: Print more dots to avoid timing out on slower
buildds (Closes: #878479)
2017-12-28 - Stefano Rivera <stefanor@debian.org>
pypy (5.10.0+dfsg-2) unstable; urgency=medium
* Patch: rvmprof: Handle ProcessorAutodetectError. Fixing builds on non-JIT
archs.
2017-12-28 - Stefano Rivera <stefanor@debian.org>
pypy (5.10.0+dfsg-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* Bump Standards_version to 4.1.2, no changes needed.
2017-10-08 - Stefano Rivera <stefanor@debian.org>
pypy (5.9.0+dfsg-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* Import patches into git-dpm (reformatting headers).
* Update copyright.
* Use VERSION_CHAR16CHAR32 as the cffi version.
* Bump Standards-Version to 4.1.1.
- Change priority to optional.
2017-06-16 - Stefano Rivera <stefanor@debian.org>
pypy (5.8.0+dfsg-2) unstable; urgency=medium
* Disable _vmprof module on kFreeBSD, as it has no F_GETPATH, or equivalent.
* Stop using asmgcc, it's no longer the default upstream. And causes an
FTBFS on i386, with _vmprof. (Closes: #864814)
2017-06-14 - Stefano Rivera <stefanor@debian.org>
pypy (5.8.0+dfsg-1) unstable; urgency=medium
* New upstream release.
* Upload to unstable again, the freeze is (almost) over.
* Refresh patches.
* Update copyright.
* Use fPIC on m68k and sh4 (Closes: #861942, #861951)
* Bump Standards-Version to 4.0.0.
- Switch copyright file Format to https URL.
2017-05-02 - Stefano Rivera <stefanor@debian.org>
pypy (5.7.1+dfsg-2) experimental; urgency=medium
* Install the new cpyext_* headers.
2017-04-25 - Stefano Rivera <stefanor@debian.org>
pypy (5.7.1+dfsg-1) experimental; urgency=medium
* New upstream release.
* Upload to experimental, due to freeze.
* Refresh patches.
* Drop patches, superseded upstream: expat-2.2.0, noprofopt, trackgcroot,
non-recursive-graphlib.
* Update copyright.
* Build-Depend on python-pycparser, required for translation now.
* Update clean rule.

See Also

Package Description
pypy-unidecode_1.0.22-1_all.deb ASCII transliterations of Unicode text (PyPy module)
pypy-wand_0.4.4-1.1_all.deb Python interface for ImageMagick library (PyPy build)
pypy-zmq_16.0.2-2build2_i386.deb PyPy bindings for 0MQ library
pypy_5.10.0+dfsg-3build2_i386.deb fast alternative implementation of Python - PyPy interpreter
pyqi_0.3.2+dfsg-2_all.deb Python framework for wrapping general commands in multiple interfaces
pyqso_1.0.0-1_all.deb logging tool for amateur radio operators
pyqt4-dev-tools_4.12.1+dfsg-2_i386.deb Development tools for PyQt4
pyqt4.qsci-dev_2.10.2+dfsg-4_all.deb Development files for Python Qscintilla2 (Qt4)
pyqt5-dev-tools_5.10.1+dfsg-1ubuntu2_i386.deb Development tools for PyQt5
pyqt5-dev_5.10.1+dfsg-1ubuntu2_all.deb Development files for PyQt5
pyqt5-examples_5.10.1+dfsg-1ubuntu2_all.deb Examples and demos for PyQt5
pyqt5.qsci-dev_2.10.2+dfsg-4_all.deb Development files for Python Qscintilla2 (Qt5)
pyracerz_0.2-8_all.deb multiplayer top view 2D racing game
pyragua_0.2.5-6_all.deb Very lightweight Python editor
pyrex-mode_0.9.9-1_all.deb emacs-lisp pyrex-mode for pyrex
Advertisement
Advertisement