pypy-enum34_1.1.6-2_all.deb


Advertisement

Description

pypy-enum34 - backport of Python 3.4's enum package (PyPy package)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename pypy-enum34_1.1.6-2_all.deb
Package name pypy-enum34
Package version 1.1.6
Package release 2
Package architecture all
Package type deb
Category universe/python
Homepage https://pypi.python.org/pypi/enum34
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 33.89 KB
Installed size 212.00 KB
PEP 435 adds an enumeration to Python 3.4.  This module provides a
backport of that data type for older Python versions.  It defines two
enumeration classes that can be used to define unit sets of names and
values: Enum and IntEnum.
This is the PyPy compatible package.

Alternatives

Package Version Architecture Repository
pypy-enum34_1.1.6-2_all.deb 1.1.6 all Ubuntu Universe
pypy-enum34 - - -

Requires

Name Value
pypy -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-enum34_1.1.6-2_all.deb
Source Package enum34

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-enum34 deb package:
    # sudo apt-get install pypy-enum34

Files

Path
/usr/lib/pypy/dist-packages/enum/README
/usr/lib/pypy/dist-packages/enum/__init__.py
/usr/lib/pypy/dist-packages/enum/test.py
/usr/lib/pypy/dist-packages/enum/doc/enum.pdf
/usr/lib/pypy/dist-packages/enum/doc/enum.rst
/usr/lib/pypy/dist-packages/enum34-1.1.6.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/enum34-1.1.6.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/enum34-1.1.6.egg-info/top_level.txt
/usr/share/doc/pypy-enum34/changelog.Debian.gz
/usr/share/doc/pypy-enum34/copyright

Changelog

2017-11-18 - Ondřej Nový <onovy@debian.org>
enum34 (1.1.6-2) unstable; urgency=medium
* Team upload.
* d/python-enum34.pydist: Provide enum_compat shim
* Bump debhelper compat level to 10
* Bump Standards-Version to 4.1.1 (no changes needed)
* Use Python 3 version of Sphinx for docs building
* d/control: Remove Testsuite: autopkgtest, it's added automatically
* d/watch: Use https
2016-07-13 - Barry Warsaw <barry@debian.org>
enum34 (1.1.6-1) unstable; urgency=medium
* New upstream release.
* d/control: Add `Breaks: python-enum` to ensure that package (since
removed from the archive) gets uninstalled when python-enum34 is
installed. (Closes: #830712)
* d/python-enum34.lintian-overrides: Added to suppress the warning on
unversioned Breaks.
2016-05-11 - Barry Warsaw <barry@debian.org>
enum34 (1.1.5-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Barry Warsaw ]
* New upstream release.
- Closes: #793506
- Closes: #820312
* d/control:
- Bump Standards-Version to 3.9.8 with no other changes needed.
- Swap Maintainer and Uploaders.
- Add Testsuite: autopkgtest (we can't use autopkgtest-pkg-python)
* d/tests/control: Add simple DEP-8 tests.
* d/pypy-enum34.pyremove: Added.
2016-01-23 - Tristan Seligmann <mithrandi@debian.org>
enum34 (1.1.2-1) unstable; urgency=medium
* Team upload.
* d/python-enum34.pydist: Add pydist file.
* New upstream version.
2015-09-15 - Tristan Seligmann <mithrandi@debian.org>
enum34 (1.0.4-3) unstable; urgency=medium
* Team upload.
* d/control:
- Build pypy-enum34 package.
- Fix python-enum34-doc to mention documentation in the description.
* d/rules: Add --with pypy.
2015-08-24 - Barry Warsaw <barry@debian.org>
enum34 (1.0.4-2) unstable; urgency=medium
* d/control:
- Remove all traces of the python3-enum34 binary package.  There's no
reason for us to provide this any more as all supported versions of
Python 3 in Debian already have it available as the stdlib enum
package.
- Remove python3-* packages from Build-Depends.
- Build-Depends on debhelper v9.
* d/rules:
- Remove python3 from dh --with.
- Remove override_dh_auto_install as no longer necessary.
* d/compat: Bump to version 9.
2015-06-02 - Barry Warsaw <barry@debian.org>
enum34 (1.0.4-1) unstable; urgency=medium
* New upstream release.
* d/watch: Update to use pypi.debian.net proxy.
2014-10-24 - Barry Warsaw <barry@debian.org>
enum34 (1.0.3-1) unstable; urgency=medium
* New upstream release.
* d/control: Bumped Standards-Version with no other changes necessary.
2014-05-16 - Barry Warsaw <barry@debian.org>
enum34 (1.0-1) unstable; urgency=medium
* New upstream release.
2014-04-24 - Barry Warsaw <barry@debian.org>
enum34 (0.9.23-2) unstable; urgency=medium
* d/python-enum34.links: Remove obsolete link.  (Closes: #743620)

See Also

Package Description
pypy-fastimport_0.9.6-3_all.deb Fastimport file format parser and generator library
pypy-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (PyPy)
pypy-funcsigs_1.0.2-4_all.deb function signatures from PEP362 - PyPy
pypy-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (PyPy)
pypy-hypothesis_3.44.1-2ubuntu1_all.deb advanced Quickcheck style testing library for PyPy
pypy-idna_2.6-1_all.deb Python IDNA2008 (RFC 5891) handling (PyPy)
pypy-ipaddress_1.0.17-1_all.deb Backport of Python 3 ipaddress module (PyPy)
pypy-iso8601_0.1.11-1_all.deb Python module to parse ISO 8601 dates - PyPy
pypy-json-tricks_3.11.0-1_all.deb Python module with extra features for JSON files
pypy-lib-testsuite_5.10.0+dfsg-3build2_all.deb standard library test suite for PyPy (an alternative Python interpreter)
pypy-lib_5.10.0+dfsg-3build2_i386.deb standard library for PyPy (an alternative Python interpreter)
pypy-libusb1_1.6.3-1_all.deb Python wrapper for libusb1 (PyPy)
pypy-mmllib_0.3.0.post1-1_all.deb library for handling Music Macro Language (PyPy)
pypy-mutagen_1.38-1_all.deb audio metadata editing library (PyPy)
pypy-packaging_17.1-1_all.deb core utilities for pypy packages
Advertisement
Advertisement