pypy-coverage_4.5+dfsg.1-3_all.deb


Advertisement

Description

pypy-coverage - code coverage tool for Python 2 PyPy

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename pypy-coverage_4.5+dfsg.1-3_all.deb
Package name pypy-coverage
Package version 4.5+dfsg.1
Package release 3
Package architecture all
Package type deb
Category universe/python
Homepage http://nedbatchelder.com/code/coverage/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 93.58 KB
Installed size 469.00 KB
Coverage.py is a tool for measuring code coverage of Python programs.
It monitors your program, noting which parts of the code have been
executed, then analyzes the source to identify code that could have
been executed but was not.
Coverage measurement is typically used to gauge the effectiveness of
tests. It can show which parts of your code are being exercised by
tests, and which are not.
This package installs the Python 2 ‘coverage’ library built for PyPy, and the
‘pypy-coverage’ program to perform and report coverage tests.

Alternatives

Package Version Architecture Repository
pypy-coverage_4.5+dfsg.1-3_all.deb 4.5+dfsg.1 all Ubuntu Universe
pypy-coverage - - -

Requires

Name Value
pypy -
pypy-pkg-resources -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-coverage_4.5+dfsg.1-3_all.deb
Source Package python-coverage

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-coverage deb package:
    # sudo apt-get install pypy-coverage

Files

Path
/usr/lib/pypy/dist-packages/coverage/__init__.py
/usr/lib/pypy/dist-packages/coverage/__main__.py
/usr/lib/pypy/dist-packages/coverage/annotate.py
/usr/lib/pypy/dist-packages/coverage/backunittest.py
/usr/lib/pypy/dist-packages/coverage/backward.py
/usr/lib/pypy/dist-packages/coverage/bytecode.py
/usr/lib/pypy/dist-packages/coverage/cmdline.py
/usr/lib/pypy/dist-packages/coverage/collector.py
/usr/lib/pypy/dist-packages/coverage/config.py
/usr/lib/pypy/dist-packages/coverage/control.py
/usr/lib/pypy/dist-packages/coverage/data.py
/usr/lib/pypy/dist-packages/coverage/debug.py
/usr/lib/pypy/dist-packages/coverage/env.py
/usr/lib/pypy/dist-packages/coverage/execfile.py
/usr/lib/pypy/dist-packages/coverage/files.py
/usr/lib/pypy/dist-packages/coverage/html.py
/usr/lib/pypy/dist-packages/coverage/htmlfiles
/usr/lib/pypy/dist-packages/coverage/misc.py
/usr/lib/pypy/dist-packages/coverage/multiproc.py
/usr/lib/pypy/dist-packages/coverage/parser.py
/usr/lib/pypy/dist-packages/coverage/phystokens.py
/usr/lib/pypy/dist-packages/coverage/pickle2json.py
/usr/lib/pypy/dist-packages/coverage/plugin.py
/usr/lib/pypy/dist-packages/coverage/plugin_support.py
/usr/lib/pypy/dist-packages/coverage/python.py
/usr/lib/pypy/dist-packages/coverage/pytracer.py
/usr/lib/pypy/dist-packages/coverage/report.py
/usr/lib/pypy/dist-packages/coverage/results.py
/usr/lib/pypy/dist-packages/coverage/summary.py
/usr/lib/pypy/dist-packages/coverage/templite.py
/usr/lib/pypy/dist-packages/coverage/version.py
/usr/lib/pypy/dist-packages/coverage/xmlreport.py
/usr/lib/pypy/dist-packages/coverage-4.5.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/coverage-4.5.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/coverage-4.5.egg-info/entry_points.txt
/usr/lib/pypy/dist-packages/coverage-4.5.egg-info/not-zip-safe
/usr/lib/pypy/dist-packages/coverage-4.5.egg-info/top_level.txt
/usr/lib/pypy/dist-packages/coverage/fullcoverage/encodings.py
/usr/share/doc/pypy-coverage/README.Debian
/usr/share/doc/pypy-coverage/changelog.Debian.gz
/usr/share/doc/pypy-coverage/copyright
/usr/share/pypy-coverage/htmlfiles/coverage_html.js
/usr/share/pypy-coverage/htmlfiles/index.html
/usr/share/pypy-coverage/htmlfiles/jquery.hotkeys.js
/usr/share/pypy-coverage/htmlfiles/keybd_closed.png
/usr/share/pypy-coverage/htmlfiles/keybd_open.png
/usr/share/pypy-coverage/htmlfiles/pyfile.html
/usr/share/pypy-coverage/htmlfiles/style.css

Changelog

2018-02-21 - Ben Finney <bignose@debian.org>
python-coverage (4.5+dfsg.1-3) unstable; urgency=medium
* The “Simona Monti” release.
* Document copyright information for bundled files in source:
* jquery.hotkeys.js
* jquery.isonscreen.js
Closes: bug#890578. Thanks to Chris Lamb for the report.
2018-02-16 - Ben Finney <bignose@debian.org>
python-coverage (4.5+dfsg.1-2) unstable; urgency=medium
* The “Nadia Benedetti” release.
* Build ‘pypy-coverage’ binary package.
Closes: bug#889823. Thanks to Ondřej Nový for the report and patch.
* Correct install directory in Debian rules.
Closes: bug#890560. Thanks to Chris Lamb for the report and patch.
2018-02-14 - Ben Finney <bignose@debian.org>
python-coverage (4.5+dfsg.1-1) unstable; urgency=medium
* The “Zakir Hossain Shaon” release.
* New upstream version.
Highlights since previous release:
* Support for plug-ins to alter Coverage.py configuration.
* Corrected behaviour of ‘include’ and ‘omit’ options.
* Specify current VCS for Debian packaging work.
* Update description of source package for current VCS workflow.
* Update Git-Buildpackage configuration for current VCS workflow.
* Override the Pybuild build system detection.
The presence of a Makefile confuses Pybuild.
2018-01-20 - Ben Finney <bignose@debian.org>
python-coverage (4.4.2+dfsg.1-1) unstable; urgency=medium
* The “Saiful Islam Chowkidar” release.
* New upstream version.
Highlights since previous release:
* Support for Python 3.7.
* Fixed a race condition when saving data.
* Tilde expansion in file paths for configuration options.
* Declare “Standards-Version: 4.1.3”. No additional changes required.
* debian/patches/03.remove-hotkeys.patch:
* Consolidate hunks, to avoid multiple patches of any one file.
Closes: bug#887780. Thanks to Jeffrey Cliff for the report.
* Update Lintian overrides for current Python versions.
* Use HTTPS URL for PyPI redirector.
* Update Debhelper compatibility level to 11.
* debian/tests/control:
* Update for new filesystem location of documentation.
* Override erroneous ‘missing-notice-file-for-apache-license’.
2017-09-09 - Ben Finney <bignose@debian.org>
python-coverage (4.4.1+dfsg.1-1) unstable; urgency=medium
* The “Jogeshwar Roy” release.
* Upload to “unstable” suite.
* New upstream version.
Highlights since previous release:
* Some warnings can now be individually disabled.
* Plugins can now choose to find unexecuted files.
* Errors now go to the standard error stream.
* Refresh patches for new upstream version.
* Use current HTTPS URL for copyright format reference.
* Declare “Standards-Version: 4.1.0”. No additional changes required.
* Update copyright years in Debian packaging.
* Grant a uniform license for Debian packaging work.
* Enable smoke test of installed Python scripts in autopkgtest.
2017-05-25 - Ben Finney <bignose@debian.org>
python-coverage (4.3.4+dfsg.1-1) experimental; urgency=medium
* The “Faraaz Ayaaz Hossain” release.
* New upstream version.
Highlights since previous release:
* HTML report generation now obeys the ‘--skip-covered’ option.
* The coverage run now executes ‘sys.excepthook’ when an exception
is uncaught.
* Configuration options in Tox configuration is now obeyed.
* Specify current VCS for Debian packaging work.
* debian/patches/03.rename-debounce-library.patch:
* Removed, applied upstream.
* debian/patches/03.remove-hotkeys.patch:
* Remove usage of incompatible ‘jquery.hotkeys.js’ API.
Closes: bug#848188. Thanks to Loic Dachary for the report.

See Also

Package Description
pypy-dev_5.10.0+dfsg-3build2_all.deb header files for PyPy (an alternative Python interpreter)
pypy-doc_5.10.0+dfsg-3build2_all.deb developer Documentation for PyPy (an alternative Python interpreter)
pypy-dulwich_0.18.5-1_i386.deb Python Git library - pypy module
pypy-enum34_1.1.6-2_all.deb backport of Python 3.4's enum package (PyPy package)
pypy-fastimport_0.9.6-3_all.deb Fastimport file format parser and generator library
pypy-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (PyPy)
pypy-funcsigs_1.0.2-4_all.deb function signatures from PEP362 - PyPy
pypy-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (PyPy)
pypy-hypothesis_3.44.1-2ubuntu1_all.deb advanced Quickcheck style testing library for PyPy
pypy-idna_2.6-1_all.deb Python IDNA2008 (RFC 5891) handling (PyPy)
pypy-ipaddress_1.0.17-1_all.deb Backport of Python 3 ipaddress module (PyPy)
pypy-iso8601_0.1.11-1_all.deb Python module to parse ISO 8601 dates - PyPy
pypy-json-tricks_3.11.0-1_all.deb Python module with extra features for JSON files
pypy-lib-testsuite_5.10.0+dfsg-3build2_all.deb standard library test suite for PyPy (an alternative Python interpreter)
pypy-lib_5.10.0+dfsg-3build2_i386.deb standard library for PyPy (an alternative Python interpreter)
Advertisement
Advertisement