pyprompter_0.9.1-2.1ubuntu4_all.deb


Advertisement

Description

pyprompter - intelligent predictive wxPython text editor

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename pyprompter_0.9.1-2.1ubuntu4_all.deb
Package name pyprompter
Package version 0.9.1
Package release 2.1ubuntu4
Package architecture all
Package type deb
Category universe/misc
Homepage http://presage.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 27.78 KB
Installed size 92.00 KB
This package contains the wxPython predictive text editor pyprompter.
pyprompter is a cross-platform predictive text editor.
pyprompter displays predictions in a contextual pop-up box as each
letter is typed. Predictions can be easily selected and inserted in
the document.

Alternatives

Package Version Architecture Repository
pyprompter_0.9.1-2.1ubuntu4_all.deb 0.9.1 all Ubuntu Universe
pyprompter - - -

Requires

Name Value
python >= 2.7
python << 2.8
python-presage >= 0.9.1-2.1ubuntu4
python-wxgtk3.0 -
python:any >= 2.6.6-7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pyprompter_0.9.1-2.1ubuntu4_all.deb
Source Package presage

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pyprompter deb package:
    # sudo apt-get install pyprompter

Files

Path
/usr/bin/pyprompter
/usr/lib/python2.7/dist-packages/pyprompter-0.9.1.egg-info
/usr/lib/python2.7/dist-packages/prompter/__init__.py
/usr/lib/python2.7/dist-packages/prompter/prompter.py
/usr/share/applications/pyprompter.desktop
/usr/share/doc/pyprompter/AUTHORS
/usr/share/doc/pyprompter/NEWS.gz
/usr/share/doc/pyprompter/README.gz
/usr/share/doc/pyprompter/THANKS
/usr/share/doc/pyprompter/TODO.gz
/usr/share/doc/pyprompter/changelog.Debian.gz
/usr/share/doc/pyprompter/copyright
/usr/share/man/man1/pyprompter.1.gz
/usr/share/pixmaps/pyprompter.png
/usr/share/pixmaps/pyprompter.xpm

Changelog

2016-12-08 - Łukasz 'sil2100' Zemczak <lukasz.zemczak@ubuntu.com>
presage (0.9.1-2.1ubuntu4) zesty; urgency=medium
* debian/patches/add_presage_config_environment_variable.patch:
- Replace use_presage_prefix_path_in_default_profile.patch with a new patch
making sure all works in snap environments
2016-11-04 - Łukasz 'sil2100' Zemczak <lukasz.zemczak@ubuntu.com>
presage (0.9.1-2.1ubuntu3) zesty; urgency=medium
[ Michael Sheldon ]
* debian/patches/use_presage_prefix_path_in_default_profile.patch:
- Use the PRESAGE_PREFIX_PATH environment variable in the default profile
* debian/patches/add-missing-online-learning-configuration-value.patch:
- Add missing ONLINE_LEARNING configuration value to defaultProfile
2016-09-06 - Matthias Klose <doko@ubuntu.com>
presage (0.9.1-2.1ubuntu1) yakkety; urgency=medium
* Merge with Debian; remaining changes:
- Remove python-wxgtk3.0 from Build-Depends
- debian/patches/ubuntu_dont_require_wxpython.patch: Do not check for wx
to enable pyprompter
- debian/patches/dont-tokenize-on-apostrophes.patch: Allow words with
apostrophes to be predicted
2016-07-03 - Aron Xu <aron@debian.org>
presage (0.9.1-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix gcc6 narrowing conversion by Kentaro Hayashi (Closes: #811758)
2016-05-19 - Matthias Klose <doko@ubuntu.com>
presage (0.9.1-2ubuntu1) yakkety; urgency=medium
* Merge with Debian; remaining changes:
- Remove python-wxgtk3.0 from Build-Depends
- debian/patches/ubuntu_dont_require_wxpython.patch: Do not check for wx
to enable pyprompter
- debian/patches/dont-tokenize-on-apostrophes.patch: Allow words with
apostrophes to be predicted
2016-03-17 - Matteo Vescovi <matteo.vescovi@yahoo.co.uk>
presage (0.9.1-2) unstable; urgency=medium
* Depend on swig instead of swig2.0 (Closes: #816999)
* Fix lintian error in libpresage1v5.symbols file
symbols-file-contains-current-version-with-debian-revision.
* Fix lintian warning command-in-menu-file-and-desktop-file.
* Reorder link library flags for gprompter (Closes: #776720)
* Update to latest policy.
2016-02-07 - Matthias Klose <doko@ubuntu.com>
presage (0.9.1-1.1ubuntu2) xenial; urgency=medium
* No-change rebuild for ncurses6 transition.
2015-10-31 - Steve Langasek <steve.langasek@ubuntu.com>
presage (0.9.1-1.1ubuntu1) xenial; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/patches/lib_underlinkage.patch: Added missing lib to link,
fixing FTBFS.
- Remove python-wxgtk3.0 from Build-Depends
- debian/patches/ubuntu_dont_require_wxpython.patch: Do not check for wx
to enable pyprompter
- debian/patches/dont-tokenize-on-apostrophes.patch: Allow words with
apostrophes to be predicted
- Build-depend on swig (3.0) instead of swig2.0.
* Dropped changes, included in Debian:
- Build using GCC 5.
- Update symbols file.
2015-10-04 - ChangZhuo Chen (陳昌倬) <czchen@debian.org>
presage (0.9.1-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Rename package for GCC 5 transition (Closes: #799642)
2015-08-15 - Aron Xu <aron@debian.org>
presage (0.9.1-1) unstable; urgency=medium
* Non-maintainer upload.
* New upstream release (Closes: #792527)

See Also

Package Description
pypump-shell_0.7-1_all.deb interface to the pump.io APIs (pypump-shell program)
pypy-appdirs_1.4.3-1_all.deb determining appropriate platform-specific directories (PyPy)
pypy-asn1crypto_0.24.0-1_all.deb Fast ASN.1 parser and serializer (PyPy)
pypy-attr_17.4.0-2_all.deb Attributes without boilerplate (PyPy)
pypy-bdist-nsi_0.1.5-1_all.deb Create NSIS windows installers for Python modules (PyPy)
pypy-bs4_4.6.0-1_all.deb error-tolerant HTML parser for PyPy
pypy-coverage_4.5+dfsg.1-3_all.deb code coverage tool for Python 2 PyPy
pypy-dev_5.10.0+dfsg-3build2_all.deb header files for PyPy (an alternative Python interpreter)
pypy-doc_5.10.0+dfsg-3build2_all.deb developer Documentation for PyPy (an alternative Python interpreter)
pypy-dulwich_0.18.5-1_i386.deb Python Git library - pypy module
pypy-enum34_1.1.6-2_all.deb backport of Python 3.4's enum package (PyPy package)
pypy-fastimport_0.9.6-3_all.deb Fastimport file format parser and generator library
pypy-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (PyPy)
pypy-funcsigs_1.0.2-4_all.deb function signatures from PEP362 - PyPy
pypy-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (PyPy)
Advertisement
Advertisement