profanity_0.5.1-3_i386.deb


Advertisement

Description

profanity - console based XMPP client

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename profanity_0.5.1-3_i386.deb
Package name profanity
Package version 0.5.1
Package release 3
Package architecture i386
Package type deb
Category universe/net
Homepage http://www.profanity.im/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 283.61 KB
Installed size 1.10 MB
Profanity is a console based instant messaging client for XMPP (Jabber)
protocol based chat. It is written in C and ncurses, and is inspired
by popular IRC client IRSSI.
Profanity's features are:
* XMPP chat services, including GoogleTalk and Slack.
* OTR (off the record) and PGP message encryption.
* Complex roster management with grouping.
* Desktop notifications via libnotify.
* Flexible resource and priority settings.
* Support for colorthemes.
* Support for plugins in C, Python, Ruby, and Lua.
* MUC (multi user chatroom) support.

Alternatives

Package Version Architecture Repository
profanity_0.5.1-3_amd64.deb 0.5.1 amd64 Ubuntu Universe
profanity - - -

Requires

Name Value
libc6 >= 2.15
libcurl3-gnutls >= 7.16.2
libglib2.0-0 >= 2.31.8
libgpgme11 >= 1.2.0
libgtk2.0-0 >= 2.10.0
libncursesw5 >= 6
libnotify4 >= 0.7.0
libotr5 >= 4.0.0
libpython2.7 >= 2.7
libreadline7 >= 6.0
libstrophe0 >= 0.9.1+git20170912
libtinfo5 >= 6
libx11-6 -
libxss1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package profanity_0.5.1-3_i386.deb
Source Package profanity

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install profanity deb package:
    # sudo apt-get install profanity

Files

Path
/usr/bin/profanity
/usr/include/profapi.h
/usr/lib/profanity/libprofanity.la
/usr/lib/profanity/libprofanity.so
/usr/share/doc/profanity/README.md
/usr/share/doc/profanity/TODO.Debian
/usr/share/doc/profanity/changelog.Debian.gz
/usr/share/doc/profanity/copyright
/usr/share/doc/profanity/examples/profrc.example
/usr/share/man/man1/profanity.1.gz
/usr/share/profanity/icons/proIcon.png
/usr/share/profanity/icons/proIconMsg.png
/usr/share/profanity/themes/aqua
/usr/share/profanity/themes/batman
/usr/share/profanity/themes/bios
/usr/share/profanity/themes/boothj5
/usr/share/profanity/themes/boothj5_slack
/usr/share/profanity/themes/complex
/usr/share/profanity/themes/forest
/usr/share/profanity/themes/hacker
/usr/share/profanity/themes/headache
/usr/share/profanity/themes/joker
/usr/share/profanity/themes/mono
/usr/share/profanity/themes/orange
/usr/share/profanity/themes/original
/usr/share/profanity/themes/original_bright
/usr/share/profanity/themes/shade
/usr/share/profanity/themes/simple
/usr/share/profanity/themes/spawn
/usr/share/profanity/themes/whiteness

Changelog

2018-04-06 - W. Martin Borgert <debacle@debian.org>
profanity (0.5.1-3) unstable; urgency=medium
* enable support for Python plugins
2018-02-24 - W. Martin Borgert <debacle@debian.org>
profanity (0.5.1-2) unstable; urgency=medium
* Temporarily disable another problematic unittest (Closes: #890996),
upstream knows about the unittest issues
* Bump dh compat to 11
2018-02-20 - W. Martin Borgert <debacle@debian.org>
profanity (0.5.1-1) unstable; urgency=medium
* New upstream version (Closes: #854735) finally
* move to Debian XMPP Maintainers and salsa.debian.org
* Bump standards version
* Temporarily disabled problematic unittest (Closes: #852261),
hopefully solved in next upstream release
* Depend on current libstrophe (Closes: #857546)
2017-01-07 - Jack Henschel <jh@openmailbox.org>
profanity (0.5.0-0.1) unstable; urgency=medium
[Jack Henschel]
* Non-maintainer upload
* Imported Upstream version 0.5.0 (Closes: #824167)
- requires new version of libstrophe (>= 0.9.0)
* Enable GTK status bar icons, Xscreensaver timeout
and C-plugin support
* Patches
- removed (obsolete) fix_spelling_error.patch
- introduced new fix-spelling-errors.patch
* Update Standards-Version to 3.9.8
[Dariusz Dwornikowski]
* added *.la file dependencies cleaning in d/rules
* changed directory for the internal lib to /usr/lib/profanity
* d/control:
- updated VCS fields to secure
- changed maintainer's email address
- debhelper >=10
* d/copyright:
- added Jack Henschel
- updated dates and emails
2015-09-26 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
profanity (0.4.7-1) unstable; urgency=medium
* Imported Upstream version 0.4.7
* Removed d/patches/add-cflags-linking.patch
* Added fix-spelling patch
* d/control:
- added libreadline-dev to Build-Deps
- added libgpgme11-dev to Build-Deps
- added uuid-dev to Build-Deps
* d/rules:
- enabled gpg support
2015-03-13 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
profanity (0.4.6-1) unstable; urgency=medium
* Imported Upstream version 0.4.6 (Closes: #780362)
2014-11-10 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
profanity (0.4.5-1) unstable; urgency=medium
* Imported Upstream version 0.4.5
* Removed fix-spelling.patch
- fixed in upstream
* Removed endian.patch
- fixed in upstream
* d/copyright
- reomoved entry for endian.patch
2014-10-21 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
profanity (0.4.4-2) unstable; urgency=medium
* Added fix for FTBS on big endian architectures (Closes: #766171)
* Bump standards to 3.9.6 no changes needed
* Added copyright information for d/patches/endian.patch
2014-08-27 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
profanity (0.4.4-1) unstable; urgency=medium
* Initial release (Closes: #745872)

See Also

Package Description
profbval_1.0.22-5_all.deb predictor of flexible/rigid protein residues from sequence
profile-sync-daemon_6.31-1_all.deb Symlink and sync browser profile directories into RAM
profisis_1.0.11-4_all.deb prediction of protein-protein interaction sites from sequence
profitbricks-api-tools_4.1.1-1_all.deb command line tools that use the public API from ProfitBricks
profnet-bval_1.0.22-5_i386.deb neural network architecture for profbval
profnet-chop_1.0.22-5_i386.deb neural network architecture for profchop
profnet-con_1.0.22-5_i386.deb neural network architecture for profcon
profnet-isis_1.0.22-5_i386.deb neural network architecture for profisis
profnet-md_1.0.22-5_i386.deb neural network architecture for metadisorder
profnet-norsnet_1.0.22-5_i386.deb neural network architecture for norsnet
profnet-prof_1.0.22-5_i386.deb neural network architecture for profacc
profnet-snapfun_1.0.22-5_i386.deb neural network architecture for snapfun
profphd-net_1.0.22-5_i386.deb neural network architecture for profphd
profphd-utils_1.0.10-4_i386.deb profphd helper utilities convert_seq and filter_hssp
profphd_1.0.42-2_all.deb secondary structure and solvent accessibility predictor
Advertisement
Advertisement