printer-driver-escpr_1.6.17-2_i386.deb


Advertisement

Description

printer-driver-escpr - printer driver for Epson Inkjet that use ESC/P-R

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename printer-driver-escpr_1.6.17-2_i386.deb
Package name printer-driver-escpr
Package version 1.6.17
Package release 2
Package architecture i386
Package type deb
Category universe/text
Homepage http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX&productName=B700
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 245.82 KB
Installed size 446.00 KB
ESC/P-R is a common language for selected Epson printers that supports every
media type, paper size and associated printing mode available on those
printers. It is suited especially for consumer electronics devices and
embedded equipments. ESC/P-R allows many kinds of devices to connect and
communicate with Epson inkjet printers, expanding possibilities for use with
medical equipment, measuring equipment, electronic whiteboards, and at home
with home electronics and game machines.
This package contains the CUPS filter driver and the compressed PPDs for the
supported printers.

Alternatives

Package Version Architecture Repository
printer-driver-escpr_1.6.17-2_amd64.deb 1.6.17 amd64 Ubuntu Universe
printer-driver-escpr - - -

Requires

Name Value
libc6 >= 2.7
libcups2 >= 1.4.0
libcupsimage2 >= 1.4.0
python3 -
xz-utils -

Replaces

Name Value
epson-escpr << 1.1.0-1~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package printer-driver-escpr_1.6.17-2_i386.deb
Source Package epson-inkjet-printer-escpr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install printer-driver-escpr deb package:
    # sudo apt-get install printer-driver-escpr

Files

Path
/usr/lib/cups/driver/escpr
/usr/lib/cups/filter/epson-escpr
/usr/lib/cups/filter/epson-escpr-wrapper
/usr/lib/printer-driver-escpr/libescpr.so.1
/usr/lib/printer-driver-escpr/libescpr.so.1.0.0
/usr/share/cups/ppd-updaters/printer-driver-escpr.ppd-updater
/usr/share/doc/printer-driver-escpr/changelog.Debian.gz
/usr/share/doc/printer-driver-escpr/copyright

Changelog

2018-02-10 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.17-2) unstable; urgency=medium
* Bump Standards-Version to 4.1.3 without changes needed
* Update Vcs-* fields for the move to salsa.d.o
2017-11-25 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.17-1) unstable; urgency=medium
* New upstream version 1.6.17
- Supported Series:
+ ET-2610
+ EW-M5071FT
* Drop debian/rules trailing spaces
* Set hardening=+all in DEB_BUILD_MAINT_OPTIONS
2017-10-12 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.16-1) unstable; urgency=medium
* New upstream version 1.6.16
- Supported Series:
+ EP-710A
+ EP-810A
+ ET-7700
+ ET-7750
+ EW-M970A3T
+ L405
+ L3050
+ L3060
+ L3070
+ XP-540
+ XP-640
* Bump S-V to 4.1.1 without changes needed
* Drop autotools_dev and autoreconf B-D and dh options, as these are default
in dh compat 10
* Update Vcs-Browser to use https
2017-07-21 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.13-1) unstable; urgency=medium
* New upstream release:
- Supported Series:
- L380
- L382
+ XP-340
* Bump S-V to 4.0.0: add and use autotools-dev for config.{sub,guess}
replacement
* Bump debhelper compat to 10
2017-01-24 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.11-1) unstable; urgency=medium
* New upstream release:
- Supported new Series:
+ ET-2600
+ ET-2650
+ L395
+ L495
2016-12-06 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.10-1) unstable; urgency=medium
* New upstream release:
- Supported new Series:
+ EP-30VA
+ EP-M570T
+ EP-L364
+ EP-L380
+ EP-L382
+ EP-L386
+ EP-L486
+ EP-L605
* Refresh patches
2016-09-27 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.8-1) unstable; urgency=medium
* New upstream release
- Supported new Series:
+ EP-709A
+ EP-979A3
+ ET-16500
+ L1455
+ L385
+ L485
+ PX-049A
+ XP-240
+ XP-243 245 247
+ XP-342 343 345
+ XP-440
+ XP-442 445
+ XP-900
* Initialize git-dpm for patches management, update get-orig-source
2016-04-28 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.5-1) unstable; urgency=medium
* New upstream release
- Supported new models:
+ WF-2750 Series
+ WF-2760 Series
* Bump S-V to 3.9.8 without changes needed
2016-03-25 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.4-1) unstable; urgency=medium
* New upstream release
- Supported new models:
+ XP-330 Series
+ XP-430 Series
* Remove superfluous XS-Testsuite entry, should be added automatically
* Bump S-V to 3.9.7 without changes needed
2016-02-23 - Didier Raboud <odyx@debian.org>
epson-inkjet-printer-escpr (1.6.3-2) unstable; urgency=medium
[ Logan Rosen ]
* Add patch to include xfifo.h in src/filter.c to fix implicit function
declaration

See Also

Package Description
printer-driver-fujixerox_1.1.0+ds-3_i386.deb printer driver for Fuji Xerox printers
printer-driver-indexbraille_1.2.3-1_i386.deb CUPS printing to Index Braille printers
printer-driver-oki_1.0.1-1_all.deb printer driver for OKI Data printers
printrun_1.6.0-1_i386.deb 3D printing host suite
prips_1.0.2-1_i386.deb tool that prints the IP addresses in a given range
prism2-usb-firmware-installer_0.2.9+dfsg-6_i386.deb firmware files for the prism2_usb kernel driver
pristine-tar_1.42_i386.deb regenerate pristine tarballs
privbind_1.2-1.1build1_i386.deb Allow unprivileged apps to bind to a privileged port
privoxy_3.0.26-5_i386.deb Privacy enhancing HTTP Proxy
proalign_0.603-3_i386.deb Probabilistic multiple alignment program
probabel-examples_0.4.5-5_all.deb Example files for ProbABEL
probabel_0.4.5-5_i386.deb Toolset for Genome-Wide Association Analysis
probalign_1.4-7_i386.deb multiple sequence alignment using partition function posterior probabilities
probcons-extra_1.12-11_i386.deb Extra programs from the probcons package
probcons_1.12-11_i386.deb PROBabilistic CONSistency-based multiple sequence alignment
Advertisement
Advertisement