printer-driver-cups-pdf_3.0.1-5_i386.deb


Advertisement

Description

printer-driver-cups-pdf - printer driver for PDF writing via CUPS

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename printer-driver-cups-pdf_3.0.1-5_i386.deb
Package name printer-driver-cups-pdf
Package version 3.0.1
Package release 5
Package architecture i386
Package type deb
Category universe/graphics
Homepage http://www.cups-pdf.de
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 24.04 KB
Installed size 238.00 KB
CUPS-PDF provides a PDF Writer backend to CUPS. This can be used as a
virtual printer in a paperless network or to perform testing on CUPS.
Documents are written to a configurable directory (by default to ~/PDF)
or can be further manipulated by a post-processing command.
Desktop users might find it simpler to use the Print To File feature
provided by GTK+ and QT or the LibreOffice's Export to PDF feature.

Alternatives

Package Version Architecture Repository
printer-driver-cups-pdf_3.0.1-5_amd64.deb 3.0.1 amd64 Ubuntu Universe
printer-driver-cups-pdf - - -

Requires

Name Value
cups -
cups-client -
ghostscript -
libc6 >= 2.7
libcups2 >= 1.4.0
libpaper-utils -

Provides

Name Value
cups-pdf -

Replaces

Name Value
cups-pdf -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package printer-driver-cups-pdf_3.0.1-5_i386.deb
Source Package cups-pdf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install printer-driver-cups-pdf deb package:
    # sudo apt-get install printer-driver-cups-pdf

Files

Path
/etc/cups/cups-pdf.conf
/usr/lib/cups/backend/cups-pdf
/usr/share/apport/package-hooks/printer-driver-cups-pdf.py
/usr/share/bug/printer-driver-cups-pdf/presubj
/usr/share/cups/ppd-updaters/printer-driver-cups-pdf.ppd-updater
/usr/share/doc/printer-driver-cups-pdf/README.Debian
/usr/share/doc/printer-driver-cups-pdf/changelog.Debian.gz
/usr/share/doc/printer-driver-cups-pdf/copyright
/usr/share/ppd/cups-pdf/CUPS-PDF_noopt.ppd
/usr/share/ppd/cups-pdf/CUPS-PDF_opt.ppd

Changelog

2018-02-17 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (3.0.1-5) unstable; urgency=medium
* Removed [examples]: upstream no longer ships contrib (see 3.0.1-1).
* Fixed the following Lintian warnings:
W: global-files-wildcard-not-first-paragraph-in-dep5-copyright
W: maintainer-script-should-not-use-recursive-chown-or-chmod
2017-03-12 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (3.0.1-4) unstable; urgency=medium
[ Tiago Stürmer Daitx ]
* [rules]
= Move cups library to the end to adhere to the standard POSIX-required
behavior and avoid undefined references (Closes: #857500, LP: #1672101)
2017-03-09 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (3.0.1-3) unstable; urgency=medium
* [control]
+ Emphasize that desktop users might prefer GTK+/QT's Print to PDF feature
or LibreOffice's Export to PDF feature (Closes: #857165).
- Suggests: system-config-printer-gnome | system-config-printer-kde
Ubuntu no longer ships -gnome and -kde appears unmaintained.
* [postinst]
+ -o pdftops-renderer-default=pdftocairo (Closes: #658004,#813618,#847462)
Thanks to Brian Potkin for suggesting this solution in #847462.
2017-02-28 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (3.0.1-2) unstable; urgency=medium
* [watch]
- pgpmode=auto
Upstream doesn't publish any GPG signed release.
2017-02-25 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (3.0.1-1) unstable; urgency=medium
* New upstream release (Closes: #503928) implements support for lpoptions.
- [control]
Dropped transitional cups-pdf package.
= [copyright]
Updated upstream and myself to year 2017.
- [copyright]
As per 3.0.beta2 ChangeLog entry:
"Removed contrib/ directory from tarball (now on WWW)"
= [printer-driver-cups-pdf.postint]
Migrated PPD name from CUPS-PDF.ppd to CUPS-PDF_opt.ppd.
+ [rules]
Added -lcups to compiler options.
- [rules]
Removed override_dh_installdocs.
+ Build-Depends: libcups2-dev
- Dropped obsolete patches:
fix_wunusedresult_on_recent_gcc.patch
truncate_title_to_first_newline.patch
update_upstreams_e-mail_address.patch
= Refreshed patches:
debian_changes_to_cups-pdf_conf.patch
ubuntu_changes_to_cups-pdf_conf.patch
2016-11-16 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (2.6.1-22) unstable; urgency=medium
* Fix "cups-pdf FTCBFS: uses build architecture compiler" (Closes: #843910)
+ Added [debian/rules] fragment:
export CC := $(shell dpkg-architecture --query DEB_HOST_GNU_TYPE)-gcc
= Thanks to Helmut Grohne for the alternate patch.
* Updated the Copyright years in [debian/rules] and [debian/copyright].
* Bumped Standards-Version to 3.9.8 (no change required).
2016-02-23 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (2.6.1-21) unstable; urgency=medium
* Fixed Lintian "W: spelling-error-in-readme-debian: debuging debugging"
* Bumped Standards-Version to 3.9.7 (no change required).
2015-05-12 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (2.6.1-20) unstable; urgency=medium
* Fixed "Syntax error in printer-driver-cups-pdf.postint" (Closes: #785049).
Thanks to Jason Rhinelander for the bug report and the solution.
2015-05-06 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (2.6.1-19) unstable; urgency=medium
* Bumped debhelper compat to 9.
2015-05-06 - Martin-Éric Racine <martin-eric.racine@iki.fi>
cups-pdf (2.6.1-18) unstable; urgency=medium
* Bumped debhelper compat to 8.
* debian/printer-driver-cups-pdf.[postinst|prerm|postrm]:
= Harmonize CUPS automation as much as possible between all three scripts.
* debian/printer-driver-cups-pdf.postinst:
+ Skip automated creation of PDF queue if /run/cups/certs/ doesn't exist.
This restores installability inside a chroot (Closes: #539156,#614713).

See Also

Package Description
printer-driver-dymo_1.4.0-8_i386.deb printer driver for DYMO label printers
printer-driver-escpr_1.6.17-2_i386.deb printer driver for Epson Inkjet that use ESC/P-R
printer-driver-fujixerox_1.1.0+ds-3_i386.deb printer driver for Fuji Xerox printers
printer-driver-indexbraille_1.2.3-1_i386.deb CUPS printing to Index Braille printers
printer-driver-oki_1.0.1-1_all.deb printer driver for OKI Data printers
printrun_1.6.0-1_i386.deb 3D printing host suite
prips_1.0.2-1_i386.deb tool that prints the IP addresses in a given range
prism2-usb-firmware-installer_0.2.9+dfsg-6_i386.deb firmware files for the prism2_usb kernel driver
pristine-tar_1.42_i386.deb regenerate pristine tarballs
privbind_1.2-1.1build1_i386.deb Allow unprivileged apps to bind to a privileged port
privoxy_3.0.26-5_i386.deb Privacy enhancing HTTP Proxy
proalign_0.603-3_i386.deb Probabilistic multiple alignment program
probabel-examples_0.4.5-5_all.deb Example files for ProbABEL
probabel_0.4.5-5_i386.deb Toolset for Genome-Wide Association Analysis
probalign_1.4-7_i386.deb multiple sequence alignment using partition function posterior probabilities
Advertisement
Advertisement