primus-libs_0~20150328-6_i386.deb


Advertisement

Description

primus-libs - Shared libraries for primus

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename primus-libs_0~20150328-6_i386.deb
Package name primus-libs
Package version 0~20150328
Package release 6
Package architecture i386
Package type deb
Category universe/utils
Homepage https://github.com/amonakov/primus
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 51.60 KB
Installed size 259.00 KB
This package contains the libraries for primus which are loaded when running
primusrun.

Alternatives

Package Version Architecture Repository
primus-libs_0~20150328-6_amd64.deb 0~20150328 amd64 Ubuntu Universe
primus-libs - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libgl1-mesa-glx -
libstdc++6 >= 5.2
libx11-6 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package primus-libs_0~20150328-6_i386.deb
Source Package primus

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install primus-libs deb package:
    # sudo apt-get install primus-libs

Files

Path
/usr/lib/i386-linux-gnu/primus/libGL.so.1
/usr/share/doc/primus-libs/changelog.Debian.gz
/usr/share/doc/primus-libs/copyright

Changelog

2018-01-22 - Luca Boccassi <bluca@debian.org>
primus (0~20150328-6) unstable; urgency=medium
* Bump Standards-Version to 4.1.3, no changes.
* Break: nvidia-driver-libs and suggest nvidia-driver-libs-nonglvnd.
(Closes: #888020)
2017-10-10 - Luca Boccassi <bluca@debian.org>
primus (0~20150328-5) unstable; urgency=medium
* Switch to @debian.org email address.
* Switch priority from "extra" to "optional" to comply with policy 4.0.1.
* Use https for Vcs fields in d/control.
* Use https for the d/copyright format field to comply with policy 4.0.0.
* Bump Standards-Version to 4.1.1.
* Do not install primus with the GLVND-enabled Nvidia packages, as they
are not quite compatible yet. (Closes: #876033)
2016-07-22 - Luca Boccassi <luca.boccassi@gmail.com>
primus (0~20150328-4) unstable; urgency=medium
* Depend alternatively on xserver-xorg-video-intel or
xserver-xorg-core >= 2:1.18.3-2, as both enable SNA by default.
2016-07-18 - Luca Boccassi <luca.boccassi@gmail.com>
primus (0~20150328-3) unstable; urgency=medium
* Move xserver-xorg-video-intel dependency from primus-libs to primus.
(Closes: #831640)
2016-07-17 - Luca Boccassi <luca.boccassi@gmail.com>
primus (0~20150328-2) unstable; urgency=medium
* Add myself to Uploaders.
* Bump Standards-Version to 3.9.8, no changes.
* Remove -dbg package in favour of -dbgsym.
* Add dependency to xserver-xorg-video-intel >= 2.99.17 for SNA.
2015-07-25 - Vincent Cheng <vcheng@debian.org>
primus (0~20150328-1) unstable; urgency=medium
* New upstream git snapshot.
- rebase on d1afbf6fce
- refresh hardening.patch
* Build with PRIMUS_UPLOAD=0 now that xserver-xorg-video-intel in sid has
SNA enabled by default.
* Add dependency on libgl1-mesa-glx to primus-libs. (LP: #1383909)
* Move bumblebee bash-completion file from obsolete /etc/bash_completion.d/
to /usr/share/bash-completion/completions/.
2014-01-15 - Vincent Cheng <vcheng@debian.org>
primus (0~20140711-1) unstable; urgency=medium
[ Vincent Cheng ]
* New upstream git snapshot.
- rebase on 4e000124ec
* Update email address.
* Update Standards version to 3.9.6, no changes required.
[ Andreas Beckmann ]
* hardening.patch: New. Use all variables that contain hardening flags.
2014-01-07 - Vincent Cheng <Vincentc1208@gmail.com>
primus (0~20131127-2) unstable; urgency=medium
* Build with PRIMUS_UPLOAD=1 to avoid a bug triggered by using primus and
xserver-xorg-video-intel with UXA acceleration enabled (which is currently
the default with xserver-xorg-video-intel 2:2.21.15-1 in unstable).
This workaround will remain in effect until xserver-xorg-video-intel
defaults to SNA in unstable. This flag will not be set if build
environment is Ubuntu, as SNA is already enabled by default (in trusty).
2014-01-06 - Vincent Cheng <Vincentc1208@gmail.com>
primus (0~20131127-1) unstable; urgency=medium
* New upstream git snapshot.
- rebase on 074817614c
* Update Standards version to 3.9.5, no changes required.
2013-10-23 - Vincent Cheng <Vincentc1208@gmail.com>
primus (0~20130904-1) unstable; urgency=low
* New upstream git snapshot.
- rebase on da6459236b

See Also

Package Description
primus_0~20150328-6_i386.deb client-side GPU offloading for NVIDIA Optimus
print-manager_17.12.3-0ubuntu1_i386.deb printer configuration and monitoring tools
printemf_1.0.9+git.10.3231442-1_i386.deb Enhanced Metafile library (executable)
printer-driver-all-enforce_0.20170124_all.deb printer drivers metapackage - enforcing version
printer-driver-all_0.20170124_all.deb printer drivers metapackage
printer-driver-c2050_0.3b-8_i386.deb printer driver for Lexmark 2050 Color Jetprinter
printer-driver-cjet_0.8.9-7_i386.deb printer driver for Canon LBP laser printers
printer-driver-cups-pdf_3.0.1-5_i386.deb printer driver for PDF writing via CUPS
printer-driver-dymo_1.4.0-8_i386.deb printer driver for DYMO label printers
printer-driver-escpr_1.6.17-2_i386.deb printer driver for Epson Inkjet that use ESC/P-R
printer-driver-fujixerox_1.1.0+ds-3_i386.deb printer driver for Fuji Xerox printers
printer-driver-indexbraille_1.2.3-1_i386.deb CUPS printing to Index Braille printers
printer-driver-oki_1.0.1-1_all.deb printer driver for OKI Data printers
printrun_1.6.0-1_i386.deb 3D printing host suite
prips_1.0.2-1_i386.deb tool that prints the IP addresses in a given range
Advertisement
Advertisement