prelude-utils_4.1.0-4_i386.deb


Advertisement

Description

prelude-utils - Security Information and Events Management system [ Utils ]

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename prelude-utils_4.1.0-4_i386.deb
Package name prelude-utils
Package version 4.1.0
Package release 4
Package architecture i386
Package type deb
Category universe/utils
Homepage https://www.prelude-siem.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 38.35 KB
Installed size 129.00 KB
The Prelude Library is a collection of generic functions providing
communication between the Prelude SIEM suite components. It provides a
convenient interface for sending alerts to Prelude Manager with transparent
SSL, failover and replication support, asynchronous events and timer
interfaces, an abstracted configuration API (hooking at the commandline, the
configuration line, or wide configuration, available from the Manager), and a
generic plugin API. It allows you to easily turn your favorite security
program into a Prelude sensor.
This package contains the Prelude shared library utils.

Alternatives

Package Version Architecture Repository
prelude-utils_4.1.0-4_amd64.deb 4.1.0 amd64 Ubuntu Universe
prelude-utils - - -

Requires

Name Value
libc6 >= 2.16
libgnutls30 >= 3.5.6
libprelude23 >= 4.1
ruby << 1:2.6~

Replaces

Name Value
libprelude2 -
libprelude23 << 4.1.0-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package prelude-utils_4.1.0-4_i386.deb
Source Package libprelude

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install prelude-utils deb package:
    # sudo apt-get install prelude-utils

Files

Path
/etc/prelude/default/client.conf
/etc/prelude/default/global.conf
/etc/prelude/default/idmef-client.conf
/etc/prelude/default/tls.conf
/usr/bin/prelude-admin
/usr/share/doc/prelude-utils/changelog.Debian.gz
/usr/share/doc/prelude-utils/copyright
/usr/share/man/man1/prelude-admin.1.gz

Changelog

2018-03-11 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-4) unstable; urgency=medium
* Fix FTBFS with gcc-8: symbol mismatch (Closes: #892588)
* d/control: Add multiarch fields
2018-03-07 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-3) unstable; urgency=medium
* Fix FTBFS on x32: symbols mismatch (Closes: #892171)
Thanks Mattia Rizzolo
2018-03-06 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-2) unstable; urgency=medium
* Fix migrating from stable (Closes: #892051)
* Fix symbols file for 32 bit architectures (Closes: #892104)
2018-02-28 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-1) unstable; urgency=medium
* Bump version 4.1.0 (Closes: #891800)
- New patches:
011-fix_spelling_error.patch
012-fix-server_confirm_type.patch (Closes: #689434)
- Remove unnecessary patches:
002-manpages-spelling.patch
003-disable_gnulib_test_lock.patch
009-update-gtkdoc-files.patch
- Fix license-problem-non-free-RFC for src/common.c
* Update d/control
- Bump to Standards-Version 4.1.3
- Update Vcs-* to Salsa
- Update debhelper to 11
- Split libprelude23 to libprelude23 and libprelude-utils (Closes: #855916)
This new package handle /etc/prelude dir and prelude-admin binary
- Update packages description
* Update d/compat to 11
* Add symbols files for libprelude23 and libpreludecpp8
* Update d/copyright: update dates to 2017
2017-11-03 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-1) unstable; urgency=medium
* Add patch to fix compatibility with GnutLS 3.6 when using prelude-admin
- 010-fix_compatibility_gnutls_3_6.patch
* Update d/control
- Add Thomas Andrejak as uploader
- Bump to Standards-Version 4.1.1
- Add Vcs* fields
- Change Priority from extra to optional
* Remove trailing whitespaces in d/changelog
2017-09-24 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.6) unstable; urgency=medium
* Non-maintainer upload.
* Update gtkdoc files to be compatible with gtkdoc-1.26 (Closes: #876591)
- Update gtk-doc.make and m4/gtk-doc.m4
- Using https://github.com/GNOME/gtk-doc
* Add libglib2.0-dev to build-dep-indep because it is required for gtk-doc
2017-08-28 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.5) unstable; urgency=medium
* Non-maintainer upload.
* Rebuild with GCC 7. (Closes: #871289)
- Build-depend on gcc >= 7.
- Update shlibs to ensure rdeps pull in the new version.
2017-07-17 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.4) unstable; urgency=medium
* Upload to unstable.
2017-06-27 - Mattia Rizzolo <mattia@debian.org>
libprelude (3.1.0-0.3) experimental; urgency=medium
* Non-maintainer upload.
* Bump Standards-Version to 4.0.0, no changes needed.
* Bump debhelper compat level to 10:
+ Drop explicit autoreconf, now part of debhelper standard sequence.
* Fix arch-dep only build, by fixing an inverted boolean check.
2017-06-22 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.2) experimental; urgency=medium
* Non-maintainer upload.
* Control:
- Support Build profiles nopython, noperl, nolua and noruby; also build
the documentation only when building the indep packages (Closes: #838115)
- Add Replace and Breaks for transition (Closes: #864460)
* Patches:
- 007-fix_libprelude-error_hurd.patch: patch for errno on hurd-i386
- 008-disable_test-poll_on_kfreebsd.patch: Disable test-poll test in
libmissing on kfreebsd

See Also

Package Description
preludedb-utils_4.1.0-1_i386.deb Security Information and Events Management System [ Library utils ]
premake4_4.3+repack1-2build1_i386.deb cross-platform build script generator
prepair-data_0.7.1-1build4_all.deb polygon repair tool -- example data
prepair_0.7.1-1build4_i386.deb polygon repair tool
preprocess_1.1.0+ds-1build1_all.deb portable multi-language file preprocessor
prerex_6.5.4-1_i386.deb course prerequisite chart editor for LaTeX/TikZ
presage-dbus_0.9.1-2.1ubuntu4_all.deb intelligent predictive text entry platform (D-Bus service)
presage_0.9.1-2.1ubuntu4_i386.deb intelligent predictive text entry platform (tools and demos)
presentty_0.2.0-1_i386.deb Console-based presentation software
preview.app_0.8.5-10build4_i386.deb General purpose image viewer for GNUstep
previsat_3.5.1.7+dfsg1-2ubuntu1_i386.deb satellite tracking software for observing purposes
prewikka_4.1.5-2_all.deb Security Information and Events Management System [ Web Interface ]
prey_0.6.2-1.1_all.deb utility for tracking stolen computers
price.app_1.3.0-1build2_i386.deb Image filtering and manipulation using GNUstep
prime-phylo_1.0.11-4build2_i386.deb bayesian estimation of gene trees taking the species tree into account
Advertisement
Advertisement