prelude-lml_4.1.0-1_i386.deb


Advertisement

Description

prelude-lml - Security Information and Events Management System [ Log Agent ]

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename prelude-lml_4.1.0-1_i386.deb
Package name prelude-lml
Package version 4.1.0
Package release 1
Package architecture i386
Package type deb
Category universe/admin
Homepage https://www.prelude-siem.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 89.39 KB
Installed size 261.00 KB
The Prelude Log Monitoring Lackey (LML) is the host-based sensor program part
of the Prelude SIEM suite. It can act as a centralized log collector for local
or remote systems, or as a simple log analyzer (such as swatch). It can run as
a network server listening on a syslog port or analyze log files. It supports
logfiles in the BSD syslog format and is able to analyze any logfile by using
the PCRE library. It can apply logfile-specific analysis through plugins such
as PAX. It can send an alert to the Prelude Manager when a suspicious log entry
is detected.

Alternatives

Package Version Architecture Repository
prelude-lml_4.1.0-1_amd64.deb 4.1.0 amd64 Ubuntu Universe
prelude-lml - - -

Requires

Name Value
libc6 >= 2.17
libgnutls30 >= 3.5.6
libicu60 >= 60.1-1~
libpcre3 -
libprelude23 >= 4.1
prelude-lml-rules >= 3.1.0-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package prelude-lml_4.1.0-1_i386.deb
Source Package prelude-lml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install prelude-lml deb package:
    # sudo apt-get install prelude-lml

Files

Path
/etc/prelude-lml/plugins.rules
/etc/prelude-lml/prelude-lml.conf
/lib/systemd/system/prelude-lml.service
/usr/bin/prelude-lml
/usr/include/prelude-lml/prelude-lml.h
/usr/lib/i386-linux-gnu/prelude-lml/debug.so
/usr/lib/i386-linux-gnu/prelude-lml/pcre.so
/usr/lib/tmpfiles.d/prelude-lml.conf
/usr/share/doc/prelude-lml/AUTHORS
/usr/share/doc/prelude-lml/HACKING.README
/usr/share/doc/prelude-lml/NEWS.gz
/usr/share/doc/prelude-lml/README
/usr/share/doc/prelude-lml/README.Debian
/usr/share/doc/prelude-lml/changelog.Debian.gz
/usr/share/doc/prelude-lml/copyright

Changelog

2018-03-15 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-lml (4.1.0-1) unstable; urgency=medium
* Bump version 4.1.1
- Update dependencies: libprelude 4.1 is required and also prelude-utils
* d/control:
- Update description
- Update Vcs-* fields to salsa
- Bump Standards-Version to 4.1.3
- Bump to debhelper and compat 11
* Update d/rules and remove d/prelude-lml.postinst to use new systemd
helpers
* Update copyrights dates
2017-12-17 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-lml (3.1.0-2) unstable; urgency=medium
* Push to unstable
* Bump Standards-Version to 4.1.2, no changes needed
* Remove rulesets since they are now in prelude-lml-rules
package (Closes: #884415)
2017-11-12 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-lml (3.1.0-1) experimental; urgency=medium
* Updating rules file:
- Add systemd support
- Reoganize dh call
- Add missing creation of /var/spool/prelude/prelude-lml
* Addition of the upstream signing key
* Update of watch file:
- Update URL since upstream website moved
- Add GPG check
* Migrate from init.d to systemd
- Remove init script and add .maintscript to handle update
- Add service and tmpfile
- Update postrm and rename it to prelude-lml.postrm
- Add prelude-lml.postinst to add creation of tmpfile
* Remove unnecessary dirs file
* Update README.debian
* New upstream release 3.1.0 (Closes: #878607)
* Patches:
- Remove unnecessary patches now that upstream included them
- 001-debian_log_paths: Update this patch for new prelude-lml version
- 002-Fix_spellcheck.patch: Fix spelling inside prelude-lml binary
* Control:
- Add Thomas Andrejak as uploader
- Remove Mickael Profeta from uploaders (Closes: #838925)
- Remove hardcoded Pre-Depends on multiarch-support (Closes: #870559)
- Remove rsyslog from Recommends
- Remove quilt build-dep
- Change Priority from extra to optional
- Add Vcs fields
- Bump Standards-Version to 4.1.1
- Bump debhelper compat level to 10
- Set Homepage field
* Rewriting of copyright file to fit the machine-readable format
* Add missing copyright information
* Add LML rules that are now shipped with prelude-lml-rules
* Fix some trailing whitespaces in changelog
2014-08-30 - Andreas Metzler <ametzler@debian.org>
prelude-lml (1.0.0-5.3) unstable; urgency=medium
* Non-maintainer upload.
* Brown paper bag release.
* Really add pkg-config to b-d.
2014-08-30 - Andreas Metzler <ametzler@debian.org>
prelude-lml (1.0.0-5.2) unstable; urgency=medium
* Non-maintainer upload.
* Configure with ICU_CFLAGS="$(shell pkg-config --cflags icu-i18n)" and
ICU_LIBS="$(shell pkg-config --libs icu-i18n)" instead of letting
./configure use icu-config. The latter prints out icu's compile-time
cflags including -fPIE (see #759792) which causes a build-error on amd64
et al. Closes: #759247
2014-08-15 - Andreas Metzler <ametzler@debian.org>
prelude-lml (1.0.0-5.1) unstable; urgency=medium
* Non-maintainer upload.
* Rebuild against GnuTLS 3. Drop build-dependency on libgnutls-dev, instead
rely on libprelude-dev pulling in GnuTLS (unused by prelude-lml) and
gcrypt development packages.
2013-07-02 - Pierre Chifflier <pollux@debian.org>
prelude-lml (1.0.0-5) unstable; urgency=low
* Bump Standards Version to 3.9.4
* Refreshed quilt patches
* Fix FTBFS with eglibc 2.17 (Closes: #701411)
2012-06-18 - Pierre Chifflier <pollux@debian.org>
prelude-lml (1.0.0-4) unstable; urgency=high
* Disable tests to avoid build failure on on kFreeBSD (Closes: #677852)
* Urgency high, RC bug
2012-06-16 - Pierre Chifflier <pollux@debian.org>
prelude-lml (1.0.0-3) unstable; urgency=high
* Trigger rebuild (Closes: #676028)
* Bump Standards Version to 3.9.3
* Switch to dpkg-source 3.0 (quilt) format
* Switch to DH version 9
- Enable hardening options
- Enable multi-arch
* Urgency high, RC bugs

See Also

Package Description
prelude-manager_4.1.1-2_i386.deb Security Information and Events Management System [ Manager ]
prelude-notify_0.9.1-1.1_all.deb Security Information Management System [ Desktop Notifier ]
prelude-utils_4.1.0-4_i386.deb Security Information and Events Management system [ Utils ]
preludedb-utils_4.1.0-1_i386.deb Security Information and Events Management System [ Library utils ]
premake4_4.3+repack1-2build1_i386.deb cross-platform build script generator
prepair-data_0.7.1-1build4_all.deb polygon repair tool -- example data
prepair_0.7.1-1build4_i386.deb polygon repair tool
preprocess_1.1.0+ds-1build1_all.deb portable multi-language file preprocessor
prerex_6.5.4-1_i386.deb course prerequisite chart editor for LaTeX/TikZ
presage-dbus_0.9.1-2.1ubuntu4_all.deb intelligent predictive text entry platform (D-Bus service)
presage_0.9.1-2.1ubuntu4_i386.deb intelligent predictive text entry platform (tools and demos)
presentty_0.2.0-1_i386.deb Console-based presentation software
preview.app_0.8.5-10build4_i386.deb General purpose image viewer for GNUstep
previsat_3.5.1.7+dfsg1-2ubuntu1_i386.deb satellite tracking software for observing purposes
prewikka_4.1.5-2_all.deb Security Information and Events Management System [ Web Interface ]
Advertisement
Advertisement