prayer-templates-dev_1.3.5-dfsg1-4build1_i386.deb


Advertisement

Description

prayer-templates-dev - tools for compiling Prayer templates

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename prayer-templates-dev_1.3.5-dfsg1-4build1_i386.deb
Package name prayer-templates-dev
Package version 1.3.5
Package release dfsg1-4build1
Package architecture i386
Package type deb
Category universe/mail
Homepage http://www-uxsup.csx.cam.ac.uk/~dpc22/prayer/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 43.00 KB
Installed size 159.00 KB
Prayer is yet another Webmail interface.
It is unusual in that it is a complete, standalone, HTTP server and proxy
rather a Apache/mod_php plugin. Prayer maintains persistent connections to
the IMAP server and is written entirely in C. Consequently it is much
faster than most open source Webmail interfaces and puts very little load
on either the machines running the Web server or the backend IMAP servers
(even if traditional Unix format mailfolders are in use).
Prayer uses its own macro expansion language for the HTML it
outputs. This package contains the programs and scripts needed to
build template libraries, as well as a makefile to facilitate the
process.

Alternatives

Package Version Architecture Repository
prayer-templates-dev_1.3.5-dfsg1-4build1_amd64.deb 1.3.5 amd64 Ubuntu Universe
prayer-templates-dev - - -

Requires

Name Value
gcc -
libc6 >= 2.4
make -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package prayer-templates-dev_1.3.5-dfsg1-4build1_i386.deb
Source Package prayer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install prayer-templates-dev deb package:
    # sudo apt-get install prayer-templates-dev

Files

Path
/usr/include/prayer/misc.h
/usr/include/prayer/template_structs.h
/usr/lib/prayer/build_index.pl
/usr/lib/prayer/makedeps.pl
/usr/lib/prayer/template_compile
/usr/lib/prayer/template_expand
/usr/share/doc/prayer-templates-dev/README.Debian
/usr/share/doc/prayer-templates-dev/TEMPLATES.gz
/usr/share/doc/prayer-templates-dev/changelog.Debian.gz
/usr/share/doc/prayer-templates-dev/copyright
/usr/share/prayer/config.make
/usr/share/prayer/template-set.make

Changelog

2018-02-05 - Dimitri John Ledkov <xnox@ubuntu.com>
prayer (1.3.5-dfsg1-4build1) bionic; urgency=high
* No change rebuild against openssl1.1.
2016-10-29 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.5-dfsg1-4) unstable; urgency=low
* Switch from CDBS to dh and debhelper compat level 9.
* openssl1.1.patch: Support OpenSSL 1.1 API changes (Closes: #828512).
* Support for Entropy Gathering Daemon removed because it's really old
and support for it is no longer enabled in OpenSSL by default.
* Add missing lsb-base dependencies.
* prayer.postrm: remove hard-coded path to deluser.
* Bump Standards-Version to 3.9.8.
2014-10-29 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.5-dfsg1-3) unstable; urgency=low
* disable_ssl3.patch (new): Disable SSL 3.0 due to CVE-2014-3566
(POODLE).
* debian/Config: Disable ACCOUNTD_SSL_ENABLE since the SSL/TLS support
in prayer-accountd and prayer-session is incomplete and never was
functional.
2013-07-18 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.5-dfsg1-2) unstable; urgency=high
* dlopen_templates.patch: Use MYCFLAGS (which is initialized to the
value of CFLAGS from dpkg-buildflags in the Config file) instead of
CFLAGS in templates/{src,cam,old}/Makefile (Closes: #715310, LP:
#1201216). The --defsym options were lost when we let CDBS override
CFLAGS in the previous upload.
2013-06-12 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.5-dfsg1-1) unstable; urgency=low
* New upstream release.
* Refresh patches.
* Drop dummy package prayer-templates.
* No longer override CDBS overriding CFLAGS, thereby allowing hardening
flags to be properly propagated. I think it caused internal include
flags to be lost, but since at least 1.3.2 that's no longer the case.
* Bump Standards-Version to 3.9.4.
* hurd.patch: Always define HAVE_SHADOW. The test for BSD4_4 seems
bogus; it is defined on Hurd, but crypt(3) is available there.
2011-08-27 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.4-dfsg1-1) unstable; urgency=low
* New upstream release.
- Drop ipv6_v6only.patch; fixed upstream.
* template_sdk.patch: templates/src/build_index.pl no longer need to
be patched.
* Bump Standards-Version to 3.9.2.
2011-03-27 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.3-dfsg1-4) unstable; urgency=low
* Merge ld-as-needed.diff from Ubuntu into dlopen_templates.patch
(Closes: #607559).
* dlopen_templates.patch: Add missing #include "dlopen_templates.h" to
servers/prayer_shared.h.
* hurd.patch (new): Use the SPT_CHANGEARGV implementation of
setproctitle() on the Hurd.
* Add basic manpage for prayer-accountd(8).
* unbrand_accountd.patch: Remove some Cambridge-specific parts of the
filter handling.
* Drop obsolete Build-Depends alternative libc-client2007b-dev.
* Increase Debhelper compat level to 7.
2010-12-19 - Matthias Klose <doko@ubuntu.com>
prayer (1.3.3-dfsg1-3ubuntu1) natty; urgency=low
* Fix FTBFS with ld --as-needed.
2010-12-16 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.3-dfsg1-3) unstable; urgency=high
* ipv6_v6only.patch (new): Set the IPV6_V6ONLY socket option on
AF_INET6 sockets; since Prayer by default enumerates available address
families and calls bind() once for each, conflicts will occur
otherwise (Closes: #607261).
2010-08-07 - Magnus Holmgren <holmgren@debian.org>
prayer (1.3.3-dfsg1-2) unstable; urgency=high
* Convert (trivially, since CDBS with quilt was already used) to source
format 3.0 (quilt).
* no_db_version_check.patch: Remove unnecessary and incorrect check that
not only the major and minor version numbers of the current libdb are
the same as at compile time, but also that the patch number is equal
or greater, which should not be a concern (Closes: #592119).

See Also

Package Description
prayer-templates-src_1.3.5-dfsg1-4build1_all.deb templates for customizing Prayer Webmail
prayer_1.3.5-dfsg1-4build1_i386.deb standalone IMAP-based webmail server
prboom-plus-game-server_2.5.1.5+svn4531+dfsg1-1_i386.deb enhanced clone of the classic first-person shooter Doom (server)
prboom-plus_2.5.1.5+svn4531+dfsg1-1_i386.deb enhanced clone of the classic first-person shooter Doom
prctl_1.6-1build1_i386.deb Process control operations
predict-gsat_2.2.3-4build2_i386.deb Graphical Satellite Tracking Client Program
predict_2.2.3-4build2_i386.deb Satellite Tracking Program with Optional Voice Output
predictnls_1.0.20-4_all.deb prediction and analysis of protein nuclear localization signals
predictprotein_1.1.07-3_all.deb suite of protein sequence analysis tools
prelink_0.0.20131005-1_i386.deb ELF prelinking utility to speed up dynamic linking
preload_0.6.4-2build1_i386.deb adaptive readahead daemon
prelude-correlator_4.1.1-2_all.deb Security Information and Events Management System [ Correlator ]
prelude-lml-rules_4.1.0-1_all.deb Security Information and Events Management System [ LML Rules ]
prelude-lml_4.1.0-1_i386.deb Security Information and Events Management System [ Log Agent ]
prelude-manager_4.1.1-2_i386.deb Security Information and Events Management System [ Manager ]
Advertisement
Advertisement