pocl-opencl-icd_1.1-5_i386.deb


Advertisement

Description

pocl-opencl-icd - pocl ICD

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename pocl-opencl-icd_1.1-5_i386.deb
Package name pocl-opencl-icd
Package version 1.1
Package release 5
Package architecture i386
Package type deb
Category universe/libs
Homepage http://portablecl.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.06 KB
Installed size 24.00 KB
Portable Computing Language is an open source implementation of the OpenCL
standard which can be easily adapted for new targets. One of the goals of the
project is improving performance portability of OpenCL programs, avoiding the
need for target-dependent manual optimizations. A "native" target is included,
which allows running OpenCL kernels on the host (CPU).
This package allows one to use pocl as an installable client driver (ICD) for
OpenCL.

Alternatives

Package Version Architecture Repository
pocl-opencl-icd_1.1-5_amd64.deb 1.1 amd64 Ubuntu Universe
pocl-opencl-icd - - -

Requires

Name Value
libpocl2 = 1.1-5

Provides

Name Value
opencl-icd -
opencl-icd-1.1-1 -
opencl-icd-1.2-1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pocl-opencl-icd_1.1-5_i386.deb
Source Package pocl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pocl-opencl-icd deb package:
    # sudo apt-get install pocl-opencl-icd

Files

Path
/etc/OpenCL/vendors/pocl.icd
/usr/share/doc/pocl-opencl-icd/README
/usr/share/doc/pocl-opencl-icd/TODO
/usr/share/doc/pocl-opencl-icd/changelog.Debian.gz
/usr/share/doc/pocl-opencl-icd/copyright

Changelog

2018-04-09 - Andreas Beckmann <anbe@debian.org>
pocl (1.1-5) unstable; urgency=medium
* Upload to unstable.
2018-04-06 - Andreas Beckmann <anbe@debian.org>
pocl (1.1-4) experimental; urgency=medium
* Run clinfo during testing.
* Do not link with --rtlib=compiler-rt on non-x86.  (Closes: #892426)
* Prevent PIC/no-PIC option clash on mips64el.
* Set target cpu for armel to arm946e-s (arch=armv5te).
* Set target cpu for armhf to arm1156t2f-s (arch=armv6t2) with
-mfpu=vfp3-d16. Probably suboptimal (should rather be arch=armv7-a without
neon,vfp4), but passes all tests.  (Closes: #888063)
* Bump Standards-Version to 4.1.4, no changes needed.
2018-03-27 - Andreas Beckmann <anbe@debian.org>
pocl (1.1-3) experimental; urgency=medium
* Add support for building for the GENERIC cpu, i.e. llvm defaults.
* Build with -DLLC_HOST_CPU=GENERIC on most architectures.
* Build with -DKERNELLIB_HOST_CPU_VARIANTS=distro on amd64.
* Switch to llvm 6.0.
2018-03-25 - Andreas Beckmann <anbe@debian.org>
pocl (1.1-2) experimental; urgency=medium
* Switch to llvm 5.0.
* Update symbols files for amd64 and i386.
* Cherry-pick upstream commits for libhwloc 2.0 support.
* Cherry-pick upstream commit fixing test_clCreateSubDevices with 3 CUs.
* Cherry-pick upstream commit fixing reported values of native/preferred
vector width for unsupported types.
* pocl-doc: Mark as Multi-Arch: foreign.
* Upload to experimental.
2018-03-10 - Andreas Beckmann <anbe@debian.org>
pocl (1.1-1) unstable; urgency=medium
* New upstream release.
* Remove patches, applied or fixed upstream.
* Remove -DFORCE_OCL_KERNEL_TARGET_CPU=ON, fixed upstream.
* Report the error code on test failure.
* Point watch file to git tags on github.
* Add debian/upstream/metadata.
* Upload to unstable.
2018-02-27 - Andreas Beckmann <anbe@debian.org>
pocl (1.1~rc2-1) experimental; urgency=medium
* New upstream release candidate.  (Closes: #888062)
* Remove patches that were applied upstream.
* Update symbols files.
* Do not attempt to run the testsuite during an arch-indep build.
* Set LLVM_ARCH for arm64, armel, armhf to generic.
* Set LLVM_ARCH for s390x to z10.  (Closes: #888064)
* Drop internal helper library packages libpoclu-dev and libpoclu2.
* Add altivec.patch to get rid of the conflicting bool and vector macros
from altivec.h.  (Closes: #764561)
* Update Lintian overrides.
* Upload to experimental.
2018-01-19 - Andreas Beckmann <anbe@debian.org>
pocl (1.0-2) unstable; urgency=medium
* Merge changes from 0.14-7.
* Build with SLEEF instead of VECMATHLIB.
* HACK: Ignore test failure for kernel/test_fabs on i386.
* Add and use new CMake option -DFORCE_OCL_KERNEL_TARGET_CPU=ON.
* Upload to unstable.
2018-01-17 - Andreas Beckmann <anbe@debian.org>
pocl (1.0-1) experimental; urgency=medium
* New upstream release.
* Refresh/remove patches.
* Build with -DPOCL_ICD_ABSOLUTE_PATH=OFF.
* Rename library packages for SOVERSION bump: 1 => 2.
* Update symbols files for amd64 and i386.
* Build with -DENABLE_VECMATHLIB=ON.
* Upload to experimental.
2018-01-17 - Andreas Beckmann <anbe@debian.org>
pocl (0.14-7) unstable; urgency=medium
* Switch to llvm 4.0.  (Closes: #873417)
* Update symbols files for amd64 and i386.
2018-01-17 - Andreas Beckmann <anbe@debian.org>
pocl (0.14-6) unstable; urgency=medium
* Switch to debhelper compat level 11.
* Bump Standards-Version to 4.1.3, no changes needed.
* Switch Vcs-* to salsa.debian.org.
* Remove superfluous patches.

See Also

Package Description
pod2pdf_0.42-5_all.deb Plain Old Documentation to Portable Document Format converter
podget_0.8.5-1_all.deb Podcast aggregrator/downloader optimized for cron
podracer_1.4-4_all.deb podcast aggregator/downloader
poe.app_0.5.1-5build7_i386.deb Vorbis comment editor
poedit-common_2.0.6-1build1_all.deb Common files for poedit
poedit_2.0.6-1build1_i386.deb gettext catalog editor
pokerth-data_1.1.1-7ubuntu1_all.deb Texas hold'em game - common data files
pokerth-server_1.1.1-7ubuntu1_i386.deb Texas hold'em game - server
pokerth_1.1.1-7ubuntu1_i386.deb Texas hold'em game
polari_3.28.0-1_i386.deb Internet Relay Chat (IRC) client
polenum_0.2-3_all.deb Extracts the password policy from a Windows system
policycoreutils-dbus_2.7-2_all.deb SELinux core policy utilities (D-Bus daemon)
policycoreutils-dev_2.7-2_i386.deb SELinux core policy utilities (development utilities)
policycoreutils-gui_2.7-2_all.deb SELinux core policy utilities (graphical utilities)
policycoreutils-python-utils_2.7-2_all.deb SELinux core policy utilities (Python utilities)
Advertisement
Advertisement