pluma_1.20.1-3ubuntu1_i386.deb


Advertisement

Description

pluma - official text editor of the MATE desktop environment

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename pluma_1.20.1-3ubuntu1_i386.deb
Package name pluma
Package version 1.20.1
Package release 3ubuntu1
Package architecture i386
Package type deb
Category universe/x11
Homepage http://www.mate-desktop.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 366.25 KB
Installed size 1.28 MB
Pluma is a text editor which supports most standard editor features,
extending this basic functionality with other features not usually
found in simple text editors. Pluma is a graphical application which
supports editing multiple text files in one window (known sometimes as
tabs or MDI).
Pluma fully supports international text through its use of the
Unicode UTF-8 encoding in edited files. Its core feature set includes syntax
highlighting of source code, auto indentation and printing and print preview
support.
Pluma is also extensible through its plugin system, which currently
includes support for spell checking, comparing files, viewing CVS
ChangeLogs, and adjusting indentation levels.

Alternatives

Package Version Architecture Repository
pluma_1.20.1-3ubuntu1_amd64.deb 1.20.1 amd64 Ubuntu Universe
pluma - - -

Requires

Name Value
gir1.2-peas-1.0 -
gir1.2-pluma-1.0 = 1.20.1-3ubuntu1
iso-codes -
libatk1.0-0 >= 1.12.4
libc6 >= 2.7
libcairo2 >= 1.2.4
libenchant1c2a >= 1.6.0
libgdk-pixbuf2.0-0 >= 2.22.0
libgirepository-1.0-1 >= 0.9.3
libglib2.0-0 >= 2.37.3
libgtk-3-0 >= 3.21.4
libgtksourceview-3.0-1 >= 2.91.4
libice6 >= 1:1.0.0
libpango-1.0-0 >= 1.14.0
libpeas-1.0-0 >= 1.0.0
libpeas-1.0-python2loader -
libsm6 -
libx11-6 -
libxml2 >= 2.7.4
mate-desktop-common -
pluma-common = 1.20.1-3ubuntu1

Provides

Name Value
mate-text-editor -

Replaces

Name Value
mate-text-editor << 1.5.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pluma_1.20.1-3ubuntu1_i386.deb
Source Package pluma

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pluma deb package:
    # sudo apt-get install pluma

Files

Path
/usr/bin/pluma
/usr/lib/i386-linux-gnu/pluma/plugins/changecase.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/docinfo.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/filebrowser.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/libchangecase.so
/usr/lib/i386-linux-gnu/pluma/plugins/libdocinfo.so
/usr/lib/i386-linux-gnu/pluma/plugins/libfilebrowser.so
/usr/lib/i386-linux-gnu/pluma/plugins/libmodelines.so
/usr/lib/i386-linux-gnu/pluma/plugins/libsort.so
/usr/lib/i386-linux-gnu/pluma/plugins/libspell.so
/usr/lib/i386-linux-gnu/pluma/plugins/libtaglist.so
/usr/lib/i386-linux-gnu/pluma/plugins/libtime.so
/usr/lib/i386-linux-gnu/pluma/plugins/libtrailsave.so
/usr/lib/i386-linux-gnu/pluma/plugins/modelines.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/sort.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/spell.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/taglist.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/time.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/trailsave.plugin
/usr/lib/pluma/pluma-bugreport.sh
/usr/share/applications/pluma.desktop
/usr/share/doc/pluma/changelog.Debian.gz
/usr/share/doc/pluma/copyright
/usr/share/man/man1/pluma.1.gz

Changelog

2018-04-25 - Martin Wimpress <martin.wimpress@ubuntu.com>
pluma (1.20.1-3ubuntu1) bionic; urgency=medium
* debian/patches:
+ Add 0001_disable_python_plugins.patch. Disable Python plugins because
libpeas only supports Python3 and the Python plugins in Pluma only
support Python2. (LP: #1743133) (LP: #1743137)
2018-04-09 - Martin Wimpress <martin.wimpress@ubuntu.com>
pluma (1.20.1-2ubuntu1) bionic; urgency=medium
* debian/control:
+ Add D: libpeas-1.0-python2loader (pluma). (LP: #1743132)
+ Move D: gir1.2-pluma-1.0 from (pluma-dev) to (pluma). (LP: #1723259)
2018-04-05 - Mike Gabriel <sunweaver@debian.org>
pluma (1.20.1-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
[ Mike Gabriel ]
* debian/copyright:
+ Update copyright attributions.
2018-03-22 - Mike Gabriel <sunweaver@debian.org>
pluma (1.20.0-2) unstable; urgency=medium
[ Mike Gabriel ]
* debian/copyright:
+ Use secure URI for copyright format.
[ Martin Wimpress ]
* debian/control:
+ Add D: gir1.2-peas-1.0 (pluma). (LP: #1757333)
2018-02-14 - Mike Gabriel <sunweaver@debian.org>
pluma (1.20.0-1) unstable; urgency=medium
[ Martin Wimpress ]
* debian/copyright (already in 1.19.3-0ubuntu1):
+ Update copyright attributions.
[ Vangelis Mouhtsis ]
* debian/control (already in 1.19.3-0ubuntu1):
+ Temporarily have pkg-mate-team ML under Uploaders:.
+ Update Maintainer: field to debian-mate ML on lists.debian.org.
+ Rename pretty name of our team -> Debian+Ubuntu MATE Packaging Team.
+ Bump Standards-Version: to 4.1.3. No changes needed.
[ Pablo Barciela ]
* debian/patches (already in 1.19.3-0ubuntu1):
+ Add 0000_Fix_list_of_recently_used_files.patch. (Closes: #883866).
[ Mike Gabriel ]
* debian/{control,compat}: Bump DH version level to 11.
* debian/{rules,pluma-common.install}:
+ Move appstream metainfo to correct location.
2018-02-07 - Martin Wimpress <martin.wimpress@ubuntu.com>
pluma (1.20.0-0ubuntu1) bionic; urgency=medium
* New upstream release.
2018-01-24 - Martin Wimpress <martin.wimpress@ubuntu.com>
pluma (1.19.3-0ubuntu1) bionic; urgency=medium
* New upstream release.
2017-11-26 - Mike Gabriel <sunweaver@debian.org>
pluma (1.18.3-2) unstable; urgency=medium
* debian/control:
+ Drop D (pluma) again: python-gtksourceview2. This was a mistake
in the previous upload and a fix only valid for Debian jessie.
2017-11-14 - Mike Gabriel <sunweaver@debian.org>
pluma (1.18.3-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
[ Mike Gabriel ]
* debian/control:
+ Bump Standards-Version: to 4.1.1. No changes needed.
+ Drop now useless B-D: autotools-dev.
+ Add D (pluma): python-gtksourceview2. (Closes: #851854).
* debian/watch: Use secure URI.

See Also

Package Description
plume-creator_0.66+dfsg1-3.1build2_i386.deb open-source tool for novelists
pluxml_5.5-2_all.deb light blog/CMS engine powered by XML
plymouth-disabler_0.1_all.deb disable plymouth by installing .override files
plymouth-theme-breeze_5.12.4-0ubuntu1_i386.deb Breeze theme for Plymouth
plymouth-theme-edubuntu_15.12.1_all.deb Plymouth is an application that runs very early
plymouth-theme-hamara_1.0_all.deb boot animation, logger and I/O multiplexer - Hamara theme
plymouth-theme-kubuntu-logo_18.04ubuntu11_all.deb graphical boot animation and logger - kubuntu-logo theme
plymouth-theme-kubuntu-text_18.04ubuntu11_all.deb graphical boot animation and logger - kubuntu-text theme
plymouth-theme-lubuntu-logo_0.71_all.deb plymouth theme for Lubuntu
plymouth-theme-lubuntu-next-logo_0.71_all.deb plymouth theme for Lubuntu Next
plymouth-theme-lubuntu-next-text_0.71_all.deb plymouth text theme for Lubuntu Next
plymouth-theme-lubuntu-text_0.71_all.deb plymouth text theme for Lubuntu
plymouth-theme-sabily-text_1.3_all.deb plymouth theme for Sabily (text theme)
plymouth-theme-sabily_1.3_all.deb plymouth theme for Sabily (graphical theme)
plymouth-theme-ubuntu-budgie-logo_0.9.6_all.deb graphical boot animation and logger - Ubuntu Budgie logo theme
Advertisement
Advertisement