pkg-kde-tools_0.15.28ubuntu1_all.deb


Advertisement

Description

pkg-kde-tools - various packaging tools and scripts for KDE Applications

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name pkg-kde-tools
Package version 0.15.28ubuntu1
Package architecture all
Package type deb
Installed size 442 B
Download size 93.39 KB
Official Mirror archive.ubuntu.com
This package contains a variety of packaging tools and build scripts that may
be very useful when packaging KDE applications. Even if you are a maintainer
of a very small KDE application, this package should be worthwhile checking
out.
Main highlights:
- recommended build flags for building packages based on the KDE Platform;
- cdbs class for building packages based on the KDE Platform (kde.mk);
- debhelper build system (--buildsystem=kde) and dh addon (--with kde) for
building packages based on the KDE Platform;
- dh_sameversiondep for generating a dependency that is versioned the same
way as a dependency (coming from the same source) of another reference
package.
- dh_movelibkdeinit for moving libkdeinit4_*.so libraries to private
location;
- dh_sodeps (and sodeps dh addon) for generating so:Depends substvar for -dev
packages based to which local packages lib*.so symlinks point to;
- dh_qmlcdeps (and qmlcdeps dh addon) for generating qmlc:Depends substvar
for packages shipping QML cache files.
- pkgkde-symbolshelper tool for efficient management of C and C++ symbol
files;
- pkgkde-debs2symbols tool for generating symbol files and symbol file
patches from pre-built binaries in the deb packages;
- pkgkde-getbuildlogs tool for downloading build logs for the specified
package (from buildd.debian.org);
- pkgkde-override-sc-dev-latest tool for overriding Breaks of the
kde-sc-dev-latest package;
- pkgkde-vcs tool for performing common tasks when packaging under VCS.
NOTE: since this package is cumulative, it does not depend on the packages it
provides helpers for. I.e. you still need to explicitly build depend on
debhelper or cdbs in your packages.

Alternatives

Package Version Architecture Repository
pkg-kde-tools_0.15.28ubuntu2~ubuntu18.04~ppa1_all.deb 0.15.28ubuntu2~ubuntu18.04~ppa1 all Kubuntu Backports
pkg-kde-tools_0.15.28ubuntu2~ubuntu18.04~ppa1_all.deb 0.15.28ubuntu2~ubuntu18.04~ppa1 all Kubuntu Backports
pkg-kde-tools_0.15.28ubuntu1_all.deb 0.15.28ubuntu1 all Ubuntu Universe
pkg-kde-tools - - -

Requires

Name Value
libdpkg-perl >= 1.19.0~
lintian -
perl -
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package pkg-kde-tools_0.15.28ubuntu1_all.deb
Source Package pkg-kde-tools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pkg-kde-tools deb package:
    # sudo apt-get install pkg-kde-tools

Files

Path
/usr/bin/dh_kubuntu_l10n_clean
/usr/bin/dh_kubuntu_l10n_generate
/usr/bin/dh_movelibkdeinit
/usr/bin/dh_qmlcdeps
/usr/bin/dh_sameversiondep
/usr/bin/dh_sodeps
/usr/bin/pkgkde-debs2symbols
/usr/bin/pkgkde-gensymbols
/usr/bin/pkgkde-getbuildlogs
/usr/bin/pkgkde-git
/usr/bin/pkgkde-mark-private-symbols
/usr/bin/pkgkde-mark-qt5-private-symbols
/usr/bin/pkgkde-override-sc-dev-latest
/usr/bin/pkgkde-symbolshelper
/usr/bin/pkgkde-vcs
/usr/lib/kubuntu-l10n/desktop-template-list
/usr/lib/kubuntu-l10n/libexec/createdesktopcontext.pl
/usr/lib/kubuntu-l10n/libexec/extract-messages.sh
/usr/lib/kubuntu-l10n/libexec/extract-xml.sh
/usr/lib/kubuntu-l10n/libexec/extractattr
/usr/lib/kubuntu-l10n/libexec/extractrc
/usr/lib/kubuntu-l10n/libexec/finddesktopfiles
/usr/lib/kubuntu-l10n/libexec/msgsplit
/usr/lib/kubuntu-l10n/libexec/preparetips
/usr/share/doc/pkg-kde-tools/NEWS.Debian.gz
/usr/share/doc/pkg-kde-tools/README.Debian
/usr/share/doc/pkg-kde-tools/README.DebianABIManager
/usr/share/doc/pkg-kde-tools/changelog.gz
/usr/share/doc/pkg-kde-tools/copyright
/usr/share/lintian/overrides/pkg-kde-tools
/usr/share/man/man1/dh_movelibkdeinit.1.gz
/usr/share/man/man1/dh_qmlcdeps.1.gz
/usr/share/man/man1/dh_sameversiondep.1.gz
/usr/share/man/man1/dh_sodeps.1.gz
/usr/share/man/man1/pkgkde-gensymbols.1.gz
/usr/share/man/man1/pkgkde-git.1.gz
/usr/share/man/man1/pkgkde-mark-private-symbols.1.gz
/usr/share/man/man1/pkgkde-mark-qt5-private-symbols.1.gz
/usr/share/man/man1/pkgkde-override-sc-dev-latest.1.gz
/usr/share/man/man1/pkgkde-symbolshelper.1.gz
/usr/share/man/man1/pkgkde-vcs.1.gz
/usr/share/perl5/Debian/PkgKde.pm
/usr/share/perl5/Debian/Debhelper/Buildsystem/kde.pm
/usr/share/perl5/Debian/Debhelper/Buildsystem/kf5.pm
/usr/share/perl5/Debian/Debhelper/Sequence/kde.pm
/usr/share/perl5/Debian/Debhelper/Sequence/kf5.pm
/usr/share/perl5/Debian/Debhelper/Sequence/pkgkde_symbolshelper.pm
/usr/share/perl5/Debian/Debhelper/Sequence/qmlcdeps.pm
/usr/share/perl5/Debian/Debhelper/Sequence/sodeps.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/CompileTest.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Patching.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/String.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Subst.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Substs.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Symbol.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/SymbolFile.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/SymbolFileCollection.pm
/usr/share/perl5/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm
/usr/share/pkg-kde-tools/bin/dpkg-gensymbols
/usr/share/pkg-kde-tools/cmake/DebianABIManager.cmake
/usr/share/pkg-kde-tools/cmake/README.DebianABIManager
/usr/share/pkg-kde-tools/cmake/debabi_verscript.cmake
/usr/share/pkg-kde-tools/cmake/debcontrol2cmake.pl
/usr/share/pkg-kde-tools/lib/kde4_flags
/usr/share/pkg-kde-tools/lib/kf5_flags
/usr/share/pkg-kde-tools/lib/shell_common
/usr/share/pkg-kde-tools/makefiles/1/variables.mk
/usr/share/pkg-kde-tools/makefiles/1/cdbs/kde.mk
/usr/share/pkg-kde-tools/makefiles/1/cdbs/symbolshelper.mk
/usr/share/pkg-kde-tools/qt-kde-team/README
/usr/share/pkg-kde-tools/qt-kde-team/1/debian-qt-kde.mk
/usr/share/pkg-kde-tools/qt-kde-team/1/library-packages.mk
/usr/share/pkg-kde-tools/qt-kde-team/1/policy.mk
/usr/share/pkg-kde-tools/qt-kde-team/1/policy/unstable.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/README
/usr/share/pkg-kde-tools/qt-kde-team/2/commands
/usr/share/pkg-kde-tools/qt-kde-team/2/debian-qt-kde.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/dhmk.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/dhmk.pl
/usr/share/pkg-kde-tools/qt-kde-team/2/l10n-packages.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/library-packages.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/lintian.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/list-missing.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/policy.mk
/usr/share/pkg-kde-tools/qt-kde-team/2/policy/unstable.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/README
/usr/share/pkg-kde-tools/qt-kde-team/3/commands
/usr/share/pkg-kde-tools/qt-kde-team/3/debian-qt-kde.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/dhmk.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/dhmk.pl
/usr/share/pkg-kde-tools/qt-kde-team/3/library-packages.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/lintian.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/list-missing.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/policy.mk
/usr/share/pkg-kde-tools/qt-kde-team/3/policy/unstable.mk
/usr/share/pkg-kde-tools/vcs/git.sh

Changelog

2017-10-26 - Adam Conrad <adconrad@ubuntu.com>
pkg-kde-tools (0.15.28ubuntu1) bionic; urgency=medium
* Merge with current Debian unstable for dpkg 1.19.0 compatibility.
2017-10-17 - Dmitry Shachnev <mitya57@debian.org>
pkg-kde-tools (0.15.28) unstable; urgency=medium
* Bump libdpkg-perl build-dependency too, to make the tests pass.
* Adapt to SymbolFile API changes in libdpkg-perl 1.19.0 (Closes: #878892).
2017-10-17 - Dmitry Shachnev <mitya57@debian.org>
pkg-kde-tools (0.15.27) unstable; urgency=medium
* Adapt SymbolsHelper to debarch_to_cpuattrs() → debarch_to_abiattrs()
renaming in libdpkg-perl 1.19.0.
2017-10-14 - Dmitry Shachnev <mitya57@debian.org>
pkg-kde-tools (0.15.26) unstable; urgency=medium
* Add a new script, dh_qmlcdeps, for generating proper Qt dependencies
for QML compiled data files (Closes: #872325).
* Bump Standards-Version to 4.1.1, no changes needed.
* Fix syntax error in pkgkde-symbolshelper.1 manpage.
2017-09-01 - Simon Quigley <tsimonq2@ubuntu.com>
pkg-kde-tools (0.15.25ubuntu1) artful; urgency=low
* Merge from Debian Sid. Remaining changes:
- Lots of Kubuntu-specific patches to the packaging.
2017-08-30 - Dmitry Shachnev <mitya57@debian.org>
pkg-kde-tools (0.15.25) unstable; urgency=medium
[ Helmut Grohne ]
* Make bit-dependent type substitutions work generically (Closes: #854493).
[ Maximiliano Curia ]
* (l10n-packages.mk) Add missing ast and eo langs
[ Dmitry Shachnev ]
* pkgkde-vcs: Add jessie and stretch to supported distributions (Closes:
#873243). Thanks to Sandro Knauß for the initial patch.
* pkgkde-vcs: Make Git version mangling more close to DEP-14: do not
strip epoch numbers, and replace tildes with underscores.
* Bump Standards-Version to 4.1.0, stop using deprecated Priority: extra.
2017-07-26 - Simon Quigley <tsimonq2@ubuntu.com>
pkg-kde-tools (0.15.24ubuntu3) artful; urgency=medium
* No change rebuild against Qt 5.9.
2017-06-26 - José Manuel Santamaría Lema <panfaust@gmail.com>
pkg-kde-tools (0.15.24ubuntu2) artful; urgency=medium
* Backport changes from qt-kde-team/3/lintian.mk into the KDE 4 version
This aims to backport the changes made in the commit
33e480ee49ad7fc09c22333234862275cc74f57c
authored by Harald whose commit message is:
"ignore when lintian target falls over dead
- genchanges will fail if it can't find a suitable .dsc in ../
- also prevent subsequent fail from cleanup of temporary file"
This change is needed to make kde4libs build properly when running the
autopkgtests using the restiction 'build-needed'
2017-02-02 - José Manuel Santamaría Lema <panfaust@gmail.com>
pkg-kde-tools (0.15.24ubuntu1) zesty; urgency=medium
* Merge with debian
2016-10-19 - Dmitry Shachnev <mitya57@debian.org>
pkg-kde-tools (0.15.24) unstable; urgency=medium
* pkgkde-symbolshelper: Do not pass stderr handle to Dpkg::IPC::spawn,
to workaround #839905 (patch does not print to stderr anyway).
* Add myself to Uploaders.

See Also

Package Description
pkg-mozilla-archive-keyring_1.1_all.deb GnuPG archive keys for the Debian Mozilla team package repository
pkg-perl-autopkgtest_0.42_all.deb collection of autopktest scripts for Perl packages
pkg-perl-tools_0.42_all.deb collection of tools to aid packaging Perl modules in Debian
pkg-r-autopkgtest_20180403_all.deb Script for the automatic testing of R packages
pkgconf_0.9.12-6_i386.deb manage compile and link flags for libraries
pkgdiff_1.7.2-1_all.deb tool for visualizing changes in Linux software packages
pkgme_0.1+bzr114_all.deb framework for generating Debian packaging artifacts
pkgsync_1.26_all.deb automated package list synchronization
pki-base-java_10.6.0-1ubuntu2_all.deb Certificate System - PKI Framework -- java client support
pki-base_10.6.0-1ubuntu2_all.deb Certificate System - PKI Framework
pki-ca_10.6.0-1ubuntu2_all.deb Certificate System - Certificate Authority
pki-console_10.6.0-1ubuntu2_all.deb Certificate System - PKI Console
pki-javadoc_10.6.0-1ubuntu2_all.deb Certificate System - PKI Framework Javadocs
pki-kra_10.6.0-1ubuntu2_all.deb Certificate System - Data Recovery Manager
pki-ocsp_10.6.0-1ubuntu2_all.deb Certificate System - Online Certificate Status Protocol Manager
Advertisement
Advertisement