php-symfony_3.4.6+dfsg-1_all.deb


Advertisement

Description

php-symfony - set of reusable components and framework for web projects

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-symfony_3.4.6+dfsg-1_all.deb
Package name php-symfony
Package version 3.4.6+dfsg
Package release 1
Package architecture all
Package type deb
Category universe/php
Homepage https://symfony.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 45.62 KB
Installed size 91.00 KB
The Symfony PHP framework allows one to create websites and web
applications. It’s a set of tools and a development methodology.
This package depends on every component. Applications depending on
Symfony should rather depend on individual components actually needed
by them.

Alternatives

Package Version Architecture Repository
php-symfony_3.4.6+dfsg-1ubuntu0.1_all.deb 3.4.6+dfsg all Ubuntu Updates Universe
php-symfony_3.4.6+dfsg-1ubuntu0.1_all.deb 3.4.6+dfsg all Ubuntu Updates Universe
php-symfony_3.4.6+dfsg-1_all.deb 3.4.6+dfsg all Ubuntu Universe
php-symfony - - -

Requires

Name Value
php-common -
php-doctrine-common << 3~~
php-doctrine-common >= 2.4
php-fig-link-util >= 1.0
php-fig-link-util << 2~~
php-psr-cache << 2~~
php-psr-cache >= 1.0
php-psr-container << 2~~
php-psr-container >= 1.0
php-psr-link << 2~~
php-psr-link >= 1.0
php-psr-log >= 1.0
php-psr-log << 2~~
php-psr-simple-cache << 2~~
php-psr-simple-cache >= 1.0
php-symfony-asset = 3.4.6+dfsg-1
php-symfony-browser-kit = 3.4.6+dfsg-1
php-symfony-cache = 3.4.6+dfsg-1
php-symfony-class-loader = 3.4.6+dfsg-1
php-symfony-config = 3.4.6+dfsg-1
php-symfony-console = 3.4.6+dfsg-1
php-symfony-css-selector = 3.4.6+dfsg-1
php-symfony-debug = 3.4.6+dfsg-1
php-symfony-debug-bundle = 3.4.6+dfsg-1
php-symfony-dependency-injection = 3.4.6+dfsg-1
php-symfony-doctrine-bridge = 3.4.6+dfsg-1
php-symfony-dom-crawler = 3.4.6+dfsg-1
php-symfony-dotenv = 3.4.6+dfsg-1
php-symfony-event-dispatcher = 3.4.6+dfsg-1
php-symfony-expression-language = 3.4.6+dfsg-1
php-symfony-filesystem = 3.4.6+dfsg-1
php-symfony-finder = 3.4.6+dfsg-1
php-symfony-form = 3.4.6+dfsg-1
php-symfony-framework-bundle = 3.4.6+dfsg-1
php-symfony-http-foundation = 3.4.6+dfsg-1
php-symfony-http-kernel = 3.4.6+dfsg-1
php-symfony-inflector = 3.4.6+dfsg-1
php-symfony-intl = 3.4.6+dfsg-1
php-symfony-ldap = 3.4.6+dfsg-1
php-symfony-lock = 3.4.6+dfsg-1
php-symfony-monolog-bridge = 3.4.6+dfsg-1
php-symfony-options-resolver = 3.4.6+dfsg-1
php-symfony-polyfill-apcu << 2~~
php-symfony-polyfill-apcu >= 1.1
php-symfony-polyfill-intl-icu >= 1.0
php-symfony-polyfill-intl-icu << 2~~
php-symfony-polyfill-mbstring >= 1.0
php-symfony-polyfill-mbstring << 2~~
php-symfony-polyfill-php56 << 2~~
php-symfony-polyfill-php56 >= 1.0
php-symfony-polyfill-php70 >= 1.6
php-symfony-polyfill-php70 << 2~~
php-symfony-process = 3.4.6+dfsg-1
php-symfony-property-access = 3.4.6+dfsg-1
php-symfony-property-info = 3.4.6+dfsg-1
php-symfony-proxy-manager-bridge = 3.4.6+dfsg-1
php-symfony-routing = 3.4.6+dfsg-1
php-symfony-security = 3.4.6+dfsg-1
php-symfony-security-bundle = 3.4.6+dfsg-1
php-symfony-security-core = 3.4.6+dfsg-1
php-symfony-security-csrf = 3.4.6+dfsg-1
php-symfony-security-guard = 3.4.6+dfsg-1
php-symfony-security-http = 3.4.6+dfsg-1
php-symfony-serializer = 3.4.6+dfsg-1
php-symfony-stopwatch = 3.4.6+dfsg-1
php-symfony-templating = 3.4.6+dfsg-1
php-symfony-translation = 3.4.6+dfsg-1
php-symfony-twig-bridge = 3.4.6+dfsg-1
php-symfony-twig-bundle = 3.4.6+dfsg-1
php-symfony-validator = 3.4.6+dfsg-1
php-symfony-var-dumper = 3.4.6+dfsg-1
php-symfony-web-link = 3.4.6+dfsg-1
php-symfony-web-profiler-bundle = 3.4.6+dfsg-1
php-symfony-web-server-bundle = 3.4.6+dfsg-1
php-symfony-workflow = 3.4.6+dfsg-1
php-symfony-yaml = 3.4.6+dfsg-1
php-twig -
php-xml -

Provides

Name Value
php-psr-cache-implementation = 1.0
php-psr-container-implementation = 1.0
php-psr-log-implementation = 1.0
php-psr-simple-cache-implementation = 1.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-symfony_3.4.6+dfsg-1_all.deb
Source Package symfony

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-symfony deb package:
    # sudo apt-get install php-symfony

Files

Path
/usr/share/doc/php-symfony/UPGRADE-3.0.md.gz
/usr/share/doc/php-symfony/UPGRADE-3.1.md.gz
/usr/share/doc/php-symfony/UPGRADE-3.2.md.gz
/usr/share/doc/php-symfony/UPGRADE-3.3.md.gz
/usr/share/doc/php-symfony/UPGRADE-3.4.md.gz
/usr/share/doc/php-symfony/UPGRADE-4.0.md.gz
/usr/share/doc/php-symfony/changelog.Debian.gz
/usr/share/doc/php-symfony/copyright
/usr/share/php/Symfony/autoload.php
/usr/share/php/Symfony/Bundle/FullStack.php

Changelog

2018-03-05 - David Prévot <taffit@debian.org>
symfony (3.4.6+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.6
[ David Prévot ]
* Update dependency overrides
* Blacklist projectservicecontainer for tests
* Make sure to load SymfonyTestsListener
* Move project repository to salsa.d.o
* Update Standards-Version to 4.1.3
* Fix testsuite with native PHP 7.2
2018-01-06 - David Prévot <taffit@debian.org>
symfony (3.4.3+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.3
[ David Prévot ]
* Update versioned dependencies
* Update copyright (years)
2017-12-15 - David Prévot <taffit@debian.org>
symfony (3.4.2+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.2
[ David Prévot ]
* Update homemade autoload.php files for new suggested packages
2017-12-05 - David Prévot <taffit@debian.org>
symfony (3.4.1+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.1
[ David Prévot ]
* Add missing dependency for ci
* Update Standards-Version to 4.1.2
2017-11-30 - David Prévot <taffit@debian.org>
symfony (3.4.0+dfsg-1) unstable; urgency=medium
* Upload stable version to unstable
[ Fabien Potencier ]
* updated VERSION for 3.4.0
2017-11-25 - David Prévot <taffit@debian.org>
symfony (3.4.0~rc2+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.0-RC2
[ David Prévot ]
* Update versioned dependencies
* Build-depend on recent phpunit
* Build-Depend on php-phpdbg for the testsuite
2017-11-23 - David Prévot <taffit@debian.org>
symfony (3.4.0~rc1+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.0-RC1
[ David Prévot ]
* Update dependency overrides
* Update test patches
2017-10-22 - David Prévot <taffit@debian.org>
symfony (3.4.0~beta1+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.0-BETA1
[ Jérémy Derussé ]
* [Lock] Re-add the Lock component in 3.4
[ David Prévot ]
* Stick to version 3
* Update dependencies
* Update homemade autoload.php files
* Update Homepage URLs
* New php-symfony-lock package
* Update images licenses
* Drop more tests currently failing
2017-10-10 - David Prévot <taffit@debian.org>
symfony (3.3.10+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.3.10
[ David Prévot ]
* Update Standards-Version to 4.1.1
* Drop Form test currently failing
2017-09-22 - David Prévot <taffit@debian.org>
symfony (3.3.9+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.3.9
[ David Prévot ]
* Update dependency overrides
* Update homemade autoload.php files
* Update source for new binary packages:
- php-symfony-dotenv
- php-symfony-web-link
- php-symfony-workflow
- php-symfony-web-server-bundle
* Don’t ship new phpunit wrapper
* Update components homepage
* Install (and load) Symfony/Bundle/FullStack.php in php-symfony
* Handle another way to embed SVG for copyright check
* Update debian/licensing/image-checksums.dcf
* Update copyright
* Add new build-dependencies
* Ship Test classes
* Update Standards-Version to 4.1.0
* Update php-symfony-cache description
* Adapt phpunit call
* Add patches to workaround the lack of Composer environment for tests
* Drop more tests currently failing
* Drop README.Debian containing advice about using a now deprecated component

See Also

Package Description
php-tcpdf_6.2.13+dfsg-1ubuntu1_all.deb PHP class for generating PDF files on-the-fly
php-text-captcha_1.0.2-4ubuntu1_all.deb Generation of CAPTCHAs
php-text-figlet_1.0.2-4_all.deb Engine for use FIGlet fonts to rendering text
php-text-languagedetect_0.3.0-2_all.deb Language detection class
php-text-password_1.2.1-2_all.deb Creating passwords with PHP
php-text-template_1.2.1-2_all.deb Simple template engine
php-text-wiki_1.2.1-3_all.deb transform Wiki and BBCode markup into XHTML, LaTeX or plain text markup
php-tideways_4.0.7-1build2_i386.deb Tideways PHP Profiler Extension
php-timer_1.0.9-1_all.deb Utility class for timing
php-token-stream_2.0.2-1ubuntu2_all.deb Wrapper around PHP's tokenizer extension
php-tokenizer_1.1.0-1_all.deb tokenized PHP source to XML converter
php-tokenreflection_1.4.0-3_all.deb PHP reflection replacement
php-twig-doc_2.4.6-1_all.deb Twig template engine documentation
php-twig_2.4.6-1_all.deb Flexible, fast, and secure template engine for PHP
php-uploadprogress_1.0.3.1-4-g95d8a0f-4build2_i386.deb file upload progress tracking extension for PHP
Advertisement
Advertisement