php-symfony-polyfill-util_1.6.0-2_all.deb


Advertisement

Description

php-symfony-polyfill-util - Symfony utilities for portability of PHP codes

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-symfony-polyfill-util_1.6.0-2_all.deb
Package name php-symfony-polyfill-util
Package version 1.6.0
Package release 2
Package architecture all
Package type deb
Category universe/php
Homepage https://symfony.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 5.78 KB
Installed size 26.00 KB
This component provides binary-safe string functions, using the mbstring
extension when available.
The Symfony Polyfill project backports features found in the latest PHP
versions and provides compatibility layers for some extensions and functions.
It is intended to be used when portability across PHP versions and extensions
is desired.
Symfony is a PHP framework, a set of tools and a development methodology.

Alternatives

Package Version Architecture Repository
php-symfony-polyfill-util_1.6.0-2_all.deb 1.6.0 all Ubuntu Universe
php-symfony-polyfill-util - - -

Requires

Name Value
php-common -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-symfony-polyfill-util_1.6.0-2_all.deb
Source Package php-symfony-polyfill

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-symfony-polyfill-util deb package:
    # sudo apt-get install php-symfony-polyfill-util

Files

Path
/usr/share/doc/php-symfony-polyfill-util/changelog.Debian.gz
/usr/share/doc/php-symfony-polyfill-util/copyright
/usr/share/php/Symfony/Polyfill/Util/Binary.php
/usr/share/php/Symfony/Polyfill/Util/BinaryNoFuncOverload.php
/usr/share/php/Symfony/Polyfill/Util/BinaryOnFuncOverload.php
/usr/share/php/Symfony/Polyfill/Util/TestListener.php
/usr/share/php/Symfony/Polyfill/Util/autoload.php

Changelog

2017-12-01 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.6.0-2) unstable; urgency=medium
* Move to namespaced phpunit versions (Closes: 882930)
2017-10-19 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.6.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Add SessionUpdateTimestampHandlerInterface polyfill
[ David Prévot ]
* Update Standards-Version to 4.1.1
2017-09-22 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.5.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Polyfills for mb_chr(), mb_ord() and mb_scrub()
* Allow Symfony 4.0
* Add Php72 polyfill, abandon Xml polyfill
[ Richard Fussenegger ]
* Added PHP_INT_MIN constant
[ David Prévot ]
* Install main README in php-symfony-polyfill
* Update copyright (years)
* Update for new binary packages
- php-symfony-polyfill-php71
- php-symfony-polyfill-php72
* Update Standards-Version to 4.1.0
* Require bootstrap.php at a latter stage
2016-05-19 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.2.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Add CHANGELOG
[ Andreas Lemke ]
* allow paragonie/random_compat 2.0
[ David Prévot ]
* Drop now useless recommendation
* Update Standards-Version to 3.9.8
* Document that two tests are failing with php-apcu-bc
[ Fabien Potencier ]
* bumped version to 1.2
2016-03-12 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.1.1-1) unstable; urgency=medium
[ David Prévot ]
* Fix composer.json syntax
* Update php-symfony-polyfill-intl-icu description
* Trim autoload.php for Apcu (removed Resources/stubs)
* PHP 7.0 transition:
- Depend on php-* instead of php5-*
- Build with recent pkg-php-tools
2016-02-14 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.1.0-1) unstable; urgency=low
* Initial release (new symfony and owncloud dependencies)

See Also

Package Description
php-symfony-polyfill-xml_1.6.0-2_all.deb Symfony polyfill for xml's utf8_encode and utf8_decode functions
php-symfony-polyfill_1.6.0-2_all.deb Symfony polyfills backporting features to lower PHP versions
php-symfony-process_3.4.6+dfsg-1_all.deb execute commands in sub-processes
php-symfony-property-access_3.4.6+dfsg-1_all.deb read from and write to an object or array
php-symfony-property-info_3.4.6+dfsg-1_all.deb extract information about properties of PHP classes
php-symfony-proxy-manager-bridge_3.4.6+dfsg-1_all.deb integration for ProxyManager with Symfony Components
php-symfony-routing_3.4.6+dfsg-1_all.deb associate a request with code that generates a response
php-symfony-security-acl_3.0.1-1_all.deb Symfony Security Component - ACL (Access Control List)
php-symfony-security-bundle_3.4.6+dfsg-1_all.deb configurable security system for the Symfony framework
php-symfony-security-core_3.4.6+dfsg-1_all.deb infrastructure for authorization systems - common features
php-symfony-security-csrf_3.4.6+dfsg-1_all.deb infrastructure for authorization systems - CSRF protection
php-symfony-security-guard_3.4.6+dfsg-1_all.deb infrastructure for authorization systems - Guard features
php-symfony-security-http_3.4.6+dfsg-1_all.deb infrastructure for authorization systems - HTTP integration
php-symfony-security_3.4.6+dfsg-1_all.deb infrastructure for sophisticated authorization systems
php-symfony-serializer_3.4.6+dfsg-1_all.deb convert PHP objects into specific formats and vice versa
Advertisement
Advertisement