php-symfony-polyfill-iconv_1.6.0-2_all.deb


Advertisement

Description

php-symfony-polyfill-iconv - Symfony polyfill for the Iconv extension

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-symfony-polyfill-iconv_1.6.0-2_all.deb
Package name php-symfony-polyfill-iconv
Package version 1.6.0
Package release 2
Package architecture all
Package type deb
Category universe/php
Homepage https://symfony.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 120.59 KB
Installed size 1.51 MB
This component provides a native PHP implementation of the iconv functions
(short of `ob_iconv_handler`).
The Symfony Polyfill project backports features found in the latest PHP
versions and provides compatibility layers for some extensions and functions.
It is intended to be used when portability across PHP versions and extensions
is desired.
Symfony is a PHP framework, a set of tools and a development methodology.

Alternatives

Package Version Architecture Repository
php-symfony-polyfill-iconv_1.6.0-2_all.deb 1.6.0 all Ubuntu Universe
php-symfony-polyfill-iconv - - -

Requires

Name Value
php-common -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-symfony-polyfill-iconv_1.6.0-2_all.deb
Source Package php-symfony-polyfill

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-symfony-polyfill-iconv deb package:
    # sudo apt-get install php-symfony-polyfill-iconv

Files

Path
/usr/share/doc/php-symfony-polyfill-iconv/changelog.Debian.gz
/usr/share/doc/php-symfony-polyfill-iconv/copyright
/usr/share/php/Symfony/Polyfill/Iconv/Iconv.php
/usr/share/php/Symfony/Polyfill/Iconv/autoload.php
/usr/share/php/Symfony/Polyfill/Iconv/bootstrap.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.big5.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp037.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp1006.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp1026.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp424.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp437.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp500.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp737.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp775.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp850.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp852.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp855.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp856.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp857.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp860.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp861.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp862.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp863.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp864.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp865.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp866.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp869.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp874.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp875.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp932.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp936.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp949.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.cp950.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-1.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-10.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-11.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-13.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-14.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-15.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-16.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-2.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-3.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-4.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-5.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-6.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-7.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-8.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.iso-8859-9.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.koi8-r.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.koi8-u.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.us-ascii.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1250.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1251.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1252.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1253.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1254.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1255.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1256.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1257.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/from.windows-1258.php
/usr/share/php/Symfony/Polyfill/Iconv/Resources/charset/translit.php

Changelog

2017-12-01 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.6.0-2) unstable; urgency=medium
* Move to namespaced phpunit versions (Closes: 882930)
2017-10-19 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.6.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Add SessionUpdateTimestampHandlerInterface polyfill
[ David Prévot ]
* Update Standards-Version to 4.1.1
2017-09-22 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.5.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Polyfills for mb_chr(), mb_ord() and mb_scrub()
* Allow Symfony 4.0
* Add Php72 polyfill, abandon Xml polyfill
[ Richard Fussenegger ]
* Added PHP_INT_MIN constant
[ David Prévot ]
* Install main README in php-symfony-polyfill
* Update copyright (years)
* Update for new binary packages
- php-symfony-polyfill-php71
- php-symfony-polyfill-php72
* Update Standards-Version to 4.1.0
* Require bootstrap.php at a latter stage
2016-05-19 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.2.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Add CHANGELOG
[ Andreas Lemke ]
* allow paragonie/random_compat 2.0
[ David Prévot ]
* Drop now useless recommendation
* Update Standards-Version to 3.9.8
* Document that two tests are failing with php-apcu-bc
[ Fabien Potencier ]
* bumped version to 1.2
2016-03-12 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.1.1-1) unstable; urgency=medium
[ David Prévot ]
* Fix composer.json syntax
* Update php-symfony-polyfill-intl-icu description
* Trim autoload.php for Apcu (removed Resources/stubs)
* PHP 7.0 transition:
- Depend on php-* instead of php5-*
- Build with recent pkg-php-tools
2016-02-14 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.1.0-1) unstable; urgency=low
* Initial release (new symfony and owncloud dependencies)

See Also

Package Description
php-symfony-polyfill-intl-grapheme_1.6.0-2_all.deb Symfony polyfill for intl's grapheme_* functions
php-symfony-polyfill-intl-icu_1.6.0-2_all.deb Symfony polyfill for intl's ICU-related data and classes
php-symfony-polyfill-intl-normalizer_1.6.0-2_all.deb Symfony polyfill for intl's Normalizer class and related functions
php-symfony-polyfill-mbstring_1.6.0-2_all.deb Symfony polyfill for the Mbstring extension
php-symfony-polyfill-php54_1.6.0-2_all.deb Symfony polyfill backporting some PHP 5.4+ features to lower PHP versions
php-symfony-polyfill-php55_1.6.0-2_all.deb Symfony polyfill backporting some PHP 5.5+ features to lower PHP versions
php-symfony-polyfill-php56_1.6.0-2_all.deb Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions
php-symfony-polyfill-php70_1.6.0-2_all.deb Symfony polyfill backporting some PHP 7.0+ features to lower PHP versions
php-symfony-polyfill-php71_1.6.0-2_all.deb Symfony polyfill backporting some PHP 7.1+ features to lower PHP versions
php-symfony-polyfill-php72_1.6.0-2_all.deb Symfony polyfill backporting some PHP 7.2+ features to lower PHP versions
php-symfony-polyfill-util_1.6.0-2_all.deb Symfony utilities for portability of PHP codes
php-symfony-polyfill-xml_1.6.0-2_all.deb Symfony polyfill for xml's utf8_encode and utf8_decode functions
php-symfony-polyfill_1.6.0-2_all.deb Symfony polyfills backporting features to lower PHP versions
php-symfony-process_3.4.6+dfsg-1_all.deb execute commands in sub-processes
php-symfony-property-access_3.4.6+dfsg-1_all.deb read from and write to an object or array
Advertisement
Advertisement