php-symfony-phpunit-bridge_3.4.6+dfsg-1_all.deb


Advertisement

Description

php-symfony-phpunit-bridge - integration for PHPUnit with Symfony Components

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-symfony-phpunit-bridge_3.4.6+dfsg-1_all.deb
Package name php-symfony-phpunit-bridge
Package version 3.4.6+dfsg
Package release 1
Package architecture all
Package type deb
Category universe/php
Homepage https://symfony.com/doc/3.4/components/phpunit_bridge.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 20.54 KB
Installed size 116.00 KB
The Symfony PHPUnit Bridge integrates PHPUnit with various
Symfony Components.
PHPUnit is a unit testing suite for the PHP language, modelled on the
xUnit testing framework.
Symfony is a PHP framework, a set of tools and a development methodology.

Alternatives

Package Version Architecture Repository
php-symfony-phpunit-bridge_3.4.6+dfsg-1ubuntu0.1_all.deb 3.4.6+dfsg all Ubuntu Updates Universe
php-symfony-phpunit-bridge_3.4.6+dfsg-1ubuntu0.1_all.deb 3.4.6+dfsg all Ubuntu Updates Universe
php-symfony-phpunit-bridge_3.4.6+dfsg-1_all.deb 3.4.6+dfsg all Ubuntu Universe
php-symfony-phpunit-bridge - - -

Requires

Name Value
php-cli -
php-common -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-symfony-phpunit-bridge_3.4.6+dfsg-1_all.deb
Source Package symfony

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-symfony-phpunit-bridge deb package:
    # sudo apt-get install php-symfony-phpunit-bridge

Files

Path
/usr/share/doc/php-symfony-phpunit-bridge/changelog.Debian.gz
/usr/share/doc/php-symfony-phpunit-bridge/copyright
/usr/share/php/Symfony/Bridge/PhpUnit/ClockMock.php
/usr/share/php/Symfony/Bridge/PhpUnit/CoverageListener.php
/usr/share/php/Symfony/Bridge/PhpUnit/DeprecationErrorHandler.php
/usr/share/php/Symfony/Bridge/PhpUnit/DnsMock.php
/usr/share/php/Symfony/Bridge/PhpUnit/SymfonyTestsListener.php
/usr/share/php/Symfony/Bridge/PhpUnit/autoload.php
/usr/share/php/Symfony/Bridge/PhpUnit/bootstrap.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/Command.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/CoverageListenerForV5.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/CoverageListenerForV6.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/CoverageListenerForV7.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/CoverageListenerTrait.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/SymfonyTestsListenerForV5.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/SymfonyTestsListenerForV6.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/SymfonyTestsListenerForV7.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/SymfonyTestsListenerTrait.php
/usr/share/php/Symfony/Bridge/PhpUnit/Legacy/TestRunner.php
/usr/share/php/Symfony/Bridge/PhpUnit/TextUI/Command.php
/usr/share/php/Symfony/Bridge/PhpUnit/TextUI/TestRunner.php

Changelog

2018-03-05 - David Prévot <taffit@debian.org>
symfony (3.4.6+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.6
[ David Prévot ]
* Update dependency overrides
* Blacklist projectservicecontainer for tests
* Make sure to load SymfonyTestsListener
* Move project repository to salsa.d.o
* Update Standards-Version to 4.1.3
* Fix testsuite with native PHP 7.2
2018-01-06 - David Prévot <taffit@debian.org>
symfony (3.4.3+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.3
[ David Prévot ]
* Update versioned dependencies
* Update copyright (years)
2017-12-15 - David Prévot <taffit@debian.org>
symfony (3.4.2+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.2
[ David Prévot ]
* Update homemade autoload.php files for new suggested packages
2017-12-05 - David Prévot <taffit@debian.org>
symfony (3.4.1+dfsg-1) unstable; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.1
[ David Prévot ]
* Add missing dependency for ci
* Update Standards-Version to 4.1.2
2017-11-30 - David Prévot <taffit@debian.org>
symfony (3.4.0+dfsg-1) unstable; urgency=medium
* Upload stable version to unstable
[ Fabien Potencier ]
* updated VERSION for 3.4.0
2017-11-25 - David Prévot <taffit@debian.org>
symfony (3.4.0~rc2+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.0-RC2
[ David Prévot ]
* Update versioned dependencies
* Build-depend on recent phpunit
* Build-Depend on php-phpdbg for the testsuite
2017-11-23 - David Prévot <taffit@debian.org>
symfony (3.4.0~rc1+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.0-RC1
[ David Prévot ]
* Update dependency overrides
* Update test patches
2017-10-22 - David Prévot <taffit@debian.org>
symfony (3.4.0~beta1+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.4.0-BETA1
[ Jérémy Derussé ]
* [Lock] Re-add the Lock component in 3.4
[ David Prévot ]
* Stick to version 3
* Update dependencies
* Update homemade autoload.php files
* Update Homepage URLs
* New php-symfony-lock package
* Update images licenses
* Drop more tests currently failing
2017-10-10 - David Prévot <taffit@debian.org>
symfony (3.3.10+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.3.10
[ David Prévot ]
* Update Standards-Version to 4.1.1
* Drop Form test currently failing
2017-09-22 - David Prévot <taffit@debian.org>
symfony (3.3.9+dfsg-1) experimental; urgency=medium
[ Fabien Potencier ]
* updated VERSION for 3.3.9
[ David Prévot ]
* Update dependency overrides
* Update homemade autoload.php files
* Update source for new binary packages:
- php-symfony-dotenv
- php-symfony-web-link
- php-symfony-workflow
- php-symfony-web-server-bundle
* Don’t ship new phpunit wrapper
* Update components homepage
* Install (and load) Symfony/Bundle/FullStack.php in php-symfony
* Handle another way to embed SVG for copyright check
* Update debian/licensing/image-checksums.dcf
* Update copyright
* Add new build-dependencies
* Ship Test classes
* Update Standards-Version to 4.1.0
* Update php-symfony-cache description
* Adapt phpunit call
* Add patches to workaround the lack of Composer environment for tests
* Drop more tests currently failing
* Drop README.Debian containing advice about using a now deprecated component

See Also

Package Description
php-symfony-polyfill-apcu_1.6.0-2_all.deb Symfony polyfill backporting apcu_* functions to lower PHP versions
php-symfony-polyfill-iconv_1.6.0-2_all.deb Symfony polyfill for the Iconv extension
php-symfony-polyfill-intl-grapheme_1.6.0-2_all.deb Symfony polyfill for intl's grapheme_* functions
php-symfony-polyfill-intl-icu_1.6.0-2_all.deb Symfony polyfill for intl's ICU-related data and classes
php-symfony-polyfill-intl-normalizer_1.6.0-2_all.deb Symfony polyfill for intl's Normalizer class and related functions
php-symfony-polyfill-mbstring_1.6.0-2_all.deb Symfony polyfill for the Mbstring extension
php-symfony-polyfill-php54_1.6.0-2_all.deb Symfony polyfill backporting some PHP 5.4+ features to lower PHP versions
php-symfony-polyfill-php55_1.6.0-2_all.deb Symfony polyfill backporting some PHP 5.5+ features to lower PHP versions
php-symfony-polyfill-php56_1.6.0-2_all.deb Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions
php-symfony-polyfill-php70_1.6.0-2_all.deb Symfony polyfill backporting some PHP 7.0+ features to lower PHP versions
php-symfony-polyfill-php71_1.6.0-2_all.deb Symfony polyfill backporting some PHP 7.1+ features to lower PHP versions
php-symfony-polyfill-php72_1.6.0-2_all.deb Symfony polyfill backporting some PHP 7.2+ features to lower PHP versions
php-symfony-polyfill-util_1.6.0-2_all.deb Symfony utilities for portability of PHP codes
php-symfony-polyfill-xml_1.6.0-2_all.deb Symfony polyfill for xml's utf8_encode and utf8_decode functions
php-symfony-polyfill_1.6.0-2_all.deb Symfony polyfills backporting features to lower PHP versions
Advertisement
Advertisement